View Issue Details

IDProjectCategoryView StatusLast Update
0000442DarkRadiantMap Editingpublic03.12.2008 21:38
Reportertels Assigned Toorbweaver  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version0.9.5Fixed in Version0.9.5 
Summary0000442: some editor variable descriptions missing
DescriptionSome editor_var, editor_bool etc. definitions from the def files do not show up when you use "Add property":

The attached screenshot shows that the help text for "patrol" for an AI is missing.

Basically, descriptions only show up for the correct classname, but not for any other "class" that you can select in the same dialog.
TagsNo tags attached.

Activities

17.11.2007 17:08

 

editor_var_bug.jpg (38,572 bytes)   
editor_var_bug.jpg (38,572 bytes)   
orbweaver

orbweaver

19.11.2007 14:36

developer   ~0000884

This is working correctly, the "categories" in the Add Property dialog are not populated from the DEF files but from the game.xml. This dates from an older version of the Entity Inspector and these could be removed altogether if they are a cause of confusion to users (although they do allow more property types that the DEF file, such as "entity" properties which always refer to another entity name in the map).
tels

tels

19.11.2007 17:47

developer   ~0000885

This issue isn't really resolved - the descriptions are still missing :)

The entries should be populated correctly (however this is done internally), and not just removed, because they are essential.

Without these entries, it is for instance not possible to set "_color" or any other property on a func_static without doing so manually - and the entire point of the the "Add property" dialog is that you don't have to do it manually, and that you get the "help" in form of a description of the spawnarg variable.
orbweaver

orbweaver

19.11.2007 18:13

developer   ~0000886

I will add a "description" attribute to the XML nodes, and this can be displayed in the text box. These will of course need to be maintained separately, but will be better than no description at all.
orbweaver

orbweaver

25.11.2007 15:23

developer   ~0000889

Fixed in revision 2578.

Issue History

Date Modified Username Field Change
17.11.2007 17:08 tels New Issue
17.11.2007 17:08 tels File Added: editor_var_bug.jpg
17.11.2007 17:09 tels Summary editor variables missing => some editor variables missing
17.11.2007 17:12 tels Summary some editor variables missing => some editor variable descriptions missing
17.11.2007 17:12 tels Description Updated
19.11.2007 14:36 orbweaver Note Added: 0000884
19.11.2007 14:36 orbweaver Status new => resolved
19.11.2007 14:36 orbweaver Resolution open => no change required
19.11.2007 14:36 orbweaver Assigned To => orbweaver
19.11.2007 17:47 tels Note Added: 0000885
19.11.2007 17:47 tels Status resolved => feedback
19.11.2007 17:47 tels Resolution no change required => reopened
19.11.2007 17:48 tels Status feedback => assigned
19.11.2007 17:48 tels Assigned To orbweaver => tels
19.11.2007 17:48 tels Assigned To tels =>
19.11.2007 17:49 tels Assigned To => orbweaver
19.11.2007 18:13 orbweaver Note Added: 0000886
19.11.2007 18:16 orbweaver Target Version => 0.9.5
25.11.2007 15:23 orbweaver Note Added: 0000889
25.11.2007 15:23 orbweaver Status assigned => resolved
25.11.2007 15:23 orbweaver Fixed in Version => 0.9.5
25.11.2007 15:23 orbweaver Resolution reopened => fixed
03.12.2008 21:38 greebo Status resolved => closed