View Issue Details

IDProjectCategoryView StatusLast Update
0004421DarkRadiantCompilation/Buildpublic07.07.2017 18:51
ReporterBaal Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
OSArchlinux 
Product Version2.1.0 
Fixed in Version2.2.0 
Summary0004421: Linux build failure
DescriptionThe build on archlinux fails with the following error message:

"map/RenderableAasFile.cpp: In Elementfunktion »virtual void uap::RenderableAasFile::renderSolid(RenderableCollector&, const VolumeTest&) const«:
map/RenderableAasFile.cpp:45:31: Fehler: falsche Benutzung des unvollständigen Typs »const class VolumeTest«
  Matrix4 invModelView = volume.GetModelview().getFullInverse();"
TagsNo tags attached.

Activities

mhoes

mhoes

23.11.2016 09:58

reporter   ~0008544

I can reproduce this on both Fedora 25 (final) and Arch Linux. (both have gcc 6.2.1, this may or may not be relevant ?).


$ ./autogen.sh
$ ./configure --enable-debug --enable-darkmod-plugins
$ make

<-snip->

  CXX map/darkradiant-MapResourceManager.o
  CXX map/darkradiant-MapFormatManager.o
  CXX map/darkradiant-AasFileManager.o
  CXX map/darkradiant-RenderableAasFile.o
map/RenderableAasFile.cpp: In member function ‘virtual void map::RenderableAasFile::renderSolid(RenderableCollector&, const VolumeTest&) const’:
map/RenderableAasFile.cpp:45:31: error: invalid use of incomplete type ‘const class VolumeTest’
  Matrix4 invModelView = volume.GetModelview().getFullInverse();
                               ^
In file included from map/RenderableAasFile.h:6:0,
                 from map/RenderableAasFile.cpp:1:
../include/irenderable.h:132:7: note: forward declaration of ‘class VolumeTest’
 class VolumeTest;
       ^~~~~~~~~~
Makefile:5467: recipe for target 'map/darkradiant-RenderableAasFile.o' failed
make[2]: *** [map/darkradiant-RenderableAasFile.o] Error 1
make[2]: Leaving directory '/home/maarten/src/darkradiant/radiant'
Makefile:752: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/maarten/src/darkradiant'
Makefile:493: recipe for target 'all' failed
make: *** [all] Error 2
greebo

greebo

25.11.2016 17:14

administrator   ~0008552

Does it fix the issue if you add

#include "ivolumetest.h"

to RenderableAasFile.cpp?
mhoes

mhoes

25.11.2016 17:44

reporter   ~0008553

Hi, this fixes the specific issue for 'RenderableAasFile.cpp' for me personally, both for Fedora 25 and Arch Linux. (Not sure about the original problem reporter though). I do now get a new error on Arch Linux though (but not for Fedora 25, which after the edit completes successfully), not sure if to report it here or to open a new bug report for that ?


Making all in radiant
make[2]: Entering directory '/home/maarten/src/darkradiant/radiant'
  CXX map/darkradiant-RenderableAasFile.o
  CXX clipper/darkradiant-ClipPoint.o
  CXX clipper/darkradiant-Clipper.o
  CXX log/darkradiant-Console.o
  CXX log/darkradiant-LogStream.o
  CXX log/darkradiant-LogWriter.o
  CXX log/darkradiant-COutRedirector.o
  CXX log/darkradiant-StringLogDevice.o
  CXX log/darkradiant-LogStreamBuf.o
  CXX log/darkradiant-LogFile.o
  CXX referencecache/darkradiant-ModelCache.o
  CXX referencecache/darkradiant-NullModel.o
  CXX referencecache/darkradiant-NullModelNode.o
  CXXLD darkradiant
/usr/bin/ld: warning: libwebkitgtk-1.0.so.0, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_document_get_default_view'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_go_back'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_go_forward'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_can_redo'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_frame_get_name'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_html_element_get_inner_text'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_back_forward_list_add_item'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_html_element_get_type'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_policy_decision_ignore'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_new'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_search_text'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_back_forward_list_get_forward_list_with_limit'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_node_append_child'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_back_forward_list_clear'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_delete_selection'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_back_forward_list_get_back_list_with_limit'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_range_clone_contents'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_select_all'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_dom_window_get_selection'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_get_title'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_get_back_forward_list'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_policy_decision_use'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_get_editable'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_set_full_content_zoom'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_data_source_get_data'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_paste_clipboard'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_mark_text_matches'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_back_forward_list_get_current_item'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_has_selection'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_can_copy_clipboard'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_load_uri'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_load_string'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_unmark_text_matches'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_network_request_get_uri'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_get_type'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_redo'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_reload'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_stop_loading'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_can_undo'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_set_highlight_text_matches'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_dom_window_get_type'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_copy_clipboard'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_frame_get_data_source'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_document_get_body'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_dom_selection_remove_all_ranges'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_get_main_frame'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_set_editable'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_get_zoom_level'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_get_dom_document'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_cut_clipboard'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_zoom_in'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_history_item_new_with_data'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_range_get_type'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_zoom_out'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_back_forward_list_set_limit'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_html_element_get_inner_html'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_can_go_forward'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_document_create_element'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_reload_bypass_cache'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_dom_selection_get_type'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_can_cut_clipboard'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_get_full_content_zoom'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_dom_selection_get_range_at'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_history_item_get_uri'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_range_get_text'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_go_to_back_forward_item'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_history_item_get_title'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_dom_document_get_type'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_can_paste_clipboard'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_history_item_get_type'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_frame_print'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_set_zoom_level'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_undo'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_execute_script'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_can_go_back'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_network_request_set_uri'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_view_get_uri'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/libwx_gtk2u_webview-3.0.so: undefined reference to `webkit_web_back_forward_list_get_limit'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:2104: darkradiant] Error 1
make[2]: Leaving directory '/home/maarten/src/darkradiant/radiant'
make[1]: *** [Makefile:752: all-recursive] Error 1
make[1]: Leaving directory '/home/maarten/src/darkradiant'
make: *** [Makefile:493: all] Error 2
mhoes

mhoes

25.11.2016 17:57

reporter   ~0008554

oh. thats seems to be because i hadnt installed a required package on Arch Linux. installing 'webkitgtk2' resolves the error on Arch Linux posted above. After installing that, I get this the error posted below. Might just be a missing package again, but doesnt seem obvious to me now.

Making all in script
make[3]: Entering directory '/home/maarten/src/darkradiant/plugins/script'
  CXX ScriptingSystem.lo
  CXX ScriptCommand.lo
  CXX ScriptModule.lo
  CXX ScriptMenu.lo
  CXX ScriptWindow.lo
  CXX SceneNodeBuffer.lo
  CXX interfaces/DialogInterface.lo
  CXX interfaces/EClassInterface.lo
  CXX interfaces/BrushInterface.lo
  CXX interfaces/RadiantInterface.lo
  CXX interfaces/PatchInterface.lo
  CXX interfaces/SelectionInterface.lo
  CXX interfaces/MapInterface.lo
  CXX interfaces/EntityInterface.lo
  CXX interfaces/MathInterface.lo
  CXX interfaces/ModelInterface.lo
  CXX interfaces/CommandSystemInterface.lo
  CXX interfaces/FileSystemInterface.lo
  CXX interfaces/GridInterface.lo
  CXX interfaces/ShaderSystemInterface.lo
  CXX interfaces/SkinInterface.lo
  CXX interfaces/SelectionSetInterface.lo
  CXX interfaces/SoundInterface.lo
  CXX interfaces/GameInterface.lo
  CXXLD script.la
.libs/ScriptingSystem.o: In function `boost::python::to_python_value<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&>::operator()(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) const':
/usr/include/boost/python/converter/builtin_converters.hpp:158: undefined reference to `PyUnicode_FromStringAndSize'
.libs/ScriptingSystem.o: In function `boost::python::to_python_value<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&>::operator()(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) const':
/usr/include/boost/python/converter/builtin_converters.hpp:158: undefined reference to `PyUnicode_FromStringAndSize'
.libs/ScriptingSystem.o: In function `boost::python::converter::arg_to_python<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > >::arg_to_python(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)':
/usr/include/boost/python/converter/builtin_converters.hpp:158: undefined reference to `PyUnicode_FromStringAndSize'
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:579: script.la] Error 1
make[3]: Leaving directory '/home/maarten/src/darkradiant/plugins/script'
make[2]: *** [Makefile:446: all-recursive] Error 1
make[2]: Leaving directory '/home/maarten/src/darkradiant/plugins'
make[1]: *** [Makefile:752: all-recursive] Error 1
make[1]: Leaving directory '/home/maarten/src/darkradiant'
make: *** [Makefile:493: all] Error 2
greebo

greebo

25.11.2016 18:26

administrator   ~0008555

Your system is probably lacking the python dev package, whatever it's called in Arch.
mhoes

mhoes

26.11.2016 11:52

reporter   ~0008557

I dont think that is it, as Arch does not have -dev packages, they ship headers right with the regular package.

'PyUnicode_FromStringAndSize' seems to be defined here :

$ grep PyUnicode_FromStringAndSize /usr/include/python2.7/unicodeobject.h /usr/include/python3.5m/unicodeobject.h
/usr/include/python2.7/unicodeobject.h:# define PyUnicode_FromStringAndSize PyUnicodeUCS2_FromStringAndSize
/usr/include/python2.7/unicodeobject.h:# define PyUnicode_FromStringAndSize PyUnicodeUCS4_FromStringAndSize
/usr/include/python2.7/unicodeobject.h:PyAPI_FUNC(PyObject*) PyUnicode_FromStringAndSize(
/usr/include/python3.5m/unicodeobject.h: PyUnicode_FromStringAndSize(NULL, size) functions. They become ready
/usr/include/python3.5m/unicodeobject.h:PyAPI_FUNC(PyObject*) PyUnicode_FromStringAndSize(

Perhaps something is wrong with my Arch Linux system.
:(
mhoes

mhoes

27.11.2016 14:47

reporter   ~0008560

I found a way to make the error go away on my Arch Linux system; Hope this helps ?

I ran

$ make SHELL="/bin/bash -x"

to show the exact make commandline that fails. Adding this "-lboost_python3 -lpython3.5m" at the end of the line makes the error go away, so the line now looks like this :

$ cd ./plugins/script

$ g++ -fPIC -DPIC -shared -nostdlib /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/crti.o /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/crtbeginS.o .libs/ScriptingSystem.o .libs/ScriptCommand.o .libs/ScriptModule.o .libs/ScriptMenu.o .libs/ScriptWindow.o .libs/SceneNodeBuffer.o interfaces/.libs/DialogInterface.o interfaces/.libs/EClassInterface.o interfaces/.libs/BrushInterface.o interfaces/.libs/RadiantInterface.o interfaces/.libs/PatchInterface.o interfaces/.libs/SelectionInterface.o interfaces/.libs/MapInterface.o interfaces/.libs/EntityInterface.o interfaces/.libs/MathInterface.o interfaces/.libs/ModelInterface.o interfaces/.libs/CommandSystemInterface.o interfaces/.libs/FileSystemInterface.o interfaces/.libs/GridInterface.o interfaces/.libs/ShaderSystemInterface.o interfaces/.libs/SkinInterface.o interfaces/.libs/SelectionSetInterface.o interfaces/.libs/SoundInterface.o interfaces/.libs/GameInterface.o -Wl,-rpath -Wl,/home/maarten/src/darkradiant/libs/math/.libs -Wl,-rpath -Wl,/home/maarten/src/darkradiant/libs/wxutil/.libs -Wl,-rpath -Wl,/home/maarten/src/darkradiant/libs/xmlutil/.libs -Wl,-rpath -Wl,/home/maarten/src/darkradiant/libs/scene/.libs -Wl,-rpath -Wl,/usr/local/lib/darkradiant -L/home/maarten/src/darkradiant/libs/math/.libs -L/home/maarten/src/darkradiant/libs/xmlutil/.libs -L/home/maarten/src/darkradiant/libs/scene/.libs -lboost_python3 -lpython2.7 -lpthread -ldl -lutil ../../libs/math/.libs/libmath.so ../../libs/wxutil/.libs/libwxutil.so -lGLEW -lwx_gtk2u_gl-3.0 -lwx_gtk2u_stc-3.0 -lwx_gtk2u_xrc-3.0 -lwx_gtk2u_webview-3.0 -lwx_gtk2u_html-3.0 -lwx_gtk2u_qa-3.0 -lwx_gtk2u_adv-3.0 -lwx_gtk2u_core-3.0 -lwx_baseu_xml-3.0 -lwx_baseu_net-3.0 -lwx_baseu-3.0 -lGL -lboost_filesystem -lboost_system -lGLU -lftgl /home/maarten/src/darkradiant/libs/xmlutil/.libs/libxmlutil.so -lxml2 /home/maarten/src/darkradiant/libs/scene/.libs/libscenegraph.so /home/maarten/src/darkradiant/libs/math/.libs/libmath.so -lsigc-2.0 -L/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1 -L/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib -L/lib/../lib -L/usr/lib/../lib -L/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/crtendS.o /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/../../../../lib/crtn.o -g -O0 -pthread -Wl,-z -Wl,defs -pthread -Wl,-soname -Wl,script.so -o .libs/script.so -lboost_python3 -lpython3.5m
mhoes

mhoes

29.11.2016 18:07

reporter  

config.log.archlinux (323,082 bytes)
mhoes

mhoes

29.11.2016 18:08

reporter   ~0008565

Just in case it might provide some insights, ive uploaded the config.log created by ./configure on arch linux.
coldtobi

coldtobi

11.12.2016 09:53

reporter   ~0008610

I see this error also while packaging the new version for Debian.

Patch is as already indicated:

--- a/radiant/map/RenderableAasFile.cpp
+++ b/radiant/map/RenderableAasFile.cpp
@@ -2,6 +2,7 @@
 
 #include "iregistry.h"
 #include "imainframe.h"
+#include "ivolumetest.h"
 
 #include "registry/registry.h"
greebo

greebo

27.12.2016 05:23

administrator   ~0008638

What's the status of this issue, can this be set to resolved?
coldtobi

coldtobi

27.12.2016 06:45

reporter   ~0008639

I guess so, seems to be fixed with commit

15bc435e5db16c19f7761a35a49e0c9e1d8d8934
greebo

greebo

27.12.2016 07:39

administrator   ~0008642

Ok, thanks for the feedback!

Issue History

Date Modified Username Field Change
21.11.2016 13:07 Baal New Issue
21.11.2016 14:51 Baal Description Updated View Revisions
21.11.2016 22:06 Baal OS => Archlinux
23.11.2016 09:58 mhoes Note Added: 0008544
25.11.2016 17:14 greebo Note Added: 0008552
25.11.2016 17:14 greebo Status new => feedback
25.11.2016 17:44 mhoes Note Added: 0008553
25.11.2016 17:57 mhoes Note Added: 0008554
25.11.2016 18:26 greebo Note Added: 0008555
26.11.2016 11:52 mhoes Note Added: 0008557
27.11.2016 14:47 mhoes Note Added: 0008560
29.11.2016 18:07 mhoes File Added: config.log.archlinux
29.11.2016 18:08 mhoes Note Added: 0008565
11.12.2016 09:53 coldtobi Note Added: 0008610
27.12.2016 05:23 greebo Note Added: 0008638
27.12.2016 06:45 coldtobi Note Added: 0008639
27.12.2016 07:39 greebo Note Added: 0008642
27.12.2016 07:39 greebo Status feedback => resolved
27.12.2016 07:39 greebo Fixed in Version => 2.2.0
27.12.2016 07:39 greebo Resolution open => fixed
27.12.2016 07:39 greebo Assigned To => greebo
07.07.2017 18:51 greebo Status resolved => closed