View Issue Details

IDProjectCategoryView StatusLast Update
0004438The Dark ModGraphicspublic07.10.2017 18:13
Reportergrayman Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.03 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004438: Bad lighting with victorian wallpaper
DescriptionThis problem was discovered when playing WS1 with 2.05.

Was okay in 2.02, went bad in 2.03.

Reference: http://forums.thedarkmod.com/topic/18525-beta-testing-205/page-4#entry398463
Additional InformationThe striped and green victorian wallpapers are bad.

The red victorian wallpaper is good.

TagsNo tags attached.

Activities

nbohr1more

nbohr1more

21.09.2017 01:28

developer   ~0009320

textures/darkmod/map_specific/steele/wallpaper_victoian_01
nbohr1more

nbohr1more

21.09.2017 02:39

developer   ~0009321

None of the dev tools show any geometry issues.

Material looks fine.

r_materialOverride to another material shows the lighting is fine.

We are down to the DDS file.

Do you have the original wallpaper_victorian_01.tga ?
grayman

grayman

21.09.2017 10:12

administrator  

grayman

grayman

21.09.2017 10:13

administrator   ~0009322

attached
nbohr1more

nbohr1more

22.09.2017 03:04

developer   ~0009326

TGA does not cure it.

Looking at the map file, there is lots of caulk in association with these textures. Perhaps there is some caulk boundary issue happening here?

Strange that material_override fixes the behavior though.

I tried adding sort decal to the material to see if I could provoke some change.
No luck.

I'll try adding a dummy normal map to see if there is a way to workaround possible corrupt surface normals or boundary issues.
nbohr1more

nbohr1more

26.09.2017 02:21

developer   ~0009350

Normal map doesn't cure it either.

Time to move it to 2.07
grayman

grayman

07.10.2017 17:54

administrator   ~0009415

This situation was caused by bad material management several years ago.

The 5 victorian wallpapers from WS1 were committed to SVN back then, but not done properly. We ended up with the same papers being defined in two different material files.

Duzenko changed the bumpmap definitions in the one file that should never have been committed, and that solved the problem.

Unfortunately, we are forced to keep that file, because we don't know who used the shaders that file defines.

Sad.

Fixed in rev. 15010.
duzenko

duzenko

07.10.2017 18:01

developer   ~0009416

Since no one reported problems in other missions we can assume it was never used?
The "broken" .mtr file itself can be safely deleted because all materials are already elsewhere?
grayman

grayman

07.10.2017 18:13

administrator   ~0009417

Just leave it there for now.

I don't want to delete it, then discover after 2.06 release that we broke a map that sneaked through 2.06 beta w/o being tested.

We can do a detailed investigation once 2.06 is gone, and remove it from 2.07 if the evidence shows the file isn't being used.

Issue History

Date Modified Username Field Change
10.12.2016 18:19 grayman New Issue
10.12.2016 18:20 grayman Description Updated View Revisions
21.09.2017 01:28 nbohr1more Note Added: 0009320
21.09.2017 02:39 nbohr1more Note Added: 0009321
21.09.2017 10:12 grayman File Added: wallpaper_victorian_04.tga
21.09.2017 10:13 grayman Note Added: 0009322
22.09.2017 03:04 nbohr1more Note Added: 0009326
26.09.2017 02:21 nbohr1more Note Added: 0009350
26.09.2017 02:22 nbohr1more Target Version TDM 2.06 => TDM 2.07
07.10.2017 17:54 grayman Note Added: 0009415
07.10.2017 17:54 grayman Assigned To => duzenko
07.10.2017 17:54 grayman Status new => resolved
07.10.2017 17:54 grayman Resolution open => fixed
07.10.2017 17:54 grayman Fixed in Version => TDM 2.06
07.10.2017 17:54 grayman Target Version TDM 2.07 => TDM 2.06
07.10.2017 18:01 duzenko Note Added: 0009416
07.10.2017 18:13 grayman Note Added: 0009417