View Issue Details

IDProjectCategoryView StatusLast Update
0004464DarkRadiantCompilation/Buildpublic22.10.2017 10:30
ReporterEoceneMiacid Assigned Togreebo  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformx64 LinuxOSKubuntu 16.10 
Product Version2.1.0 
Target Version2.2.0Fixed in Version2.2.0 
Summary0004464: Making all in install/i18n fails when gettext binaries are missing
DescriptionAttempting to compile DarkRadiant on my system fails with the following output:

Making all in install/i18n
make[2]: Entering directory '/download/DarkRadiant/install/i18n'
test ! -f ./darkradiant.pot || \
  test -z "de.gmo" || make de.gmo
make[3]: Entering directory '/download/DarkRadiant/install/i18n'
for dir in *; do \
        if test -d ${dir}; then \
                cp ${dir}/LC_MESSAGES/darkradiant.po ${dir}.po; \
        fi; \
done
: --update --lang=de de.po darkradiant.pot
rm -f de.gmo && : -c --statistics --verbose -o de.gmo de.po
mv: cannot stat 't-de.gmo': No such file or directory
Makefile:333: recipe for target 'de.gmo' failed
make[3]: *** [de.gmo] Error 1
make[3]: Leaving directory '/download/DarkRadiant/install/i18n'
Makefile:370: recipe for target 'stamp-po' failed
make[2]: *** [stamp-po] Error 2
make[2]: Leaving directory '/download/DarkRadiant/install/i18n'
Makefile:752: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/download/DarkRadiant'
Makefile:493: recipe for target 'all' failed
make: *** [all] Error 2
Steps To ReproduceClone from GIT - ./autogen.sh > ./configure > make
Additional InformationI reported a similar error (4359) with a prior version before
TagsNo tags attached.

Relationships

duplicate of 0004266 closed Compilation fails on Debian 8 

Activities

greebo

greebo

27.01.2017 14:31

administrator   ~0008720

Hm, I don't get this error in Ubuntu 16.10. What's the difference to Kubuntu 16.10, I wonder?
EoceneMiacid

EoceneMiacid

27.01.2017 16:22

reporter   ~0008721

No idea. I just verified that all dependencies are properly installed, they are. Did a make clean and repeated the steps, same error.

Would it possible to create a .deb?
greebo

greebo

27.01.2017 18:09

administrator   ~0008722

If you can do without the German localisation package, you can just remove the install/i18n folder in the SUBDIRS line in the Makefile.am in the root folder. That should put the .po stuff aside and get it to compile.
EoceneMiacid

EoceneMiacid

27.01.2017 18:36

reporter   ~0008724

That worked. Thanks!
greebo

greebo

27.01.2017 19:15

administrator   ~0008725

Last edited: 27.01.2017 19:18

View 3 revisions

Good to hear that. Can you maybe check whether you have gettext package installed on your system?

After reading this (http://dev.exiv2.org/issues/1099) it seems that there might be something missing, triggering that message.

Maybe also attach the configure.log file here for inspection?

greebo

greebo

28.01.2017 07:20

administrator   ~0008726

Ah, I could reproduce the original issue, it seems this is due to the missing gettext package.
greebo

greebo

28.01.2017 07:29

administrator   ~0008727

The gettext binaries are now checked by the configure.ac script. Fixed in e412fc30fb54020ce6263f63b3a54f04680d2395

In your case, an additional

sudo apt-get install gettext

is needed, then run ./configure again
EoceneMiacid

EoceneMiacid

28.01.2017 10:22

reporter   ~0008728

Thank you for your help, much appreciated.

Issue History

Date Modified Username Field Change
15.01.2017 12:48 EoceneMiacid New Issue
25.01.2017 17:53 greebo Status new => acknowledged
27.01.2017 14:31 greebo Note Added: 0008720
27.01.2017 16:22 EoceneMiacid Note Added: 0008721
27.01.2017 18:09 greebo Note Added: 0008722
27.01.2017 18:36 EoceneMiacid Note Added: 0008724
27.01.2017 19:15 greebo Note Added: 0008725
27.01.2017 19:18 greebo Note Edited: 0008725 View Revisions
27.01.2017 19:18 greebo Note Edited: 0008725 View Revisions
28.01.2017 07:20 greebo Note Added: 0008726
28.01.2017 07:21 greebo Summary Unable to compile => Making all in install/i18n fails when gettext binaries are missing
28.01.2017 07:21 greebo Status acknowledged => confirmed
28.01.2017 07:21 greebo Target Version => 2.2.0
28.01.2017 07:21 greebo Assigned To => greebo
28.01.2017 07:21 greebo Status confirmed => assigned
28.01.2017 07:29 greebo Note Added: 0008727
28.01.2017 07:29 greebo Status assigned => resolved
28.01.2017 07:29 greebo Fixed in Version => 2.2.0
28.01.2017 07:29 greebo Resolution open => fixed
28.01.2017 07:31 greebo Relationship added duplicate of 0004266
28.01.2017 10:22 EoceneMiacid Note Added: 0008728
22.10.2017 10:30 greebo Status resolved => closed