View Issue Details

IDProjectCategoryView StatusLast Update
0004523The Dark ModTweakingpublic27.04.2018 18:18
ReporterAndersonAssigned Tonbohr1more 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindowsOS Version10
Product VersionTDM 2.05 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004523: Romanian Translation fix slated for 2.06
DescriptionI've PM'ed Bikerdude about this and created a thread in the forum related to this matter: http://forums.thedarkmod.com/topic/18828-romanian-gui-issue-request-for-bugtracker/#entry405642

If possible I'd like this planned for 2.06 to deal with it quickly because this translation is only bare bones. It doesn't even contain the proper characters unfortunately as I'm a layman in code and Strawberry.
Steps To ReproduceCheck the GUI and menu in Romanian.
TagsBug, Fix, Glitch, Hotfix, Patch, Romanian, Translation, Tweak

Activities

nbohr1more

nbohr1more

14.12.2017 15:32

developer   ~0009787

Slovak targeted for 2.06 too:

http://forums.thedarkmod.com/topic/17374-slovak-translation-progress-screenshots-etc/#entry415909

user81

14.12.2017 19:14

  ~0009795

Also replied in the above thread asking in Petike had manage to fix the broken fonts.
grayman

grayman

10.01.2018 12:50

administrator   ~0009991

I know Petike is working on Slovak.

If he's not also working on Romanian, who is?
Anderson

Anderson

10.01.2018 13:02

reporter   ~0009992

Last edited: 10.01.2018 13:02

View 2 revisions

I was on Romanian with help from Tels.

grayman

grayman

11.01.2018 14:20

administrator   ~0009995

@Anderson, @NB:

Is there more work to be done on Romanian?
Anderson

Anderson

11.01.2018 14:50

reporter   ~0009996

Last edited: 11.01.2018 14:50

View 2 revisions

At the moment I have done everything within my abilities. The Romanian translation should be fully functional as is.

grayman

grayman

11.01.2018 15:48

administrator   ~0009997

@NB, if you agree, can we close this issue?
Anderson

Anderson

11.01.2018 16:18

reporter   ~0009999

If the latest tdm_base01.pk4 is implemented then yes, it can be closed as far as Romanian is concerned.
nbohr1more

nbohr1more

11.01.2018 18:31

developer   ~0010000

We need to compare your work to the Slovak translation.

Somehow it wasn't fully compliant before.
Anderson

Anderson

11.01.2018 20:07

reporter   ~0010001

What are the standards to comply with, if I may ask?

I coordinated all translation of the GUI, menu, loading tips, inventory description with Tels at the time, as he was the one who started the Internationalisation (I18N) project.
nbohr1more

nbohr1more

11.01.2018 20:48

developer   ~0010002

Just needs to match the strings in all.lang for 2.06

Every time someone adds new words to the GUI, we need matching string values.
Anderson

Anderson

11.01.2018 20:56

reporter   ~0010003

I think it's set properly in the tdm_base01.pk4 linked in the description to Google Drive.

Did the strings in all.lang for 2.06 change?
nbohr1more

nbohr1more

13.01.2018 14:20

developer   ~0010009

"Did the strings in all.lang for 2.06 change?"

2.06 has new Graphic menu options for uncapped FPS, multi-core, and soft shadows.
They will need corresponding translation updates.
grayman

grayman

13.01.2018 15:03

administrator   ~0010010

@NB,

Do we have translators on record for the other languages?

They should be contacted to see if they can translate the new strings.

Is that something you can take care of?
nbohr1more

nbohr1more

13.01.2018 17:38

developer   ~0010011

I will take a look.
I was thinking that Petike was making is Slovak "2.06 ready" so I could just compare that to Anderson's work.
Anderson

Anderson

15.01.2018 13:05

reporter   ~0010013

Last edited: 15.01.2018 13:08

View 2 revisions

How do I get the all.lang file for 2.06? Beta forums are closed to me.

Or you can PM me the words that need translating and I will answer.

Atm busy with real life so doing it myself would take longer. At least for the duration of this winter.

grayman

grayman

15.01.2018 13:10

administrator   ~0010014

I attached the current 2.06 all.lang file.
nbohr1more

nbohr1more

15.01.2018 14:09

developer   ~0010015

2.06 Beta is public:

http://forums.thedarkmod.com/topic/19162-beta-testing-206/
Anderson

Anderson

15.01.2018 15:11

reporter   ~0010019

Thanks!

I will do my best, but I can't guarantee anything at least until February.
Anderson

Anderson

19.01.2018 15:46

reporter   ~0010020

Sorry, messed up the file name on upload but I revised the characters to exclude all broken cedillas and umlauts.

Could you tell me the string numbers for the graphics options you've mentioned?
grayman

grayman

23.01.2018 14:45

administrator   ~0010027

These are the new strings I added for the new graphics features.

They're available starting with yesterday's 2.06 package build.

    // Strings required for new 2.06 features (grayman 0004736)
    "#str_02930" "Player Field of View"
    "#str_02931" "Soft Shadow Quality"
    "#str_02932" "Multi Core Enhancement"
    "#str_02933" "Uncap FPS"
    "#str_02934" "HUD Size/Opacity"

    // Strings for inventory grid
    "#str_02935" "Inventory Grid"

    "#str_02940" "Total:"
    "#str_02941" "Jewels:"
    "#str_02942" "Goods:"
Anderson

Anderson

23.01.2018 15:46

reporter   ~0010031

Can you upload the new file here with these strings here?
Thank you in advance.
grayman

grayman

23.01.2018 15:48

administrator  

all.lang (630,798 bytes)
grayman

grayman

23.01.2018 15:48

administrator   ~0010032

Done
Anderson

Anderson

24.01.2018 07:46

reporter  

all_Romanian.lang (631,248 bytes)
Anderson

Anderson

24.01.2018 07:46

reporter   ~0010037

Also done.
nbohr1more

nbohr1more

25.01.2018 04:37

developer   ~0010040

Rev 15153 Skina's Russian fixes
Rev 15154 Anderson's Romanian fixes
nbohr1more

nbohr1more

25.01.2018 07:19

developer   ~0010041

Rev 15155 more language fixes and Petike the Taffer's Slovak
nbohr1more

nbohr1more

25.01.2018 07:50

developer   ~0010042

15156 Russian Unicode to CP1251 fix
grayman

grayman

14.03.2018 19:12

administrator   ~0010054

Last edited: 14.03.2018 19:12

View 2 revisions

@NB:

I'm trying to get my head around these language changes.

When you submitted Russian, Romanian, and Slovak *.lang files, had you added their strings into all.lang, and then used Tels' program to automatically create the 3 *.lang files?

Or did these guys create free-standing *.lang files and you submitted them as is, w/o transferring their contents to all.lang first, and then using the process?

nbohr1more

nbohr1more

15.03.2018 00:44

developer   ~0010056

Last edited: 15.03.2018 00:45

View 3 revisions

I copied the (specific, eg. just russian, etc) lang data from the all.lang to it's own document then used compare in Notepad++ to see where the all.lang differed from russian.lang (etc) and updated the child lang files to include additional translation strings.

Where there was no translation for some of the new strings, I used google translate then copied the result into an Cyrillic converter and then finally into the child lang file.

All tedious manual work.

The script would be great if it worked instead of creating a sheet of question marks (due to unrecognized characters).

grayman

grayman

15.03.2018 01:03

administrator   ~0010057

Last edited: 15.03.2018 01:05

View 2 revisions

So it looks like we have to remove those three languages from the perl script and instead of creating the individual files automatically, we have to maintain them manually.

Right?

I'll need to do this, revert the 3 individual files I submitted as part of 15157, and add the single missing line (#str_07221) in each of the 3 files that 15157 is adding. It won't be translated, but at least it'll be present.

nbohr1more

nbohr1more

15.03.2018 01:06

developer   ~0010058

Sounds like it. Unless Obsttorte has any better idea.

Thanks.
grayman

grayman

15.03.2018 01:07

administrator   ~0010059

Is it just Russian I need to handle this way?

I don't see the question marks in Romanian or Slovak.
grayman

grayman

15.03.2018 01:09

administrator   ~0010060

You mean if Obs has a better idea along the lines of fixing the perl script?
nbohr1more

nbohr1more

15.03.2018 01:15

developer   ~0010061

I think russian is the biggest problem. Romanian we just need to watch out for those strange "a" characters that keep coming back somehow. (Probably because I just took Anderson's romanian.lang and didn't backport the changes to all.lang.)

Obs seems to know language stuff pretty well. He always gets into the threads.
grayman

grayman

15.03.2018 16:12

administrator   ~0010064

@NB:

I just submitted russian.

Rev 15164.

Can you see if what I did was correct?

I commented the russian section in gen_lang.pl and all.lang, and changed russian.lang by hand.
nbohr1more

nbohr1more

16.03.2018 00:27

developer   ~0010065

Last edited: 16.03.2018 01:53

View 3 revisions

Looks good to me.

At least as good as what I had, except I'm gonna fix a few character issues in Romanian...

Revision 15165

Russian resolution settings fix

Revision 15166

grayman

grayman

16.03.2018 12:49

administrator   ~0010066

Two bad things:

1 - I can't simply comment out the Russian section in all.lang. The syntax inside the section doesn't allow for block comments (/* -> */). I had to delete the entire section to get gen_lang.pl to run.

2 - gen_lang.pl corrupts the romanian.lang and slovak.lang output files.

So we have three languages that can't be handled by the gen_lang.pl program.
grayman

grayman

16.03.2018 12:56

administrator   ~0010067

I started a PM with Obs to see if he can help with the script.
nbohr1more

nbohr1more

27.04.2018 18:18

developer   ~0010405

Rev 15193 should complete the 2.06 work.

Issue History

Date Modified Username Field Change
06.05.2017 19:11 Anderson New Issue
06.05.2017 19:13 Anderson Tag Attached: Bug
06.05.2017 19:13 Anderson Tag Attached: Fix
06.05.2017 19:13 Anderson Tag Attached: Glitch
06.05.2017 19:13 Anderson Tag Attached: Hotfix
06.05.2017 19:13 Anderson Tag Attached: Patch
06.05.2017 19:13 Anderson Tag Attached: Romanian
06.05.2017 19:13 Anderson Tag Attached: Translation
06.05.2017 19:13 Anderson Tag Attached: Tweak
06.10.2017 02:53 nbohr1more Target Version => TDM 2.06
14.12.2017 15:32 nbohr1more Note Added: 0009787
14.12.2017 16:06 nbohr1more Assigned To => nbohr1more
14.12.2017 16:06 nbohr1more Status new => assigned
14.12.2017 19:14 user81 Note Added: 0009795
08.01.2018 21:57 grayman Summary Romanian Translation fix slate for 2.06 => Romanian Translation fix slated for 2.06
10.01.2018 12:50 grayman Note Added: 0009991
10.01.2018 13:02 Anderson Note Added: 0009992
10.01.2018 13:02 Anderson Note Edited: 0009992 View Revisions
11.01.2018 14:20 grayman Note Added: 0009995
11.01.2018 14:50 Anderson Note Added: 0009996
11.01.2018 14:50 Anderson Note Edited: 0009996 View Revisions
11.01.2018 15:48 grayman Note Added: 0009997
11.01.2018 16:18 Anderson Note Added: 0009999
11.01.2018 18:31 nbohr1more Note Added: 0010000
11.01.2018 20:07 Anderson Note Added: 0010001
11.01.2018 20:48 nbohr1more Note Added: 0010002
11.01.2018 20:56 Anderson Note Added: 0010003
13.01.2018 14:20 nbohr1more Note Added: 0010009
13.01.2018 15:03 grayman Note Added: 0010010
13.01.2018 17:38 nbohr1more Note Added: 0010011
15.01.2018 13:05 Anderson Note Added: 0010013
15.01.2018 13:08 Anderson Note Edited: 0010013 View Revisions
15.01.2018 13:10 grayman File Added: all.lang
15.01.2018 13:10 grayman Note Added: 0010014
15.01.2018 14:09 nbohr1more Note Added: 0010015
15.01.2018 15:11 Anderson Note Added: 0010019
19.01.2018 15:44 Anderson File Added: all.lang.lang
19.01.2018 15:46 Anderson Note Added: 0010020
23.01.2018 14:45 grayman Note Added: 0010027
23.01.2018 15:46 Anderson Note Added: 0010031
23.01.2018 15:47 grayman File Deleted: all.lang
23.01.2018 15:47 grayman File Deleted: all.lang.lang
23.01.2018 15:48 grayman File Added: all.lang
23.01.2018 15:48 grayman Note Added: 0010032
24.01.2018 07:46 Anderson File Added: all_Romanian.lang
24.01.2018 07:46 Anderson Note Added: 0010037
25.01.2018 04:37 nbohr1more Note Added: 0010040
25.01.2018 07:19 nbohr1more Note Added: 0010041
25.01.2018 07:50 nbohr1more Note Added: 0010042
14.03.2018 19:12 grayman Note Added: 0010054
14.03.2018 19:12 grayman Note Edited: 0010054 View Revisions
15.03.2018 00:44 nbohr1more Note Added: 0010056
15.03.2018 00:45 nbohr1more Note Edited: 0010056 View Revisions
15.03.2018 00:45 nbohr1more Note Edited: 0010056 View Revisions
15.03.2018 01:03 grayman Note Added: 0010057
15.03.2018 01:05 grayman Note Edited: 0010057 View Revisions
15.03.2018 01:06 nbohr1more Note Added: 0010058
15.03.2018 01:07 grayman Note Added: 0010059
15.03.2018 01:09 grayman Note Added: 0010060
15.03.2018 01:15 nbohr1more Note Added: 0010061
15.03.2018 16:12 grayman Note Added: 0010064
16.03.2018 00:27 nbohr1more Note Added: 0010065
16.03.2018 00:42 nbohr1more Note Edited: 0010065 View Revisions
16.03.2018 01:53 nbohr1more Note Edited: 0010065 View Revisions
16.03.2018 12:49 grayman Note Added: 0010066
16.03.2018 12:56 grayman Note Added: 0010067
27.04.2018 18:18 nbohr1more Note Added: 0010405
27.04.2018 18:18 nbohr1more Status assigned => resolved
27.04.2018 18:18 nbohr1more Resolution open => fixed
27.04.2018 18:18 nbohr1more Fixed in Version => TDM 2.06