View Issue Details

IDProjectCategoryView StatusLast Update
0004556The Dark ModGraphicspublic11.07.2017 14:19
Reporterstgatilov Assigned Toduzenko  
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004556: Weapon icon not rendered + lightgem color does not change
DescriptionSometimes two graphical glitches happen:
1. Lightgem is drawn with dim color, regardless of its real value.
2. Weapon icon is not visible in the lower-left corner.
Usually after some time they "enable back" automatically.
Steps To Reproduce1. Load "Inn Business" mission and start its afresh.
2. After game is started, enable blackjack and lantern, check if they are rendered properly in the bottom of the screen.
3. Exit to menu and click "Restart mission".
4. After game is started, enable blackjack and lantern, check if their icons are rendered properly.

Usually everything is OK when you have just started the mission, but if you restart it, then the issue happens. Also loading a save in fresh TDM causes the issue to happen too.
Note that the tool icon on the right (compass, flahsbombs, etc) renders properly no matter what. Also note that lightgem value is calculated properly: guards immediately notice me if I switch on lantern (but I still see dim lightgem on my screen).
I have no idea when the issue disappears: sometimes it happens almost immediately, sometimes in a minute.

I have reproduced it on MSVC 32-bit and 64-bit and Linux 64-bit.
TagsNo tags attached.

Relationships

related to 0004544 resolvedduzenko Exclude the (multiplayer) network code for now. 

Activities

stgatilov

stgatilov

08.07.2017 07:36

administrator  

BluePill

BluePill

08.07.2017 14:59

reporter   ~0008971

Can confirm this exact issue (MSVC 2013 Release 32/64).
I couldn't reproduce it in some cases but it mostly happened after restarting/loading a savegame in various missions.
I assumed it was because I used the 2.05 assets for the SVN code but that isn't the reason, obviously.
I couldn't find any meaningful output in the logs, though I assume it *might* be related to renderer changes such as the GLSL shaders.
stgatilov

stgatilov

08.07.2017 16:58

administrator  

Darkmod.cfg (11,190 bytes)
duzenko

duzenko

11.07.2017 14:19

developer   ~0008980

Svn rev 7016 should fix this

Issue History

Date Modified Username Field Change
08.07.2017 07:32 stgatilov New Issue
08.07.2017 07:34 stgatilov Steps to Reproduce Updated View Revisions
08.07.2017 07:36 stgatilov File Added: innbiz_2017-07-08_14.22.33.jpg
08.07.2017 14:59 BluePill Note Added: 0008971
08.07.2017 16:58 stgatilov File Added: Darkmod.cfg
11.07.2017 14:04 nbohr1more Relationship added related to 0004544
11.07.2017 14:19 duzenko Note Added: 0008980
11.07.2017 14:19 duzenko Assigned To => duzenko
11.07.2017 14:19 duzenko Status new => assigned
11.07.2017 14:19 duzenko Status assigned => resolved
11.07.2017 14:19 duzenko Fixed in Version => TDM 2.06
11.07.2017 14:19 duzenko Resolution open => fixed