View Issue Details

IDProjectCategoryView StatusLast Update
0004585The Dark ModCodingpublic06.08.2017 11:33
ReporterDasCapschen Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version4.11.9-Arch
Product VersionSVN 
Fixed in VersionTDM 2.06 
Summary0004585: [Linux] Compilation Error due to case sensitivity
DescriptionWhen trying to compile the SVN version of TDM, compilation fails as both framework/File.cpp and framework/FileSystem.cpp try to include "minizip/Unzip.h" and "minizip/Zip.h" but the actual header files do not start with capital letters.
Not a huge deal to fix, but I thought I'd report it so it's fixed in the SVN and perhaps remind the dev team to pay attention to case sensitivity.
Diff included for fix.
TagsNo tags attached.

Activities

DasCapschen

DasCapschen

23.07.2017 13:38

reporter  

case_sensitivity_fix.diff (676 bytes)   
Index: framework/File.cpp
===================================================================
--- framework/File.cpp	(Revision 7044)
+++ framework/File.cpp	(Arbeitskopie)
@@ -18,7 +18,7 @@
 
 
 
-#include "minizip/Unzip.h"
+#include "minizip/unzip.h"
 
 /*
 =================
Index: framework/FileSystem.cpp
===================================================================
--- framework/FileSystem.cpp	(Revision 7044)
+++ framework/FileSystem.cpp	(Arbeitskopie)
@@ -18,9 +18,9 @@
 
 
 
-#include "minizip/Unzip.h"
+#include "minizip/unzip.h"
 //stgatilov: for pk4 repacking
-#include "minizip/Zip.h"
+#include "minizip/zip.h"
 
 #ifdef WIN32
 	#include <io.h>	// for _read
case_sensitivity_fix.diff (676 bytes)   
stgatilov

stgatilov

06.08.2017 11:33

administrator   ~0009056

Thanks for reporting this!
Please don't hesitate to report any issues for Linux build. I wish you had access to latest SVN assets too...

Hopefully fixed in revision 7059.

As for "remind the dev team to pay attention to case sensitivity", I'm afraid it is pretty useless. I think everyone knows that everything must be treated case sensitive, but it is hard to perfectly follow this rule when no one compiles TDM on Linux =(
Due to some reason, these errors do not happen for me in the Linux VM, maybe because the project is located on NTFS shared directory.

Issue History

Date Modified Username Field Change
23.07.2017 13:38 DasCapschen New Issue
23.07.2017 13:38 DasCapschen File Added: case_sensitivity_fix.diff
06.08.2017 11:33 stgatilov Note Added: 0009056
06.08.2017 11:33 stgatilov Assigned To => stgatilov
06.08.2017 11:33 stgatilov Status new => assigned
06.08.2017 11:33 stgatilov Status assigned => resolved
06.08.2017 11:33 stgatilov Fixed in Version => TDM 2.06
06.08.2017 11:33 stgatilov Resolution open => fixed