View Issue Details

IDProjectCategoryView StatusLast Update
0004625The Dark ModCodingpublic27.06.2018 17:41
Reporterduzenko Assigned Tonbohr1more  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004625: Hooded lantern twitches, as well as player model in mirrors.
DescriptionLooks broken and very annoying
Steps To ReproduceApproach any mirror or activate lantern and watch its shadows twitching.
TagsNo tags attached.

Relationships

related to 0004159 resolvedSteveL Shadows cast by lantern start jumping when the player enters water 
related to 0004852 resolvednbohr1more Player lantern pulses when Player is on a ladder 

Activities

nbohr1more

nbohr1more

27.09.2017 12:36

developer   ~0009354

This is happening in noclip mode right?

SteveL implemented a solution in 2.04:

At rev 6534
/trunk/game/Player.cpp
/trunk/game/Player.h
/trunk/game/physics/Physics_Actor.h

At rev 14369
/trunk/script/tdm_ai.script
/trunk/script/tdm_player.script

but it was not extended to noclip.
nbohr1more

nbohr1more

28.09.2017 05:33

developer   ~0009358

Last edited: 28.09.2017 05:48

View 3 revisions

Player.cpp

It looks like this is the equivalent change. :

else if (physicsObj.GetWaterLevel() >= WATERLEVEL_HEAD || noclip)

SetAnimState(ANIMCHANNEL_LEGS, "Legs_Idle", 4);

Probably should remove the duplicate check in the script tdm_player.script

nbohr1more

nbohr1more

28.09.2017 05:55

developer   ~0009359

Fix in rev 7177
duzenko

duzenko

28.09.2017 07:48

developer   ~0009360

Now there is no swimming animation?
Do we have mirrors near swimming areas or simply 3rd person look?
nbohr1more

nbohr1more

28.09.2017 11:44

developer   ~0009362

As far as I know, there is no swim animation so this fix is no worse than 4159.

Still, to future proof it, we can nest:

else if (physicsObj.GetWaterLevel() >= WATERLEVEL_HEAD || noclip)
    {

          //stop flickering noclip animations
           if (noclip)
             {
              SetAnimState(ANIMCHANNEL_LEGS, "Legs_Idle", 4);
               
             }
        

          // No viewbob when fully underwater or in noclip mode, start at beginning of cycle again
        
        bobCycle = 0;
        bobFoot = 0;
        bobfracsin = 0;
    }
nbohr1more

nbohr1more

29.09.2017 00:45

developer   ~0009366

Rev. 7180

Issue History

Date Modified Username Field Change
27.09.2017 08:17 duzenko New Issue
27.09.2017 12:35 nbohr1more Relationship added related to 0004159
27.09.2017 12:36 nbohr1more Note Added: 0009354
28.09.2017 05:33 nbohr1more Note Added: 0009358
28.09.2017 05:41 nbohr1more Note Edited: 0009358 View Revisions
28.09.2017 05:48 nbohr1more Note Edited: 0009358 View Revisions
28.09.2017 05:55 nbohr1more Note Added: 0009359
28.09.2017 05:56 nbohr1more Assigned To => nbohr1more
28.09.2017 05:56 nbohr1more Status new => assigned
28.09.2017 05:56 nbohr1more Resolution open => fixed
28.09.2017 05:56 nbohr1more Fixed in Version => TDM 2.06
28.09.2017 05:56 nbohr1more Status assigned => resolved
28.09.2017 07:48 duzenko Note Added: 0009360
28.09.2017 11:44 nbohr1more Note Added: 0009362
29.09.2017 00:45 nbohr1more Note Added: 0009366
27.06.2018 17:41 nbohr1more Relationship added related to 0004852