View Issue Details

IDProjectCategoryView StatusLast Update
0004632The Dark ModGraphicspublic23.12.2017 08:16
Reporterstgatilov Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
Product VersionTDM 2.06 
Target VersionFixed in VersionTDM 2.06 
Summary0004632: Mirror is black: no reflection (Inn Business)
DescriptionWhen I go to the Innkeeper's room in "Inn Business" mission, the mirror there is completely black.
Previously it showed reflection of the room (including the player).
Steps To Reproduce1. Launch "Inn Business" mission.
2. Run notarget command in console.
3. Enter Inn through front door.
4. After the hall, go to the right.
5. Enter last door to the right in the corridor.
6. Look at the mirror in the corner of the room.
Additional InformationIt seems to not depend on GLSL/FBO and other stuff.
TagsNo tags attached.

Relationships

related to 0004615 resolvedduzenko Remote camera lost when saving\loading 
related to 0004707 resolvedduzenko Wrong reflection in mirror 

Activities

stgatilov

stgatilov

13.10.2017 02:32

developer  

innbiz_2017-10-13_09.28.15.jpg (331,040 bytes)
nbohr1more

nbohr1more

14.10.2017 00:00

developer   ~0009465

Last edited: 14.10.2017 00:01

View 2 revisions

This happened to the mirrors in Caduceus of St Alban due to changes in 4615.
The workaround was to edit the material. textures/washroom/mirror

The workaround was not a complete restoration of functionality as the original mirror had the reflection blended with a darkening mask to make it look old, dirty and primitive (like a 16th century mirror).

I saw another mirror with the same problem in Crystal Grave.

Now, what I don't get is that the reflective transparent puddle patches in Sir Talbot's and Penny Dreadful 2 work just fine even though they also are using a reflection in a blend operation?

duzenko

duzenko

14.10.2017 12:02

developer   ~0009467

Last edited: 14.10.2017 12:03

View 2 revisions

At revision: 15033
Question: I can see mirror.dds in dds\textures\glass but no textures/common/mirror.tga that textures/common/mirror wants to use. Ideas?
There is some tinting on the mirror in this map but I'm not sure where it's coming from

VanishedOne

VanishedOne

14.10.2017 15:05

developer   ~0009476

> Now, what I don't get is that the reflective transparent puddle patches in Sir Talbot's and Penny Dreadful 2 work just fine even though they also are using a reflection in a blend operation?

I haven't seen the workaround version, but in the 2.05 installation I'm looking at, textures/washroom/mirror and textures/common/mirror use the global mirror keyword, whereas textures/darkmod/decals/dirt/puddle uses a mirrorRenderMap stage. Relevant?
nbohr1more

nbohr1more

14.10.2017 16:17

developer   ~0009477

Last edited: 14.10.2017 16:19

View 4 revisions

> Question: I can see mirror.dds in dds\textures\glass but no textures/common/mirror.tga that textures/common/mirror wants to use. Ideas?

The image loader will skip uncompressed images if there is a DDS version available
so that is what you are seeing there. The map says to load an uncompressed texture and Id Tech 4 is saying "nope, we have compression enabled so go get the DDS instead".

Now don't ask me how the code works because I tried to puzzle over it during my early RGTC\LATC experiments and I'm clearly missing some part of the process because it was utterly confusing...
I'm probably missing some trick in the pattern match call or something.

Going back to the original material, it loads the native "mirror" image rather than explicitly calling for a mirrorRender map and it then uses that
as the input for a blend filter operation (needlessly spelled out with the literal GL functions gl_dst_color,gl_zero instead of just using "blend filter" keywords).

VanishedOne

VanishedOne

14.10.2017 16:47

developer   ~0009478

There's no DDS version of textures/common/mirror.* in tdm_textures_base01.pk4. In fact there's no dds/textures/common/* in there at all.

Issue History

Date Modified Username Field Change
13.10.2017 02:31 stgatilov New Issue
13.10.2017 02:31 stgatilov Status new => assigned
13.10.2017 02:31 stgatilov Assigned To => duzenko
13.10.2017 02:32 stgatilov File Added: innbiz_2017-10-13_09.28.15.jpg
13.10.2017 23:56 nbohr1more Relationship added related to 0004615
14.10.2017 00:00 nbohr1more Note Added: 0009465
14.10.2017 00:01 nbohr1more Note Edited: 0009465 View Revisions
14.10.2017 12:02 duzenko Note Added: 0009467
14.10.2017 12:02 duzenko Status assigned => closed
14.10.2017 12:02 duzenko Resolution open => fixed
14.10.2017 12:02 duzenko Fixed in Version => TDM 2.06
14.10.2017 12:03 duzenko Note Edited: 0009467 View Revisions
14.10.2017 15:05 VanishedOne Note Added: 0009476
14.10.2017 16:17 nbohr1more Note Added: 0009477
14.10.2017 16:18 nbohr1more Note Edited: 0009477 View Revisions
14.10.2017 16:18 nbohr1more Note Edited: 0009477 View Revisions
14.10.2017 16:19 nbohr1more Note Edited: 0009477 View Revisions
14.10.2017 16:47 VanishedOne Note Added: 0009478
23.12.2017 08:16 stgatilov Relationship added related to 0004707