View Issue Details

IDProjectCategoryView StatusLast Update
0004649The Dark ModDesign/Codingpublic05.11.2017 00:22
ReporterVanishedOne Assigned To 
PrioritynormalSeveritynormalReproducibilityunable to reproduce
Status closedResolutionunable to reproduce 
Product VersionTDM 2.05 
Summary0004649: Entity that should stay visible culled by spyglass FOV
DescriptionBelow you'll find an in-progress particle definition and a prefab to use it with.

When I use the spyglass to try to get a better view of the topmost part of the fountain, the particles disappear. Since the emitter is at ground level, I suspect the distance from the entity origin causes the particles to be culled.
Steps To Reproduce/*
    Generated by the Particle Editor.
    To use the particle editor, launch the game and type 'editParticles' on the console.
*/
particle fountain_double {
    {
        count 100
        material textures/darkmod/sfx/overcast2
        time 1.500
        cycles 0.000
        bunching 1.000
        distribution cylinder 8.000 8.000 0.000 0.000
        direction cone "90.000"
        orientation aimed 20.000 8.000
        customPath helix 29.000 29.000 0.000 0.000 0.000
        entityColor 1
        speed "0.000"
        size "4.000"
        aspect "1.000"
        randomDistribution 0
        boundsExpansion 0.000
        fadeIn 0.100
        fadeOut 0.250
        fadeIndex 0.000
        color 1.000 1.000 1.000 1.000
        fadeColor 0.000 0.000 0.000 0.000
        offset 0.000 0.000 20.000
        gravity world -1.000
    }
    {
        count 100
        material textures/darkmod/sfx/overcast2
        time 1.500
        cycles 0.000
        bunching 1.000
        distribution cylinder 8.000 8.000 0.000 0.000
        direction cone "90.000"
        orientation aimed 20.000 7.000
        customPath helix 14.000 14.000 0.000 0.000 0.000
        entityColor 1
        speed "0.000"
        size "4.000"
        aspect "1.000"
        randomDistribution 0
        boundsExpansion 0.000
        fadeIn 0.100
        fadeOut 0.250
        fadeIndex 0.000
        color 1.000 1.000 1.000 1.000
        fadeColor 0.000 0.000 0.000 0.000
        offset 0.000 0.000 50.000
        gravity world -1.000
    }
    {
        count 100
        material textures/darkmod/sfx/overcast2
        time 1.500
        cycles 0.000
        bunching 1.000
        distribution sphere 1.000 1.000 1.000
        direction cone "90.000"
        orientation view
        entityColor 1
        speed "150.000"
        size "4.000"
        aspect "1.000"
        randomDistribution 1
        boundsExpansion 0.000
        fadeIn 0.100
        fadeOut 0.250
        fadeIndex 0.000
        color 1.000 1.000 1.000 1.000
        fadeColor 0.000 0.000 0.000 0.000
        offset 0.000 0.000 90.000
        gravity 1.000
    }
}






Version 2
// entity 0
{
"classname" "func_static"
"name" "func_static_10"
"origin" "64 -144 -64.0006"
"rotation" "1 0 0 0 1 0 0 0 1"
"model" "models/darkmod/waterworks/fountain01_3bowls.lwo"
}
// entity 1
{
"classname" "func_emitter"
"name" "func_emitter_9"
"origin" "64 -144 -64"
"cycleTrigger" "0"
"model" "fountain_double.prt"
}
Additional InformationI haven't tried changing bounds expansion on the particles. (The stage I'm trying to examine isn't even very big.)

I've also found that, even without the spyglass involved, sometimes the trailing end of long_banner01.md5mesh will disappear when near the edge of the screen (and lantern_round01.md5mesh can behave similarly, but that's only semi-usable to begin with).
TagsNo tags attached.

Relationships

related to 0004622 new Scenery showing through AI model 

Activities

VanishedOne

VanishedOne

05.11.2017 00:10

developer   ~0009548

Last edited: 05.11.2017 00:20

View 2 revisions

Changed reproducibility to 'sometimes' because I just loaded up TDM again and the particles are now working wherever I stand. Maybe it's related to the fact I was using editParticles to position the particles on the fountain; maybe it's just an unreliable kind of bug.

Edit: still can't reproduce this, so unless it happens again I'm going to put it down to using editParticles and not reloading the map. My note about the banner remains, though.

Issue History

Date Modified Username Field Change
05.11.2017 00:01 VanishedOne New Issue
05.11.2017 00:02 VanishedOne Relationship added related to 0004622
05.11.2017 00:07 VanishedOne Reproducibility always => sometimes
05.11.2017 00:10 VanishedOne Note Added: 0009548
05.11.2017 00:20 VanishedOne Note Edited: 0009548 View Revisions
05.11.2017 00:20 VanishedOne Reproducibility sometimes => unable to reproduce
05.11.2017 00:20 VanishedOne Status new => closed
05.11.2017 00:20 VanishedOne Assigned To => VanishedOne
05.11.2017 00:20 VanishedOne Resolution open => unable to reproduce
05.11.2017 00:22 VanishedOne Assigned To VanishedOne =>