View Issue Details

IDProjectCategoryView StatusLast Update
0004682The Dark ModTexturespublic03.12.2017 14:40
ReporterSpooks Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN 
Fixed in VersionTDM 2.06 
Summary0004682: Painting skins broken in 2.06
DescriptionSome painting skins show pure black in-game. I have compared some skin definitions between 2.05 and 2.06 and they look the same. I suspect the problem might be with the textures.

So far the broken skins I have noticed are:
portrait_fair_maiden
presenting_severed_head

Please be on the lookout for more.
TagsNo tags attached.

Relationships

related to 0003812 closedduzenko idBounds::ToString() returns a pointer to a temporary object that immediately gets destroyed 

Activities

duzenko

duzenko

25.11.2017 09:03

developer   ~0009696

Are those used anywhere? I can't see file or material named portrait_fair_maiden anywhere
Spooks

Spooks

25.11.2017 13:03

reporter   ~0009698

Those are the skin names inside the skin definition files for the decorative wall entities. Regardless, I've done more testing and I couldn't find any difference between the materials, nor the texture locations.

I've narrowed it down to a spawnarg. When you use the aformentioned skin names with the "random_skin" spawnarg, they appear black. They appear fine when used with the "skin" spawnarg. It's not a texture/material/skin problem after all, it seems.

I doubt a lot of FMs use the "random_skin" spawnarg, so I will upload a test map to more easily diagnose the problem.
Spooks

Spooks

25.11.2017 13:05

reporter  

spots.map (7,922 bytes)
duzenko

duzenko

29.11.2017 10:20

developer   ~0009711

I agree it is not specific to any particular skins. The spwanarg parser had a bug that corrupted the skin string.

One unrelated problem with random_skin is that mapper needs to be careful with texture orientation, because e.g. portrait_fair_maiden is in portrait and presenting_severed_head is in landscape.
duzenko

duzenko

29.11.2017 10:22

developer   ~0009712

At revision: 7321
duzenko

duzenko

29.11.2017 10:26

developer   ~0009713

Last edited: 29.11.2017 10:27

View 2 revisions

Original bug info

Revision: 4118
Author: tels
Date: Sunday, 1 August 2010 12:20:00
Message:
implement support for random_skin on entity

Might have only manifested now because of compiler change in 2.06

Springheel

Springheel

03.12.2017 14:40

administrator   ~0009732

There's a "random_skin" spawnarg??

Issue History

Date Modified Username Field Change
24.11.2017 23:34 Spooks New Issue
25.11.2017 09:03 duzenko Note Added: 0009696
25.11.2017 13:03 Spooks Note Added: 0009698
25.11.2017 13:05 Spooks File Added: spots.map
29.11.2017 09:05 duzenko Assigned To => duzenko
29.11.2017 09:05 duzenko Status new => assigned
29.11.2017 10:12 duzenko Relationship added related to 0003812
29.11.2017 10:20 duzenko Note Added: 0009711
29.11.2017 10:22 duzenko Note Added: 0009712
29.11.2017 10:22 duzenko Status assigned => resolved
29.11.2017 10:22 duzenko Fixed in Version => TDM 2.06
29.11.2017 10:22 duzenko Resolution open => fixed
29.11.2017 10:26 duzenko Note Added: 0009713
29.11.2017 10:27 duzenko Note Edited: 0009713 View Revisions
03.12.2017 14:40 Springheel Note Added: 0009732