View Issue Details

IDProjectCategoryView StatusLast Update
0004691The Dark ModAIpublic03.12.2018 17:45
Reportergrayman Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityrandom
Status resolvedResolutionfixed 
Product VersionTDM 2.05 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004691: AI sometimes try to relight a doused overhead light when it's too far off the floor.
DescriptionThe problem is in the 2.05 code for SwitchOnLightState::Init(), at line 338:

if (gameLocal.clip.TracePoint(result, startPoint, bottomPoint, MASK_OPAQUE, NULL))

That NULL should be _goalEnt, causing the trace to ignore the light itself.

Somewhere between there and SwitchOnLightState::Think(), line 592:

idVec3 goalOrigin = _goalEnt->GetPhysics()->GetOrigin();

_goalEnt becomes NULL. Don't know why at this point.

If _goalEnt is too high for the AI to reach, SwitchOnLightState::Think() should never run.

TagsNo tags attached.

Activities

grayman

grayman

04.09.2018 02:35

administrator   ~0010755

Since this was filed so long ago, and I didn't note the original circumstances where the problem was seen, I replicated an overhead light as best I could.

The code worked fine.

I went ahead and made the first change that I noted at the time, and checked for a NULL _goalEnt as the second change.

I'll put this on feedback in case anyone notices a problem before 2.07 gets released, at which point I'll have a better example.
grayman

grayman

04.09.2018 02:40

administrator   ~0010756

Rev 7687:

SwitchOnLightState.cpp
grayman

grayman

03.12.2018 17:41

administrator   ~0010813

Last edited: 03.12.2018 17:45

View 2 revisions

No one's reported anything in 3 months, so I'm calling this resolved.

Issue History

Date Modified Username Field Change
02.12.2017 03:55 grayman New Issue
02.12.2017 03:55 grayman Status new => assigned
02.12.2017 03:55 grayman Assigned To => grayman
04.09.2018 02:35 grayman Note Added: 0010755
04.09.2018 02:40 grayman Note Added: 0010756
04.09.2018 02:40 grayman Status assigned => feedback
04.09.2018 02:40 grayman Resolution open => fixed
04.09.2018 02:40 grayman Fixed in Version => TDM 2.07
03.12.2018 17:41 grayman Note Added: 0010813
03.12.2018 17:41 grayman Status feedback => assigned
03.12.2018 17:41 grayman Status assigned => resolved
03.12.2018 17:45 grayman Note Edited: 0010813 View Revisions