View Issue Details

IDProjectCategoryView StatusLast Update
0004693The Dark ModGraphicspublic21.12.2018 04:01
Reporterstgatilov Assigned Tostgatilov  
PrioritylowSeverityminorReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
Product VersionTDM 2.06 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004693: Soft shadows: some squares of shadow flicker randomly
DescriptionIn some cases shadow starts flickering. You can see random rectangles becoming light/dark alternatively (i.e. they flicker).
The flickering happens even when mouse is not moved. But it does not happen with r_useFBO. When I take screenshot, the squares often dissappear, so the problem is not captured. But not always: sometimes screenshot does not remove the problem.
Steps To ReproduceYou can see the problem in Full Moon Fever map. In the Lord's room (see map: second floor), find a book near the window (see screenshots).

Also, you can load test map "tavern" (dmap tavern + map tavern). The lamp near starting position shows the problem.
TagsNo tags attached.

Relationships

related to 0004425 resolvedduzenko Framebuffer objects for color, depth, stencil 

Activities

stgatilov

stgatilov

07.12.2017 01:45

administrator  

stgatilov

stgatilov

07.12.2017 01:46

administrator  

stgatilov

stgatilov

07.12.2017 01:46

administrator  

stgatilov

stgatilov

07.12.2017 01:47

administrator   ~0009744

Since the issue does not happen with FBO enabled, and soft shadows without FBO are known to be somewhat hacky, and non-FBO version probably gets removed in future versions, I suggest to NOT spend time on the issue.
Just reproduce it, acknowledge, and stop there.
stgatilov

stgatilov

20.12.2017 14:32

administrator   ~0009854

I tried to set "r_shadowPolygonFactor 1", it makes no difference in the tavern map.

The issue happens when I have both "r_useFBO 0" and "r_softShadowsQuality > 0". Even value = 1 is enough. The flickering happens even when everything is completely static (no mouse/keyboard input, no light/object changes).
nbohr1more

nbohr1more

20.12.2017 19:12

developer   ~0009859

As I've observed, these artifacts only happen on noSelfShadows materials.

On r_useFBO, there is no self-shadow to produce the artifact.
stgatilov

stgatilov

23.12.2017 09:20

administrator  

ac1_badshadow.jpg (1,305,357 bytes)
stgatilov

stgatilov

23.12.2017 09:22

administrator   ~0009870

Added one more screenshot ac1_badshadow.jpg from "Accountant 1" mission. This is from the alchemist shop (easily found by its purple color).
The lantern is on, FBO is off, soft shadows is on. There shadow in the middle of the book look like a checkerboard, and additionally it flickers =)

user81

28.03.2018 08:40

  ~0010174

see stgatilov's first note.
Springheel

Springheel

10.05.2018 01:06

administrator   ~0010453

Here is a video demonstrating the problem: http://forums.thedarkmod.com/topic/18982-tdm-206/?p=421382
nbohr1more

nbohr1more

10.05.2018 01:10

developer  

NOFBO206.save (256,791 bytes)
nbohr1more

nbohr1more

10.05.2018 01:12

developer   ~0010454

Last edited: 10.05.2018 01:13

View 2 revisions

Save from Closemouthed Shadows on 2.06 beta rev 7393

NOFBO206.save

Shadow flickers on paper and cup.

nbohr1more

nbohr1more

10.05.2018 01:17

developer  

NOFBOSVN.save (268,454 bytes)
nbohr1more

nbohr1more

10.05.2018 01:18

developer   ~0010455

Save from Closemouthed Shadows on SVN rev 7392

NOFBOSVN.save

Shadow flickers on paper and cup.
nbohr1more

nbohr1more

20.12.2018 16:38

developer   ~0010997

Last edited: 21.12.2018 04:01

View 2 revisions

Cannot reproduce in 2.07 beta.

No flickering shadows in r_useFBO 0 for either r_shadows 1 or 2.

Issue History

Date Modified Username Field Change
07.12.2017 01:45 stgatilov New Issue
07.12.2017 01:45 stgatilov File Added: fever_2017-12-07_00.26.39.jpg
07.12.2017 01:46 stgatilov File Added: fever_2017-12-07_00.26.43.jpg
07.12.2017 01:46 stgatilov File Added: fever_2017-12-07_00.26.45.jpg
07.12.2017 01:47 stgatilov Note Added: 0009744
20.12.2017 14:32 stgatilov Note Added: 0009854
20.12.2017 19:12 nbohr1more Note Added: 0009859
23.12.2017 09:20 stgatilov File Added: ac1_badshadow.jpg
23.12.2017 09:22 stgatilov Note Added: 0009870
26.12.2017 19:03 nbohr1more Relationship added related to 0004425
28.03.2018 08:40 user81 Note Added: 0010174
28.03.2018 08:40 user81 Assigned To => user81
28.03.2018 08:40 user81 Status new => acknowledged
10.05.2018 01:06 Springheel Note Added: 0010453
10.05.2018 01:10 nbohr1more File Added: NOFBO206.save
10.05.2018 01:12 nbohr1more Note Added: 0010454
10.05.2018 01:13 nbohr1more Note Edited: 0010454 View Revisions
10.05.2018 01:17 nbohr1more File Added: NOFBOSVN.save
10.05.2018 01:18 nbohr1more Note Added: 0010455
20.12.2018 16:38 nbohr1more Note Added: 0010997
20.12.2018 16:39 nbohr1more Status acknowledged => suspended
20.12.2018 16:39 nbohr1more Resolution open => suspended
21.12.2018 04:01 nbohr1more Note Edited: 0010997 View Revisions
21.12.2018 04:01 nbohr1more Assigned To user81 => stgatilov
21.12.2018 04:01 nbohr1more Status suspended => resolved
21.12.2018 04:01 nbohr1more Resolution suspended => unable to reproduce
21.12.2018 04:01 nbohr1more Fixed in Version => TDM 2.07
21.12.2018 04:01 nbohr1more Target Version => TDM 2.07