View Issue Details

IDProjectCategoryView StatusLast Update
0004708The Dark ModGraphicspublic31.12.2017 14:08
Reporterstgatilov Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004708: Water: big square blocks on screen when FBO is on
DescriptionJust see the screenshot.
Steps To Reproduce1. "Load Accountant 2" mission
2. Noclip into the void.
3. Now you have to find a small isolated piece of land with a gray dome above it. There is also a screen with cinematic of going through the portal nearby. You can also easily find it if you fly to the ship first, and then turn to the back of the ship and fly into that direction.
4. Go to the land and take a red crystal in its center.
5. Walk to the waterfall and inspect water there.

With "r_useFBO 1" the water is glitchy, with "r_useFBO 0" it is not.
Additional InformationReproduced on the latest 2.06 beta as of now.
TagsNo tags attached.

Relationships

child of 0004425 resolvedduzenko Framebuffer objects for color, depth, stencil 

Activities

stgatilov

stgatilov

23.12.2017 08:59

administrator  

water_blocks.jpg (440,849 bytes)
stgatilov

stgatilov

23.12.2017 09:05

administrator  

Darkmod.cfg (11,967 bytes)
stgatilov

stgatilov

23.12.2017 09:09

administrator  

ac_ONE_bottles.jpg (932,482 bytes)
stgatilov

stgatilov

23.12.2017 09:12

administrator   ~0009869

A very similar issue happens in "Accountant 1" mission in the alchemist shop. You can easily find it with noclipping: it is the only room with purple color.

The bottles look weird and blocky with FBO enabled. Attached a screenshot with lantern lit. It also constantly flickers even if nothing changes.
duzenko

duzenko

23.12.2017 21:13

developer   ~0009874

Last edited: 23.12.2017 21:17

View 3 revisions

It must be a feedback loop in depth buffer.
It should not be a problem in an ideal world because depth is masked at that stage and thus no writes actually occur. Still it happens...
I guess I removed the shared depth cvar too soon but I still hope there is a better solution for this...

The simple workaround is replace heatandhazeWITHDEPTH with heatandhaze on the material level, even though it adds a distortion for player weapon

duzenko

duzenko

28.12.2017 20:41

developer   ~0009914

I might have found it.
New stages (that use custom GPU programs) have their own depth mask setup.
Unless they are explicitly marked "maskDepth" they will actually write to depth buffer -> feedback loop!
duzenko

duzenko

30.12.2017 17:05

developer   ~0009933

I can't see fountain at that place
Screenshot attached
duzenko

duzenko

30.12.2017 17:05

developer  

Untitled.jpg (261,333 bytes)   
Untitled.jpg (261,333 bytes)   
duzenko

duzenko

30.12.2017 17:33

developer   ~0009936

Fixed flask in Acc1
stgatilov

stgatilov

30.12.2017 18:09

administrator   ~0009939

About the fountain: are you sure that you did not misunderstand the directions (in "Steps To Reproduce") ?
Maybe you have particles disabled?

Actually, it is not a fountain, but a waterfall =)
Anyway, the water is blocky everywhere in this mission. If you see no blocks with FBO enabled, I hope the issue is gone.
duzenko

duzenko

30.12.2017 18:48

developer   ~0009940

I was in an area right after crystal teleport. There is a stream, but no waterfall.
r_skipParticles = 0.
duzenko

duzenko

31.12.2017 09:13

developer   ~0009948

Added maskDepth to water_stream

Issue History

Date Modified Username Field Change
23.12.2017 08:59 stgatilov New Issue
23.12.2017 08:59 stgatilov Status new => assigned
23.12.2017 08:59 stgatilov Assigned To => duzenko
23.12.2017 08:59 stgatilov File Added: water_blocks.jpg
23.12.2017 09:05 stgatilov File Added: Darkmod.cfg
23.12.2017 09:06 stgatilov Additional Information Updated View Revisions
23.12.2017 09:09 stgatilov File Added: ac_ONE_bottles.jpg
23.12.2017 09:12 stgatilov Note Added: 0009869
23.12.2017 21:13 duzenko Note Added: 0009874
23.12.2017 21:14 duzenko Note Edited: 0009874 View Revisions
23.12.2017 21:17 duzenko Note Edited: 0009874 View Revisions
26.12.2017 19:00 nbohr1more Relationship added child of 0004425
28.12.2017 20:41 duzenko Note Added: 0009914
30.12.2017 17:05 duzenko Note Added: 0009933
30.12.2017 17:05 duzenko File Added: Untitled.jpg
30.12.2017 17:33 duzenko Note Added: 0009936
30.12.2017 18:09 stgatilov Note Added: 0009939
30.12.2017 18:10 stgatilov Steps to Reproduce Updated View Revisions
30.12.2017 18:48 duzenko Note Added: 0009940
31.12.2017 09:13 duzenko Note Added: 0009948
31.12.2017 09:13 duzenko Status assigned => resolved
31.12.2017 09:13 duzenko Fixed in Version => TDM 2.06
31.12.2017 09:13 duzenko Resolution open => fixed
31.12.2017 14:08 grayman Target Version => TDM 2.06