View Issue Details

IDProjectCategoryView StatusLast Update
0004728The Dark ModCodingpublic22.01.2018 05:34
ReporterSpringheel Assigned Tograyman  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004728: Moving over moss is awkward
Descriptionhttp://forums.thedarkmod.com/topic/19162-beta-testing-206/?p=417410

I feel like moss is worse to step on, lots of little bumps and it feels like I'm almost getting caught on some.

Try doing a crouched creep, walk and run.

I don't think it's as smooth and reliable to jolt past people anymore.

As well, I think the moss has been nerfed a bit, enemies now look towards me when dropping a lot more easily than before if I drop from rafters onto the ground.
Additional InformationThere were changes made in the area of "what the player bumps into while walking" for 2.06, having to do with framerate.

They're probably the reason for loss of "smoothness" when walking over moss.

I suspect that from frame-to-frame, the player (2.05) moved up at a constant rate so that the step felt smooth, but in 2.06, the integral moves up are happening at a different rate due to framerate changes. The framerate _might_ be different frame-to-frame, which means to ascend the moss, the framerate difference have to be taken into account.

We'll see.
TagsNo tags attached.

Activities

Springheel

Springheel

20.01.2018 15:48

administrator   ~0010021

I can confirm crouch-walking across moss feels weird. It is slow and jerky like you're getting stuck on the models. This does not happen in 2.05.
grayman

grayman

22.01.2018 05:20

administrator   ~0010022

Last edited: 22.01.2018 05:34

View 2 revisions

The root cause appears to be the mass of the moss patch.

It's undefined, which causes the code to calculate a mass of 442, which is way too high.

The player thought he was trying to push against something that weighed 442 units, and the math of 2.06 caused forward movement to be jerky.

Setting the mass of the patch to 5 solves the problem, and both the player and AI pass smoothly across the patches left by a moss arrow.

2.05 might not have exhibited this problem because something in the "pushing against" code wasn't as sensitive to high-mass objects as 2.06 is. The moss patch is marked as "mantleable", and changes were made in 2.06 in the mantling code, so maybe that's why 2.05 and 2.06 behaved differently in this instance.

grayman

grayman

22.01.2018 05:23

administrator   ~0010023

Rev. 15148

tdm_weapon_mossarrow.def

Issue History

Date Modified Username Field Change
12.01.2018 21:22 Springheel New Issue
20.01.2018 15:48 Springheel Note Added: 0010021
21.01.2018 18:58 grayman Assigned To => grayman
21.01.2018 18:58 grayman Status new => assigned
21.01.2018 18:58 grayman Additional Information Updated View Revisions
22.01.2018 05:20 grayman Note Added: 0010022
22.01.2018 05:23 grayman Note Added: 0010023
22.01.2018 05:23 grayman Status assigned => resolved
22.01.2018 05:23 grayman Resolution open => fixed
22.01.2018 05:23 grayman Fixed in Version => TDM 2.06
22.01.2018 05:34 grayman Note Edited: 0010022 View Revisions