View Issue Details

IDProjectCategoryView StatusLast Update
0004791DarkRadiantGUIpublic05.09.2021 18:21
ReporterR Soul Assigned Togreebo  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
OSWindows 10 
Product Version2.5.0 
Target Version2.12.0Fixed in Version2.12.0 
Summary0004791: Copy model/entity/prefab paths to clipboard
DescriptionAfter right clicking to select Create Entity, Create Model etc, it would be useful if the following window allowed us to copy the path of the selected item to the clipboard. It would help when asking a question in the forum about a specific thing because we could just paste the full path.

It would also help when creating new ones, because we could quickly search the text file for a similar thing to use as a base.
TagsNo tags attached.

Activities

greebo

greebo

06.05.2018 16:37

administrator   ~0010447

Last edited: 06.05.2018 16:37

It's possible to copy a path from the pickers, but the result would depend on the context.

For models this would refer to the actual path within the mod:

 models/darkmod/decorative/statues/abbey_statue_001.lwo

Whereas for particles it would be the decl name (the one stored in the .prt file, minus the .prt ending):

 tdm_fire_gaslight_glare.prt

Similar for textures or sound shaders, here the def name can be copied:

 textures/darkmod/stone/natural/dark_dirt_smeary
 environmental_sewer_sounds01

One question though: you said "it would also help when creating new ones, because we could quickly search the text file for a similar thing to use as a base." I'm not sure how the path could help with searching?

greebo

greebo

30.01.2021 04:30

administrator   ~0013567

greebo

greebo

30.01.2021 04:32

administrator   ~0013568

Currently implemented for the Media Browser, Model Selector, Prefab Selector, Sound Chooser and Particle Chooser.

Related Changesets

DarkRadiant: master d82c943d

2021-01-30 03:39:01

greebo

Details Diff
0004791: Extend default ResourceTreeView context menu by a "Copy Resource Path" option, defaulting to fullPath, overridable by subclasses. Affected Issues
0004791
mod - include/version.h Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File

DarkRadiant: master dd4b98bf

2021-01-30 03:58:02

greebo

Details Diff
0004791: PopupMenu hides separators at the bottom of the menu Affected Issues
0004791
mod - libs/wxutil/menu/PopupMenu.cpp Diff File

DarkRadiant: master f48acb91

2021-01-30 04:14:34

greebo

Details Diff
0004791: Add another option to let client code decide which column the decl path is located in. Affected Issues
0004791
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File

DarkRadiant: master c96c1406

2021-01-30 04:15:28

greebo

Details Diff
0004791: Implement resource path selection for the ModelTreeView.
Since it is storing the skin paths and model paths in separate columns we need to override the base logic.
Affected Issues
0004791
mod - radiant/ui/modelselector/ModelTreeView.cpp Diff File
mod - radiant/ui/modelselector/ModelTreeView.h Diff File

Issue History

Date Modified Username Field Change
06.05.2018 13:55 R Soul New Issue
06.05.2018 14:02 greebo Status new => acknowledged
06.05.2018 16:37 greebo Note Added: 0010447
06.05.2018 16:37 greebo Note Edited: 0010447
06.05.2018 16:37 greebo Note Edited: 0010447
06.05.2018 16:37 greebo Note Edited: 0010447
31.01.2019 18:12 orbweaver Severity normal => feature
31.01.2019 18:12 orbweaver Summary Feature Request: Copy model/entity/prefab paths to clipboard => Copy model/entity/prefab paths to clipboard
30.01.2021 04:29 greebo Changeset attached => DarkRadiant master d82c943d
30.01.2021 04:29 greebo Changeset attached => DarkRadiant master dd4b98bf
30.01.2021 04:29 greebo Changeset attached => DarkRadiant master f48acb91
30.01.2021 04:29 greebo Changeset attached => DarkRadiant master c96c1406
30.01.2021 04:29 greebo Assigned To => greebo
30.01.2021 04:29 greebo Status acknowledged => assigned
30.01.2021 04:29 greebo Target Version => 2.12.0
30.01.2021 04:30 greebo Status assigned => resolved
30.01.2021 04:30 greebo Resolution open => fixed
30.01.2021 04:30 greebo Fixed in Version => 2.12.0
30.01.2021 04:30 greebo Note Added: 0013567
30.01.2021 04:30 greebo File Added: 2021-01-30 05_29_50-Choose Model.png
30.01.2021 04:32 greebo Note Added: 0013568
05.09.2021 18:21 greebo Status resolved => closed