View Issue Details

IDProjectCategoryView StatusLast Update
0004835The Dark ModCodingpublic26.12.2018 04:13
Reporternbohr1more Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilitysometimes
Status closedResolutionunable to reproduce 
Product VersionTDM 2.06 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004835: Somewhere Above the City: debriefing hangs
Descriptionhttp://forums.thedarkmod.com/topic/11619-vertical-contest-mission-somewhere-above-the-city-by-grayman-aug-20-2010/page-5#entry423270
Steps To ReproduceReplayed the mission now and got a hang at the end of the cinematic debriefing. TDM freezes and stops responding after the priest says "let the builder judge the thief at the day of reckoning". I killed the bad priest and that got mentioned in the debriefing.

Pressing esc to skip the debriefing neither works right at the start of the cinematic nor when it already stopped. TDM just hangs and ALT-Tab does not work.

Windows shows the common not responding dialog when CTRL-ALT-Entfing into task manager and switching back to TDM.
TagsNo tags attached.

Relationships

duplicate of 0004919 resolvedduzenko TDM sometimes crashes after finishing mission 

Activities

nbohr1more

nbohr1more

14.06.2018 07:18

developer   ~0010519

r_cinematic_legacyRoq 1

is the workaround
stgatilov

stgatilov

17.07.2018 16:49

administrator   ~0010690

I have played the mission "in one go" and managed to reproduce it.

In my case the debriefing played fully to the very end. After the second "blessed day, ..." the camera centered on the artifact. Then it simply stopped there without the mission ending. The engine still worked normally: lighting of the scene was constantly changing because of the torches. Exiting to main menu did not work.

However, when I load my savegames and finish mission, the issue does NOT happen: the mission finishes after the camera centers on the artifact and "mission complete" screen is shown.

Anyway, there is no cinematic playing during the debriefing: no ROQ/FFmpeg is involved. There are no ROQ files in mission pk4. The whole debriefing is scripted gameplay. And the cvar "helped" only because the issues does not reproduce so easily.
stgatilov

stgatilov

17.07.2018 17:13

administrator   ~0010691

I tried to reproduce it with fresh game and did not succeed.
stgatilov

stgatilov

29.07.2018 15:12

administrator   ~0010733

Resigning myself: this problem is not related to cinematics/ffmpeg.
grayman

grayman

10.12.2018 16:17

administrator   ~0010856

I just played this mission with both endings, and had no problems.

We should get some 2.07 testers to run this to see if the problem exists for them.

I'll attach my Darkmod.cfg file.
grayman

grayman

10.12.2018 16:18

administrator  

Darkmod.cfg (12,449 bytes)
grayman

grayman

10.12.2018 16:19

administrator   ~0010857

Need someone to confirm this problem during 2.07 beta, if it still exists.
nbohr1more

nbohr1more

18.12.2018 03:36

developer   ~0010959

Still happens for "The Rat's Triumphant".

The affected Roq appears to be the mission complete animation?

Somehow the timing at that phase is thrown off by FFMPEG decoding vs legacy decoding?
nbohr1more

nbohr1more

18.12.2018 03:51

developer   ~0010960

Hmm...

Maybe this is a little fragile:

Objective.h

idStr m_CompletionTarget;

I seem to recall a number of discussions about idStr not properly retaining data...
grayman

grayman

18.12.2018 04:24

administrator   ~0010961

I won’t be looking at this.

Someone else needs to handle it.
nbohr1more

nbohr1more

19.12.2018 04:10

developer   ~0010967

Unable to reproduce on 2.07 beta package.
nbohr1more

nbohr1more

26.12.2018 04:01

developer   ~0011122

Closed as a duplicate of 4919
stgatilov

stgatilov

26.12.2018 04:13

administrator   ~0011125

I am not sure that it is duplicate: it does not crash at least.
I changed resolution to "Unable to reproduce", since that's how the things actually are (for a rather long time).

Issue History

Date Modified Username Field Change
14.06.2018 07:15 nbohr1more New Issue
14.06.2018 07:15 nbohr1more Status new => assigned
14.06.2018 07:15 nbohr1more Assigned To => stgatilov
14.06.2018 07:16 nbohr1more Relationship added related to 0004507
14.06.2018 07:18 nbohr1more Note Added: 0010519
17.07.2018 16:49 stgatilov Note Added: 0010690
17.07.2018 16:49 stgatilov Relationship deleted related to 0004507
17.07.2018 16:50 stgatilov Summary FFMPEG ROQ decoding causes debriefing to hang in "Somewhere Above the City" => Somewhere Above the City: debriefing hangs
17.07.2018 16:50 stgatilov Description Updated View Revisions
17.07.2018 17:13 stgatilov Note Added: 0010691
29.07.2018 15:12 stgatilov Note Added: 0010733
29.07.2018 15:12 stgatilov Status assigned => confirmed
29.07.2018 15:12 stgatilov Assigned To stgatilov =>
29.07.2018 15:13 stgatilov Category Graphics => Coding
10.12.2018 16:17 grayman Note Added: 0010856
10.12.2018 16:18 grayman File Added: Darkmod.cfg
10.12.2018 16:19 grayman Note Added: 0010857
10.12.2018 16:19 grayman Assigned To => grayman
10.12.2018 16:19 grayman Status confirmed => feedback
18.12.2018 03:36 nbohr1more Note Added: 0010959
18.12.2018 03:36 nbohr1more Status feedback => assigned
18.12.2018 03:51 nbohr1more Note Added: 0010960
18.12.2018 04:23 grayman Assigned To grayman =>
18.12.2018 04:24 grayman Note Added: 0010961
19.12.2018 04:10 nbohr1more Note Added: 0010967
19.12.2018 04:11 nbohr1more Status assigned => feedback
19.12.2018 04:53 stgatilov Relationship added related to 0004919
26.12.2018 04:00 nbohr1more Assigned To => stgatilov
26.12.2018 04:00 nbohr1more Status feedback => closed
26.12.2018 04:00 nbohr1more Resolution open => duplicate
26.12.2018 04:00 nbohr1more Fixed in Version => TDM 2.07
26.12.2018 04:00 nbohr1more Relationship deleted related to 0004919
26.12.2018 04:01 nbohr1more Relationship added duplicate of 0004919
26.12.2018 04:01 nbohr1more Note Added: 0011122
26.12.2018 04:12 stgatilov Resolution duplicate => unable to reproduce
26.12.2018 04:13 stgatilov Note Added: 0011125