View Issue Details

IDProjectCategoryView StatusLast Update
0004839The Dark ModCodingpublic05.12.2019 09:02
ReporterSpringheel Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0004839: Sword animation can get stuck on screen.
DescriptionThis has been reported by two players so far.

"Sword stuck when trying to hit a rat and freezed in a position prepared to swing. Changing to different weapon or sheathing the sword did not help."

"I can reproduce this when swinging the sword a dozen times in the Training Mission."
TagsNo tags attached.




18.06.2018 04:25

administrator   ~0010536

I tried to reproduce it but failed.
On the other hand, I remember seeing such problem during 2.06 development.


20.06.2018 12:13

reporter   ~0010542

I used a low-end PC with experimental settings on such as Uncap FPS and Multicore Enhancements. These problems persist in every FM.


01.07.2018 16:49

developer   ~0010634

Please retest this with the binaries from the VBO Beta:

which include the fix for 4853


01.07.2018 18:17

administrator   ~0010636

I don't think that fix of 0004853 could influence this. But I don't know why sword gets stuck =)

I hope that someone from the team can reproduce it.


11.12.2018 05:22

developer   ~0010874

No recent reports, moving to 2.08


01.01.2019 06:57

administrator   ~0011200

I can reproduce it relatively well on Arena FM.
1) Launch Arena FM.
2) Execute "god" in console.
3) Go to monster-spawning room and spawn 20-30 monsters.
4) Jump down to monsters and kill them with your sword.

Sometimes sword gets stuck on the side. Trying to attack more times does not help. Changing weapon does not help (it changes in GUI, but no affect on game). Hitting Escape a few times to go to menu and back does not help.
The plan above allows me to reproduce it in about half of times =(

Note that I got stuck sword with "com_fixedTic 1". I disabled it and tried for two more times and did not get stuck sword. It is quite likely that this is sword swinging code being non-tolerant to tick variation.


09.02.2019 12:02

reporter   ~0011554

Last edited: 09.02.2019 17:06

View 4 revisions

Catched another instance of this bug on "The Outpost", by trying to reproduce it.
Trying to select other weapons influences visibility on the lightgem but the sword is still stuck.

Even saved it in a save file to see how the bug looks when triggered.
Link for these files on OneDrive:!AvGDCLNzgVKKhMIWEjCN-D7d6buGRg



05.12.2019 08:57

administrator   ~0011891

Seemingly fixed by svn rev 8435.
See related issue 0004924

Issue History

Date Modified Username Field Change
17.06.2018 13:25 Springheel New Issue
18.06.2018 04:25 stgatilov Note Added: 0010536
20.06.2018 12:13 Anderson Note Added: 0010542
01.07.2018 16:49 nbohr1more Note Added: 0010634
01.07.2018 16:53 nbohr1more Status new => feedback
01.07.2018 18:17 stgatilov Note Added: 0010636
11.12.2018 05:22 nbohr1more Note Added: 0010874
11.12.2018 05:23 nbohr1more Target Version TDM 2.07 => TDM 2.08
01.01.2019 06:57 stgatilov Note Added: 0011200
01.01.2019 06:57 stgatilov Assigned To => stgatilov
01.01.2019 06:57 stgatilov Status feedback => confirmed
09.02.2019 12:02 Anderson Note Added: 0011554
09.02.2019 12:02 Anderson Note Edited: 0011554 View Revisions
09.02.2019 12:20 Anderson Note Edited: 0011554 View Revisions
09.02.2019 17:06 Anderson Note Edited: 0011554 View Revisions
05.12.2019 08:57 stgatilov Note Added: 0011891
05.12.2019 09:02 stgatilov Status confirmed => resolved
05.12.2019 09:02 stgatilov Resolution open => fixed
05.12.2019 09:02 stgatilov Fixed in Version => TDM 2.08