View Issue Details

IDProjectCategoryView StatusLast Update
0004849The Dark ModGraphicspublic21.07.2018 19:48
Reporterstgatilov Assigned Tocabalistic  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004849: Replace VBO implementation with the one similar to D3BFG
DescriptionVanilla Doom 3 has inefficient usage of Vertex Buffer Objects (VBO).
The idea is to reimplement them using an approach similar to the one used in Doom 3 BFG.
Additional InformationThe VBO replacement megathread:
  http://forums.thedarkmod.com/topic/19257-testers-and-reviewers-wanted-bfg-style-vertex-cache/

Old discussion (devs only):
  http://forums.thedarkmod.com/topic/18951-vertex-data-tangents-calculation-and-upload/
TagsNo tags attached.

Relationships

related to 0003234 resolvedduzenko Merge Mh's Optimized VBO Code 
child of 0003684 new Investigate GPL Renderer Improvements 

Activities

stgatilov

stgatilov

28.06.2018 17:29

administrator   ~0010608

Last edited: 18.07.2018 01:44

View 2 revisions

A pack of issues which bother me:
1. Warnings "RB_T_RenderShaderPasses: !tri->ambientCache", accompanied by all objects (including guards) disappearing for a moment.
2. If you start Inn Business mission, you will notice a few freezes because of VBO doubling when you turn camera around immediately after start.

UPDATE: The second issue is not critical, but the guards glitching due to the first point must be fixed somehow...

nbohr1more

nbohr1more

21.07.2018 19:47

developer   ~0010716

Rev 7585 fixes the last remaining issue.

Issue History

Date Modified Username Field Change
25.06.2018 05:52 stgatilov New Issue
25.06.2018 05:52 stgatilov Status new => assigned
25.06.2018 05:52 stgatilov Assigned To => cabalistic
25.06.2018 05:52 stgatilov Relationship added related to 0003234
28.06.2018 17:29 stgatilov Note Added: 0010608
17.07.2018 21:44 nbohr1more Relationship added child of 0003684
18.07.2018 01:44 stgatilov Note Edited: 0010608 View Revisions
21.07.2018 19:47 nbohr1more Note Added: 0010716
21.07.2018 19:48 nbohr1more Status assigned => resolved
21.07.2018 19:48 nbohr1more Resolution open => fixed
21.07.2018 19:48 nbohr1more Fixed in Version => TDM 2.07