View Issue Details

IDProjectCategoryView StatusLast Update
0004851The Dark ModGraphicspublic01.09.2018 16:12
Reporterstgatilov Assigned Tocabalistic  
PrioritynormalSeveritynormalReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004851: Soft shadows with multisampling produces sparklies near wall edges
DescriptionIf you enable both soft shadows and antialiasing (which is done by multisamples FBOs now), then you can see sort of "sparklies" artifact in some walls.
Steps To Reproduce1. Enable antialiasing and soft shadows.
2. Start Saint Lucia mission.
3. Fly to the big hall with many benches (chapel?).

Look at the walls which are in shadow, especially at the corners. They are NOT completely dark as expected.
Additional InformationOriginally reported and discussed here:
  http://forums.thedarkmod.com/topic/19507-antialiasing-in-trunk-207/#entry423594
TagsNo tags attached.

Relationships

related to 0004850 resolvedcabalistic Implement antialiasing compatible with FBO 
related to 0004660 suspendedstgatilov Soft shadows: sometimes light leaks near edges (in complete darkness) 

Activities

stgatilov

stgatilov

25.06.2018 06:10

administrator  

stgatilov

stgatilov

25.06.2018 06:12

administrator   ~0010582

Just as with the similar issue 0004660, setting polygon offset:
  r_shadowPolygonOffset 1
or even:
  r_shadowPolygonOffset 0.5
hides the problem (for a reason not yet clear).
stgatilov

stgatilov

01.09.2018 11:24

administrator  

stgatilov

stgatilov

01.09.2018 11:24

administrator   ~0010745

The issue is also visible in Closemouthed Shadows (attached a new image).
cabalistic

cabalistic

01.09.2018 16:12

developer   ~0010746

Fixed in rev. 7671

Issue History

Date Modified Username Field Change
25.06.2018 06:09 stgatilov New Issue
25.06.2018 06:09 stgatilov Status new => assigned
25.06.2018 06:09 stgatilov Assigned To => cabalistic
25.06.2018 06:09 stgatilov Assigned To cabalistic =>
25.06.2018 06:09 stgatilov Assigned To => stgatilov
25.06.2018 06:09 stgatilov Status assigned => new
25.06.2018 06:09 stgatilov Assigned To stgatilov =>
25.06.2018 06:09 stgatilov Assigned To => stgatilov
25.06.2018 06:09 stgatilov Status new => assigned
25.06.2018 06:09 stgatilov Status assigned => new
25.06.2018 06:10 stgatilov Assigned To stgatilov =>
25.06.2018 06:10 stgatilov File Added: multisampling_and_softshadows.jpg
25.06.2018 06:11 stgatilov Relationship added related to 0004850
25.06.2018 06:11 stgatilov Relationship added related to 0004660
25.06.2018 06:12 stgatilov Note Added: 0010582
29.07.2018 07:29 cabalistic Assigned To => cabalistic
29.07.2018 07:29 cabalistic Status new => assigned
01.09.2018 11:24 stgatilov File Added: cmshadows_softshadows_MSAA_leak.jpg
01.09.2018 11:24 stgatilov Note Added: 0010745
01.09.2018 16:12 cabalistic Note Added: 0010746
01.09.2018 16:12 cabalistic Status assigned => resolved
01.09.2018 16:12 cabalistic Fixed in Version => TDM 2.07
01.09.2018 16:12 cabalistic Resolution open => fixed