View Issue Details

IDProjectCategoryView StatusLast Update
0004873DarkRadiantDesign/Codingpublic25.09.2018 14:20
ReportergraymanAssigned Togreebo 
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.6.0 
Target Version2.6.1Fixed in Version2.6.1 
Summary0004873: Game/Project Setup should show recently used custom paths in the mission drop down list
DescriptionWhen changing the Game/Project Setup setting for the current project I'm working on, the pull down menu of previous projects only looks to see what's in the fms folder.

Refer to the attached screen image.

I prefer not to keep my projects there, for safety reasons in case I have to delete my darkmod folder and replace it for development purposes. I'm sure other mappers place their project folders in various locations depending on their work process.

Can the pull-down menu please show the full pathnames of previous projects?

thx.
TagsNo tags attached.

Activities

grayman

grayman

22.07.2018 18:38

administrator  

projectSetting.jpg (110,467 bytes)
projectSetting.jpg (110,467 bytes)
greebo

greebo

20.09.2018 09:41

administrator   ~0010765

The pulldown menu doesn't represent a history of your settings. It doesn't show previous projects only, but lists the contents of the fms/ folder, for convenience.

If you don't benefit from this dropdown showing only fms/ contents, maybe the old Doom3-style dialog is better for your use-case?
grayman

grayman

20.09.2018 14:44

administrator   ~0010769

What does that look like?
greebo

greebo

20.09.2018 16:23

administrator   ~0010770

If you change the game type to Doom 3, you'll get the good old "engine path" / "fs_game" and "fs_game_base" type entry fields, like we used to have before a few versions ago.
grayman

grayman

24.09.2018 12:52

administrator   ~0010774

No, that doesn't help, since it doesn't list previous settings.
greebo

greebo

25.09.2018 07:37

administrator   ~0010776

Ok, so do I understand this right that you want the FMs dropdown to list previously entered paths additionally to the folders living in the fms/ subfolder?

Would that help? Or is there more that should be changed?
grayman

grayman

25.09.2018 10:39

administrator   ~0010777

Nope, that's it.

I only ask because my missions have a full pathname like:

D:/TDM/Missions/steele/ws4_warrens/

and I'm constantly switching back and forth among several WIPs, so it would be nice to just click on a full pathname instead of having to type it in.
greebo

greebo

25.09.2018 10:44

administrator   ~0010778

I'll have a look.
greebo

greebo

25.09.2018 14:19

administrator   ~0010779

Implemented a draft version of your request in commit a0c4e710c. Watch out for this in the next pre-release.

Issue History

Date Modified Username Field Change
22.07.2018 18:38 grayman New Issue
22.07.2018 18:38 grayman File Added: projectSetting.jpg
20.09.2018 09:41 greebo Note Added: 0010765
20.09.2018 09:41 greebo Status new => feedback
20.09.2018 14:44 grayman Note Added: 0010769
20.09.2018 14:44 grayman Status feedback => new
20.09.2018 16:23 greebo Note Added: 0010770
24.09.2018 09:20 greebo Status new => feedback
24.09.2018 12:52 grayman Note Added: 0010774
24.09.2018 12:52 grayman Status feedback => new
25.09.2018 07:37 greebo Note Added: 0010776
25.09.2018 10:39 grayman Note Added: 0010777
25.09.2018 10:44 greebo Note Added: 0010778
25.09.2018 10:44 greebo Status new => acknowledged
25.09.2018 14:19 greebo Assigned To => greebo
25.09.2018 14:19 greebo Status acknowledged => assigned
25.09.2018 14:19 greebo Target Version => 2.6.1
25.09.2018 14:19 greebo Note Added: 0010779
25.09.2018 14:19 greebo Status assigned => resolved
25.09.2018 14:19 greebo Fixed in Version => 2.6.1
25.09.2018 14:19 greebo Resolution open => fixed
25.09.2018 14:20 greebo Summary Game/Project Setup assumes projects live in the fms folder => Game/Project Setup should show recently used custom paths in the mission drop down list