View Issue Details

IDProjectCategoryView StatusLast Update
0004878The Dark ModSoundpublic03.09.2018 02:43
Reportergrayman Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004878: Problem with efx file syntax
DescriptionI like to give my location entities names like

InfoLocMarket
InfoLocStart

That way, they appear in the upper section of DR's list of entities, and I can easily move from one location to another in DR.

The efx file, however, doesn't like uppercase letters in the location names.

If I have

reverb "InfoLocMarket"

in the efx file, EFX won't match that to the location entity named "InfoLocMarket".

I have to change all uppercase letters to lowercase to get a match.

So I need to use

infolocmarket

and

reverb "infolocmarket"

to get a match.

Please change this so uppercase letters are allowed.
TagsNo tags attached.

Activities

stgatilov

stgatilov

02.09.2018 06:40

administrator   ~0010750

Fixed in svn rev 7676.
At least, I can write "streets" location as "Streets", "StReeTs" and "STREETS" in my test, and after reloadSounds it still works.
grayman

grayman

02.09.2018 13:15

administrator   ~0010751

I confirmed that this works, but would like one more change.

Given the location entity named 'InfoLocStart' ...

and the efx definition 'reverb "InfoLocStart"' ...

TDM reports, when entering InfoLocStart:

"Switching to EFX 'infolocstart' (0000293)"

This can be confusing, since that's not the name of the reverb in use.

Thanks.
stgatilov

stgatilov

02.09.2018 17:56

administrator   ~0010752

Removed lowercasing of location name in svn rev 7683.
grayman

grayman

03.09.2018 02:43

administrator   ~0010753

Confirmed.

Thanks!

Issue History

Date Modified Username Field Change
19.08.2018 02:34 grayman New Issue
01.09.2018 17:24 stgatilov Assigned To => stgatilov
01.09.2018 17:24 stgatilov Status new => assigned
02.09.2018 06:40 stgatilov Note Added: 0010750
02.09.2018 06:40 stgatilov Status assigned => resolved
02.09.2018 06:40 stgatilov Fixed in Version => TDM 2.07
02.09.2018 06:40 stgatilov Resolution open => fixed
02.09.2018 13:15 grayman Note Added: 0010751
02.09.2018 17:56 stgatilov Note Added: 0010752
03.09.2018 02:43 grayman Note Added: 0010753