View Issue Details

IDProjectCategoryView StatusLast Update
0004898The Dark ModSoundpublic09.12.2018 09:13
Reportergrayman Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Fixed in VersionTDM 2.07 
Summary0004898: Problem with "opposite ear" volume
DescriptionSee this thread:

http://forums.thedarkmod.com/topic/19727-minimum-volume-cap-for-directional-sounds/#entry429822
TagsNo tags attached.

Relationships

related to 0004907 confirmed Make OpenAL settings more configurable inside TDM 

Activities

MirceaKitsune

MirceaKitsune

07.11.2018 12:40

reporter   ~0010795

In summary: I'm running TDM 2.06 x64 on Linux (openSUSE Tumbleweed), my sound is on a pair of wireless Logitech headphones. The mode is set to stereo in the audio settings panel, and I even tried setting both s_minVolume2 and s_minVolume6 to levels above 0.0 and 0.25 then using s_restart to apply any changes.

No matter what I do, directional sounds are never heard in the ear opposite of the sound source, and there is no minimum volume cap for me. This is very irking to the ear, enough that I often have to face toward loud sounds just so I don't get this ambiguous effect. Hope the cause of this issue can be identified.
Judith

Judith

25.11.2018 11:05

reporter   ~0010796

I compared this with vanilla Doom 3 and TDM 2.05. s_minVolume2 works in both, with default value of 0.25. It doesn't work in 2.06 at all, so it somehow got broken during work on 2.06. I suggest raising the severity, as this impacts player experience a lot.
stgatilov

stgatilov

26.11.2018 05:19

administrator   ~0010798

Maybe the cvars are ignored in the OpenAL path which TDM uses starting from 2.06.
stgatilov

stgatilov

27.11.2018 06:06

administrator   ~0010801

We have to solve the problem using OpenAL ways.

Here are two possibilities:
1) HRTF, controlled by hrtf.
2) crossfeed, controlled by cf_level.
Also all of this depends on whether you use headphones or not (stereo-mode in the ini file).

Moreover, it seems that HRTF should be enabled by default if OpenAL sees that you use headphones, but for some reason it is not =(
stgatilov

stgatilov

06.12.2018 12:33

administrator   ~0010832

Last edited: 06.12.2018 12:34

View 2 revisions

Now TDM distributes alsoft.ini with two hrtf data files alongside TDM.

As a result, HRTF is enabled by default. Of course, it would most likely work only with headphones (although you can force it in config), and only with suitable sample rates (although you can also force it in config).

Aside from that, I set cf_level to 2 for the case when player cannot load HRTF for some reason. This settings works only when HRTF does not, and it says opposite ear to have at least some volume.

http://forums.thedarkmod.com/topic/17689-improve-your-tdm-experience-by-playing-with-openal-soft-hrtf-better-3d-audio/page-3#entry430365

Issue History

Date Modified Username Field Change
07.11.2018 05:09 grayman New Issue
07.11.2018 12:40 MirceaKitsune Note Added: 0010795
25.11.2018 11:05 Judith Note Added: 0010796
26.11.2018 05:19 stgatilov Note Added: 0010798
27.11.2018 06:06 stgatilov Note Added: 0010801
06.12.2018 12:27 stgatilov Assigned To => stgatilov
06.12.2018 12:27 stgatilov Status new => assigned
06.12.2018 12:33 stgatilov Note Added: 0010832
06.12.2018 12:33 stgatilov Status assigned => resolved
06.12.2018 12:33 stgatilov Fixed in Version => TDM 2.07
06.12.2018 12:33 stgatilov Resolution open => fixed
06.12.2018 12:34 stgatilov Note Edited: 0010832 View Revisions
09.12.2018 09:13 stgatilov Relationship added related to 0004907