View Issue Details

IDProjectCategoryView StatusLast Update
0004904DarkRadiantGUIpublic11.03.2019 05:37
Reporteruser81Assigned Togreebo 
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version8.1
Product Version2.6.0 
Target Version2.6.1Fixed in Version2.6.1 
Summary0004904: Unmaximised DarkRadiant not remembering main window size and location
DescriptionDR not remembering size and location of main window on an ultrawide monitor (3440*1440) change the resolution to more traditional sizes and DR go back to behaving itself again.
Steps To ReproduceOpen DR set the window size and location, and then move the ortho and inspector window dividers to where you want them. Then finally set the location of the child windows, layers, transform and Surface inspector

Close and reopen DR and it remembers the child window sizes and locations, but the main window keeps opening up in the middle of the screen ignoring the size, location and divider locations.
TagsNo tags attached.

Activities

user81

22.12.2018 10:12

  ~0011046

This is even worse on an ultrawide monitor, the child windows remember thier location just fine, but the main window and its dividers need adjusted each and every time Dr is opened.
greebo

greebo

10.03.2019 07:51

administrator   ~0011683

It's not only related to ultra-wide monitors but to having the main window in an unmaximised state. When un-maximising and placing the main window somewhere, the size and position is properly saved to the user.xml but it won't be applied at the next startup.
greebo

greebo

11.03.2019 05:37

administrator   ~0011684

Fixed in 653a9f
Position of unmaximised windows is not perfectly restored, there seems to be a slight offset applied, the reason of which I couldn't figure out yet.

Issue History

Date Modified Username Field Change
02.12.2018 00:54 user81 New Issue
02.12.2018 00:55 user81 Assigned To => greebo
02.12.2018 00:55 user81 Status new => assigned
02.12.2018 00:55 user81 Status assigned => feedback
22.12.2018 10:12 user81 Note Added: 0011046
22.12.2018 10:12 user81 Status feedback => assigned
24.12.2018 17:59 greebo Assigned To greebo =>
24.12.2018 17:59 greebo Status assigned => acknowledged
24.12.2018 17:59 greebo Target Version 2.6.1 =>
10.03.2019 07:48 greebo Status acknowledged => confirmed
10.03.2019 07:51 greebo Note Added: 0011683
10.03.2019 07:51 greebo Product Version 2.6.1 => 2.6.0
10.03.2019 07:51 greebo Summary Darkradiant .exe not remembering main window size and location => Unmaximised DarkRadiant not remembering main window size and location
11.03.2019 05:36 greebo Assigned To => greebo
11.03.2019 05:36 greebo Status confirmed => assigned
11.03.2019 05:36 greebo Target Version => 2.6.1
11.03.2019 05:37 greebo Note Added: 0011684
11.03.2019 05:37 greebo Status assigned => resolved
11.03.2019 05:37 greebo Fixed in Version => 2.6.1
11.03.2019 05:37 greebo Resolution open => fixed