View Issue Details

IDProjectCategoryView StatusLast Update
0004906The Dark ModFeature proposalpublic19.12.2018 11:41
ReporterSTiFU Assigned ToSTiFU  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004906: Add frob assistance for cluttered objects inside containers
DescriptionPicking up cluttered objects in a container can consume quite some time, which lessens immersion. Gameplay would greatly benefit from some sort of FrobHelper.

Two Methods have been proposed:
1) Show a subtle dot for aim-assistance when multiple objects are within frob range.
-> It should slowly blend in to a semi-transparent state with configurable delay, fade-in time and alpha-value.
2) Cycle through multiple frobable objects with an additional button.
-> Some team members spoke out against adding further control elements, though.

Any implemented method has to be fully optional.
Additional InformationFull discussion: http://forums.thedarkmod.com/topic/19759-could-picking-up-cluttered-objects-become-easier/
TagsNo tags attached.

Activities

STiFU

STiFU

16.12.2018 16:56

developer   ~0010948

Method 1 has been implemented. The FrobHelper cursor is shown when there are small objects within frob range.
stgatilov

stgatilov

17.12.2018 17:31

administrator   ~0010957

Copying here:

Is it really necessary to hack alpha parameter into idUserInterface::Redraw?
There are states and something like registers there. Maybe they can be used?

Update: search for HUD_Opacity in gui files and in the source code.
It looks like the right way to do that.
STiFU

STiFU

17.12.2018 19:17

developer   ~0010958

Thank you, that's a good suggestion. Corrected in trunk rev. 7833.
STiFU

STiFU

19.12.2018 11:40

developer   ~0010969

Feature has been merged from trunk to 2.07-Release.

Issue History

Date Modified Username Field Change
08.12.2018 12:05 STiFU New Issue
08.12.2018 12:06 STiFU Description Updated View Revisions
14.12.2018 19:57 STiFU Assigned To => STiFU
14.12.2018 19:57 STiFU Status new => assigned
14.12.2018 19:58 STiFU Target Version => TDM 2.08
15.12.2018 18:13 STiFU Status assigned => feedback
16.12.2018 16:56 STiFU Note Added: 0010948
16.12.2018 16:56 STiFU Status feedback => assigned
16.12.2018 16:58 STiFU Status assigned => feedback
17.12.2018 17:31 stgatilov Note Added: 0010957
17.12.2018 19:17 STiFU Note Added: 0010958
17.12.2018 19:17 STiFU Status feedback => assigned
17.12.2018 19:17 STiFU Status assigned => resolved
17.12.2018 19:17 STiFU Target Version TDM 2.08 => TDM 2.07
19.12.2018 11:40 STiFU Note Added: 0010969
19.12.2018 11:40 STiFU Fixed in Version => TDM 2.07
19.12.2018 11:41 STiFU Resolution open => fixed