View Issue Details

IDProjectCategoryView StatusLast Update
0004910DarkRadiantGeneralpublic22.07.2022 11:50
ReporterEoceneMiacid Assigned Togreebo  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.5.0 
Target Version3.1.0Fixed in Version3.1.0 
Summary0004910: DR does not parse materials in def files
DescriptionI'm working on a large sandbox mod.

Doom3 (I'm using dhewm3) allows you to define a material in a .def by prefixing it with 'material', as an alternative to having it in a .mtr file in /materials.

I prefer this method, since this way, you can keep everything that's related to an entity contained in the .def file, which makes things nicer to manage, find, and mod.

You can also do this with skins, soundshaders, ragdolls, particles and so on.

DarkRadiant does not support this - it does not parse the materials, and as such my entities are untextured in the editor.

It would be nice if DarkRadiant implemented support for this, to be feature parity with IdTech4 at least.
TagsNo tags attached.

Relationships

related to 0005977 resolvedgreebo Improve Declaration Block Parsing 

Activities

orbweaver

orbweaver

31.01.2019 14:05

developer   ~0011525

It would definitely be nice to have the same parsing flexibility as idTech4, but would require non-trivial changes to DR's architecture since currently all of the parsers are separate and tied to their own search directories.

If this were ever implemented, I would suggest a sort of "global def manager" which is responsible for searching ALL directories that might contain defs, then farming each one out to a task-specific parser based on either the containing directory name or the explicit def type listed in the file.
greebo

greebo

22.07.2022 11:50

administrator   ~0015070

Resolved through 0005977

Issue History

Date Modified Username Field Change
09.12.2018 18:16 EoceneMiacid New Issue
31.01.2019 14:05 orbweaver Note Added: 0011525
31.01.2019 14:05 orbweaver Status new => confirmed
16.06.2022 15:55 greebo Relationship added related to 0005977
22.07.2022 11:49 greebo Assigned To => greebo
22.07.2022 11:49 greebo Status confirmed => assigned
22.07.2022 11:49 greebo Target Version => 3.1.0
22.07.2022 11:50 greebo Status assigned => resolved
22.07.2022 11:50 greebo Resolution open => fixed
22.07.2022 11:50 greebo Fixed in Version => 3.1.0
22.07.2022 11:50 greebo Note Added: 0015070