View Issue Details

IDProjectCategoryView StatusLast Update
0004913The Dark ModGraphicspublic18.11.2019 17:47
Reporterstgatilov Assigned Tostgatilov  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindowsOS Version10
Product VersionSVN 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0004913: Object proportions depend on aspect ratio
DescriptionWith some aspect ratio in Windowed mode I see object heavily stretched vertically.
Is this supposed to happen?
Steps To ReproduceRun any mission with 4:3 (5:4) and with 16:9 (Windowed) and look at the same object in both cases. It will look streched on one of the cases.
Additional InformationSee also attached screenshort of own reflection in the mirror.
On 5:4 aspect ratio I look too slim =)
TagsNo tags attached.

Activities

stgatilov

stgatilov

14.12.2018 15:34

developer  

1280x1024.jpg (304,851 bytes)
stgatilov

stgatilov

14.12.2018 15:34

developer  

1280x720.jpg (222,628 bytes)
1280x720.jpg (222,628 bytes)
Springheel

Springheel

15.12.2018 15:07

administrator   ~0010932

It's definitely not intentional.
STiFU

STiFU

16.12.2018 17:02

developer   ~0010949

I think this needs to be fixed for 2.07. We can't have people play with incorrect aspect ratio.
stgatilov

stgatilov

16.12.2018 17:35

developer   ~0010950

Last edited: 16.12.2018 17:45

View 2 revisions

On TDM 2.05, this problems does not happen.
...
Can anyone reproduce it on current 2.07 version?

stgatilov

stgatilov

17.12.2018 03:31

developer   ~0010955

Ok, I found where aspect ratio is taken into account.
It is in idGameLocal::CalcFov. This piece of code stinks.

Anyway, the problem is that this function uses r_aspectRatio to learn the resolution proportions. And this one was not updated properly when I bumped into this bug, so the code used wrong aspect ratio for deducing view params.
Now the aspect ratio should be fixed, so the problem should not happen.
stgatilov

stgatilov

17.12.2018 03:37

developer   ~0010956

Added 2.08 target: I'll rewrite the code in idGameLocal::CalcFov to use r_customWidth / r_customHeight directly after beta phase ends.
If someone manages to bump into the problem during beta, the target will be lowered =)
stgatilov

stgatilov

18.11.2019 17:33

developer   ~0011871

The latest discussion on forum:
  http://forums.thedarkmod.com/index.php?/topic/20159-delete-r_fovratio/
stgatilov

stgatilov

18.11.2019 17:44

developer   ~0011872

Finished in svn rev 8404

Issue History

Date Modified Username Field Change
14.12.2018 15:34 stgatilov New Issue
14.12.2018 15:34 stgatilov File Added: 1280x1024.jpg
14.12.2018 15:34 stgatilov File Added: 1280x720.jpg
14.12.2018 15:35 stgatilov Steps to Reproduce Updated View Revisions
14.12.2018 15:35 stgatilov Additional Information Updated View Revisions
15.12.2018 15:07 Springheel Note Added: 0010932
16.12.2018 17:02 STiFU Note Added: 0010949
16.12.2018 17:35 stgatilov Note Added: 0010950
16.12.2018 17:45 stgatilov Note Edited: 0010950 View Revisions
17.12.2018 03:31 stgatilov Note Added: 0010955
17.12.2018 03:31 stgatilov Assigned To => stgatilov
17.12.2018 03:31 stgatilov Status new => assigned
17.12.2018 03:31 stgatilov Product Version TDM 2.07 => SVN
17.12.2018 03:36 stgatilov Target Version => TDM 2.08
17.12.2018 03:37 stgatilov Note Added: 0010956
18.11.2019 17:33 stgatilov Note Added: 0011871
18.11.2019 17:44 stgatilov Note Added: 0011872
18.11.2019 17:47 stgatilov Status assigned => resolved
18.11.2019 17:47 stgatilov Resolution open => fixed
18.11.2019 17:47 stgatilov Fixed in Version => TDM 2.08