View Issue Details

IDProjectCategoryView StatusLast Update
0004928The Dark ModGraphicspublic29.12.2018 22:03
Reportergrayman Assigned ToSpringheel  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product VersionTDM 2.07 
Summary0004928: Gold texture is wrong
DescriptionObserve the difference between the gold texture in 2.06 and the same texture in 2.07.

Map file attached.

The only light in the room is ambient_world.

This is one of many flat metal textures, so the problem might not be limited to the gold texture.
TagsNo tags attached.

Relationships

child of 0004364 assignedduzenko RGTC Normal Map compression 

Activities

grayman

grayman

24.12.2018 19:54

administrator  

gold.map (5,811 bytes)   
Version 2
// entity 0
{
"classname" "worldspawn"
"editor_drMapPos1" "1738.55 1171.14 -520.531"
"editor_drMapAngle1" "14.7001 87.8977 0"
"editor_drMapPos2" "414.798 255.441 -264.933"
"editor_drMapAngle2" "2.10002 84.5976 0"
"editor_drMapPos3" "-749.97 -1606.21 -470.066"
"editor_drMapAngle3" "-3.29998 6.59757 0"
"editor_drMapPos4" "1014.05 -953.679 -556.857"
"editor_drMapAngle4" "-10.2 355.498 0"
"editor_drMapPos5" "987.599 3513.79 -319.877"
"editor_drMapAngle5" "-61.1999 172.198 0"
"editor_drMapPos6" "-1032.5 -2840 739.5"
"editor_drMapAngle6" "-77.0999 175.798 0"
"editor_drMapPos7" "952.822 285.005 1366.04"
"editor_drMapAngle7" "-74.8 149.373 0"
"editor_drMapPos8" "976 424 320"
"editor_drMapAngle8" "-3 15.3467 0"
"editor_drMapPos9" "409.146 547.464 392.83"
"editor_drMapAngle9" "-16.8 284.947 0"
"editor_drMapPos10" "3134.38 -1495.39 -94.4922"
"editor_drMapAngle10" "-9.3 278.7 0"
"editor_drLastCameraPos" "8.27018 28.5077 90.0395"
"editor_drLastCameraAngle" "11.1 308.4 0"
// primitive 0
{
brushDef3
{
( 0 0 1 -136 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 1 0 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 1 0 0 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 -1 0 -64 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( -1 0 0 -64 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 0 -1 128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
}
}
// primitive 1
{
brushDef3
{
( 0 0 1 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 1 0 -136 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 1 0 0 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 0 -1 0 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( -1 0 0 -64 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 -1 0 128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
}
}
// primitive 2
{
brushDef3
{
( 0 0 1 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 1 0 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 1 0 0 -136 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 0 -1 0 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 -1 0 -64 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( -1 0 0 128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
}
}
// primitive 3
{
brushDef3
{
( 0 1 0 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 1 0 0 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 0 -1 -8 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 -1 0 -64 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( -1 0 0 -64 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 0 1 0 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
}
}
// primitive 4
{
brushDef3
{
( 0 0 1 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 1 0 0 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 0 -1 0 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 -1 0 -72 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( -1 0 0 -64 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 1 0 64 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
}
}
// primitive 5
{
brushDef3
{
( 0 0 1 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 1 0 -128 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 0 -1 0 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 0 -1 0 -64 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( -1 0 0 -72 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
( 1 0 0 64 ) ( ( 0.015625 0 0 ) ( 0 0.0078125 0 ) ) "textures/darkmod/metal/flat/tiling_1d/gen_smooth_gold01" 0 0 0
}
}
}
// entity 1
{
"classname" "atdm:ambient_world"
"name" "ambient_world"
"origin" "32 32 64"
"light_center" "0 0 0"
"light_radius" "320 320 320"
"_color" "0.08 0.08 0.08"
}
// entity 2
{
"classname" "info_player_start"
"name" "info_player_start_1"
"origin" "-32 -32 0"
"angle" "45"
}
gold.map (5,811 bytes)   
duzenko

duzenko

25.12.2018 07:48

developer   ~0011110

Last edited: 25.12.2018 07:49

View 2 revisions

I don't have 2.06 assets on my PC
Can you attach a split screen shot please?

Looks like a fake reflection to me.

duzenko

duzenko

25.12.2018 07:50

developer  

Untitled.jpg (172,055 bytes)   
Untitled.jpg (172,055 bytes)   
duzenko

duzenko

25.12.2018 07:57

developer   ~0011111

Can anybody explain what this is supposed to achieve?

        blend gl_dst_alpha, gl_one

This is the first active stage, so where is gl_dst_alpha initialized?
Looks like this material needs some fixing effort.
grayman

grayman

25.12.2018 13:44

administrator  

gold.jpg (305,559 bytes)
grayman

grayman

25.12.2018 13:45

administrator   ~0011112

Attached
duzenko

duzenko

25.12.2018 16:52

developer   ~0011113

Another RGTC artifact
duzenko

duzenko

25.12.2018 17:22

developer   ~0011114

Our reflect-cube shader is ARB2. Our options:
1 - port it to GLSL and add RGTC support while on it
2 - remove the bump stage from the material in question
Theoretically it's possible to add RGTC support to the existing ARB2 shader but IMHO we'd better off with GLSL replacement
nbohr1more

nbohr1more

25.12.2018 18:35

developer   ~0011115

Doesn't image_useNormalmapCompression 1 use S3TC compression and only
Mode 2 enable RGTC? Or has the whole GLSL pipeline been converted to RGTC now?
duzenko

duzenko

25.12.2018 18:45

developer   ~0011116

I believe @grayman tested this with image_useNormalmapCompression 2
duzenko

duzenko

25.12.2018 19:02

developer   ~0011117

So I ported most of the ARB2 shader and I can see a problem with the env/gen1 cubemap. Its seams have been sewn incorrectly as shown on the attached screenshot.

I modified the material like this locally

    {
        //blend gl_dst_alpha, gl_one
        blend add
        //maskalpha
        cubeMap env/gen1
            //red sintable[time*0.1]
            //green sintable[time*0.1]
            //blue sintable[time*0.1]
        //texgen reflect
        texgen skybox
    }

The texgen is to show the seam issue and the rest is my attempt at fixing the material
nbohr1more

nbohr1more

26.12.2018 03:55

developer   ~0011119

Last edited: 26.12.2018 03:57

View 3 revisions

So...

It's really cool that you are improving RGTC support but I think we should be
clear here.

RGTC compression is not yet production ready for 2.07 so players and mappers
should not be using it other than to tinker with it and check it out in it's
early incarnation.

image_useNormalCompression 1 is the default mode and should have been advised as
soon as Grayman encountered the first lighting bug where RGTC was discovered as
the root cause.

As to why Grayman had this value set to 2?

1) WAY back before TDM 1.08, this was the default mode. It was using RXGB
compression (swizzled S3TC). When RXGB was broken in 1.08 all textures simply
fell back to uncompressed so nobody would've noticed if they left the
value at 2?

2) Grayman saw the RGTC development thread and tried testing this out and forgot
to change it back to 1?

etc.

Whatever the case, mode 2 has not worked since 1.07 and should not be used until
RGTC is production ready with working glass, water, and reflection shaders
(etc).

TLDR; use image_useNormalCompression 1

Does this make sense?

grayman

grayman

26.12.2018 04:09

administrator   ~0011124

Last edited: 26.12.2018 04:09

View 2 revisions

Probably suggestion 1.

grayman

grayman

26.12.2018 04:17

administrator   ~0011126

Indeed, setting image_useNormalCompression 1 fixes the problem.

Since that's the default, this bug can be closed.

As for how it got set to 2, it's probably been in my config file for years, and when the setting of "2" became broken, it wasn't advertised loudly enough for me to realize to change it back to 1.
duzenko

duzenko

26.12.2018 06:13

developer   ~0011127

Committed shader and C++ changes.
Still needs material and cubemap fixes.
STiFU

STiFU

29.12.2018 22:03

developer   ~0011181

As this was a config problem,I am closing this issue. RGTC fixes and improvements should be tracked under a more meaningful issue name.

Issue History

Date Modified Username Field Change
24.12.2018 19:54 grayman New Issue
24.12.2018 19:54 grayman Status new => assigned
24.12.2018 19:54 grayman Assigned To => duzenko
24.12.2018 19:54 grayman File Added: gold.map
25.12.2018 07:48 duzenko Note Added: 0011110
25.12.2018 07:49 duzenko Note Edited: 0011110 View Revisions
25.12.2018 07:50 duzenko File Added: Untitled.jpg
25.12.2018 07:57 duzenko Note Added: 0011111
25.12.2018 13:44 grayman File Added: gold.jpg
25.12.2018 13:45 grayman Note Added: 0011112
25.12.2018 16:52 duzenko Note Added: 0011113
25.12.2018 16:52 duzenko Status assigned => confirmed
25.12.2018 17:22 duzenko Note Added: 0011114
25.12.2018 18:35 nbohr1more Note Added: 0011115
25.12.2018 18:45 duzenko Note Added: 0011116
25.12.2018 19:02 duzenko Note Added: 0011117
26.12.2018 03:55 nbohr1more Note Added: 0011119
26.12.2018 03:56 nbohr1more Note Edited: 0011119 View Revisions
26.12.2018 03:57 nbohr1more Note Edited: 0011119 View Revisions
26.12.2018 04:09 grayman Note Added: 0011124
26.12.2018 04:09 grayman Note Edited: 0011124 View Revisions
26.12.2018 04:17 grayman Note Added: 0011126
26.12.2018 06:13 duzenko Note Added: 0011127
26.12.2018 06:13 duzenko Assigned To duzenko => Springheel
26.12.2018 06:13 duzenko Target Version TDM 2.07 => TDM 2.08
26.12.2018 18:03 nbohr1more Relationship added child of 0004364
29.12.2018 22:03 STiFU Note Added: 0011181
29.12.2018 22:03 STiFU Status confirmed => closed
29.12.2018 22:03 STiFU Resolution open => no change required
29.12.2018 22:03 STiFU Target Version TDM 2.08 =>