View Issue Details

IDProjectCategoryView StatusLast Update
0004946The Dark ModGraphicspublic20.05.2020 09:50
ReporterSpooks Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
OSWindowsOS Version7 
Product VersionTDM 2.06 
Target VersionTDM 2.09Fixed in VersionTDM 2.08 
Summary0004946: Candle Flame Particle Behind Wall Shows in a Mirror
DescriptionIn Night of Reluctant Benefaction, there is a mirror in one room and a stock candle in the room behind it. Under certain viewing angles, you can see the candle flame particle show up in the mirror but not the candle (or light emitted) itself.

The two rooms have proper visportalling, so the visleafs should be sealed from each other. Extinguishing the candle in the other room makes the particle go away from the mirror. Relighting it brings it back.
Steps To Reproducehttp://forums.thedarkmod.com/topic/19774-beta-testing-207/page-7#entry432487

This post contains screenshots. In anorb2.map, the getviewpos is "635.64 535.45 300.25 2.4 -84.2 0.0"
Additional InformationThere is an additional candle in the room with the mirror. It does not affect the reflection from where it is, but if you bring it to the other room and place it next to the offending candle, you may see two candle flames in the mirror depending on your position.
TagsNo tags attached.

Activities

duzenko

duzenko

06.01.2019 09:18

developer   ~0011249

Last edited: 06.01.2019 09:19

View 3 revisions

AFAIK The particle gets to the screen because the mirror clip is a part of the depth test and the particle does not write to depth buffer.

I would propose to pass the mirror clip plane to soft_particle.vfp but since the ARB2 shaders are scheduled to drop in 2.08 it has to wait until then.

I don't think anything has to be done on the portal code or the map.

stgatilov

stgatilov

12.01.2019 16:33

administrator   ~0011333

Soft particles is new feature?
Is it possible to disable it? If yes, then how?
If they are disabled, then the problem disappears?
nbohr1more

nbohr1more

12.01.2019 18:39

developer   ~0011337

R_useSoftParticles was introduced by SteveL in 2.03
nbohr1more

nbohr1more

08.05.2020 02:59

developer   ~0012479

Most of the issues with candles and mirrors are resolved in 2.08 but the core issue here can still be reproduced.
duzenko

duzenko

09.05.2020 12:06

developer   ~0012484

At revision: 8721
Test cvar: r_useClipPlaneCulling

Issue History

Date Modified Username Field Change
03.01.2019 20:58 Spooks New Issue
06.01.2019 09:18 duzenko Note Added: 0011249
06.01.2019 09:18 duzenko Status new => acknowledged
06.01.2019 09:18 duzenko Target Version => TDM 2.08
06.01.2019 09:19 duzenko Note Edited: 0011249 View Revisions
06.01.2019 09:19 duzenko Note Edited: 0011249 View Revisions
12.01.2019 16:33 stgatilov Note Added: 0011333
12.01.2019 18:39 nbohr1more Note Added: 0011337
08.05.2020 02:59 nbohr1more Note Added: 0012479
09.05.2020 12:06 duzenko Assigned To => duzenko
09.05.2020 12:06 duzenko Status acknowledged => resolved
09.05.2020 12:06 duzenko Resolution open => fixed
09.05.2020 12:06 duzenko Fixed in Version => TDM 2.08
09.05.2020 12:06 duzenko Note Added: 0012484
20.05.2020 09:50 stgatilov Target Version TDM 2.08 => TDM 2.09