View Issue Details

IDProjectCategoryView StatusLast Update
0004948The Dark ModPhysicspublic13.02.2019 09:46
ReporterSTiFUAssigned ToSTiFU 
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 2.07 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0004948: Improve ladder/rope slide (no fall-damage + sound)
DescriptionIn the current implementation, the ladder/rope sliding is as good as useless because you can get fall damage. A nice improvement would be to give those slides a non-damaging terminal velocity.

Furthermore, a slide soundeffect would be nice.
Additional Informationhttp://forums.thedarkmod.com/topic/19799-making-mantling-feel-more-natural/?p=432548
TagsNo tags attached.

Relationships

related to 0004991 new Add material dependent climb_slide sounds 

Activities

STiFU

STiFU

12.02.2019 12:05

developer   ~0011576

Rev. 7949:
If you press and hold crouch while facing towards a climbable surface, the player will graciously slide down at a non-damaging terminal velocity. If facing the other side, the player will detach, just like before.

This feature has not been added to ropes due to their swinging behavior: A slide down is not easily done and requires completely different physics.

TODO: Add sliding sound
STiFU

STiFU

13.02.2019 09:32

developer   ~0011584

Rev. 7952 adds a sliding sound to the ladder slide. It can be specialized to the surface type just like the actual climbing sounds in tdm_player_thief.def, e.g.:
snd_climb_slide_metal
snd_climb_slide_foliage

Currently, there is only snd_climb_slide_default due to the lack of appropriate sounds.

Issue History

Date Modified Username Field Change
05.01.2019 18:25 STiFU New Issue
05.01.2019 19:44 STiFU Summary Improve ladder/tope slide (no fall-damage + sound) => Improve ladder/rope slide (no fall-damage + sound)
12.02.2019 11:41 STiFU Assigned To => STiFU
12.02.2019 11:41 STiFU Status new => assigned
12.02.2019 12:05 STiFU Note Added: 0011576
13.02.2019 09:32 STiFU Note Added: 0011584
13.02.2019 09:32 STiFU Status assigned => resolved
13.02.2019 09:32 STiFU Resolution open => fixed
13.02.2019 09:32 STiFU Fixed in Version => TDM 2.08
13.02.2019 09:46 STiFU Relationship added related to 0004991