View Issue Details

IDProjectCategoryView StatusLast Update
0004949The Dark ModGUIpublic17.01.2019 13:34
Reporterduzenko Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0004949: Briefing Sound Looped / Out of Sync
DescriptionIt seems as if the briefing video is played in loop but the audio track plays faster than video
Steps To ReproduceStart the Sneak and Destroy mission
Watch the briefing video till the end
Notice how in the video end it starts playing the sound from the video start
TagsNo tags attached.

Relationships

related to 0004540 resolvedstgatilov Sound stops playing in cinematics because of breakpoints 

Activities

stgatilov

stgatilov

17.01.2019 11:23

developer   ~0011383

Last edited: 17.01.2019 11:36

View 2 revisions

Happens in 2.06, but not in 2.05.

I noticed that with "com_showSoundDecoders 1" the kneipe_story.wav sound decoder is not shown in 2.06, but is shown in 2.05.
If I enable "s_useOpenAL 1" in 2.05, then it also is NOT shown on the list.
It seems that wav decoders were only shown with non-OpenAL sound system.

However, in 2.05 the problem does NOT happen even with "s_useOpenAL 1".

stgatilov

stgatilov

17.01.2019 11:59

developer   ~0011386

I measured timing physically.
Used a timer on my mobile, started when I click on "New Game" button.

In all cases the voice ends at 1:27 (a tiny little bit earlier). The sound sample itself is about 1:26.
So the sound part behaves the same way in 2.05 and 2.06, which means that transition to OpenAL is very unlikely the problem.

However, the GUI is working slower in 2.06.
In 2.05, I see the objectives screen at about 1:33.5, while in 2.06 I see it at something like 1:37.5. So here are +4 seconds.

I have fullscreen, experimental stuff off (like multithreading and uncapped FPS).
stgatilov

stgatilov

17.01.2019 12:10

developer   ~0011388

What is more important:
In 2.05, when sound ends, it does not start over again. I even tried to postpone some GUI events by 6 seconds in the script so that the graphical part were longer: sound did not repeat.
In 2.06, the sound starts playing from the very beginning very soon after it finishes. The sound is not looping, so this should not happen. If it did not happen, then it would be OK, even with a bit longer graphics.
stgatilov

stgatilov

17.01.2019 13:33

developer   ~0011391

The problem with sound restart is caused by my change due to 0004540.

While the change makes sense for streaming sounds, the engine seems to also have non-streaming ones (very short OGGs and all WAVs). The non-streaming ones were efficiently made looping by the change.

Fixed it in svn rev 7919.
I'm pretty scared of the idea of pushing this to 2.07, so let it start in trunk until 2.08

Issue History

Date Modified Username Field Change
07.01.2019 11:01 duzenko New Issue
07.01.2019 11:01 duzenko Status new => assigned
07.01.2019 11:01 duzenko Assigned To => stgatilov
17.01.2019 11:22 stgatilov Reproducibility have not tried => always
17.01.2019 11:22 stgatilov Product Version SVN => TDM 2.06
17.01.2019 11:23 stgatilov Note Added: 0011383
17.01.2019 11:36 stgatilov Note Edited: 0011383 View Revisions
17.01.2019 11:59 stgatilov Note Added: 0011386
17.01.2019 12:10 stgatilov Note Added: 0011388
17.01.2019 13:26 stgatilov Relationship added related to 0004540
17.01.2019 13:33 stgatilov Note Added: 0011391
17.01.2019 13:33 stgatilov Summary Briefing Video Out of Sync / Looped => Briefing Sound Looped / Out of Sync
17.01.2019 13:34 stgatilov Status assigned => resolved
17.01.2019 13:34 stgatilov Fixed in Version => TDM 2.08
17.01.2019 13:34 stgatilov Resolution open => fixed