View Issue Details

IDProjectCategoryView StatusLast Update
0004958The Dark ModModelspublic26.01.2019 04:56
ReporterJudith Assigned Tostgatilov  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionTDM 2.07 
Target VersionTDM 2.07Fixed in Version 
Summary0004958: Broken smoothing on models
DescriptionRecent 2.07 beta update broke something with model smoothing. You can see soft lines between model faces, even though they are assigned to one smoothing group and should be one contiguous surface. This is very problematic for materials with high specularity, like glass or metal.

https://i.postimg.cc/R0DwDCqr/obraz.png

https://i.postimg.cc/ZnvR538H/obraz.png
Steps To ReproduceLaunch A Matter of Hours. Look at the pipes in the starting location. Go to the other side of a warehouse and look at glass bottles. Use lantern if there isn't enough light. Or, start any mission with glass bottles and metal pipes.
TagsNo tags attached.

Relationships

related to 0004955 confirmedstgatilov Wrongly black interaction light on a crate 

Activities

stgatilov

stgatilov

17.01.2019 05:00

developer   ~0011373

Another good testing place is: Inn Business FM in the kitchen (setviewpos 587.43 -96.97 68.25 22.0 171.6 0.0). There are lots of bottles and other stuff there, and if you move a candle from the table near them, the lack of smoothing it seen very well.
Judith

Judith

17.01.2019 05:09

reporter   ~0011374

Also bottles in the crate in the same room (AMoH).

2.05:
https://i.postimg.cc/VknYzbJY/obraz.png

2.07:
https://i.postimg.cc/DwZMgVKR/obraz.png
stgatilov

stgatilov

17.01.2019 08:17

developer   ~0011376

Fixed in svn rev 15565.
Judith

Judith

17.01.2019 08:34

reporter   ~0011377

Great! I don't have SVN access, so I'll have to wait for another beta update.
STiFU

STiFU

17.01.2019 10:52

developer   ~0011380

Fix confirmed.
http://forums.thedarkmod.com/topic/19774-beta-testing-207/?p=433133

I did not change "Fixed in Version" because the change has not yet been merged to release branch.

Issue History

Date Modified Username Field Change
16.01.2019 15:08 Judith New Issue
16.01.2019 18:37 nbohr1more Relationship added child of 0004955
16.01.2019 18:37 nbohr1more Status new => acknowledged
16.01.2019 18:37 nbohr1more Product Version SVN => TDM 2.07
16.01.2019 18:37 nbohr1more Target Version => TDM 2.07
17.01.2019 05:00 stgatilov Note Added: 0011373
17.01.2019 05:09 Judith Note Added: 0011374
17.01.2019 08:17 stgatilov Note Added: 0011376
17.01.2019 08:17 stgatilov Assigned To => stgatilov
17.01.2019 08:17 stgatilov Status acknowledged => assigned
17.01.2019 08:17 stgatilov Status assigned => feedback
17.01.2019 08:34 Judith Note Added: 0011377
17.01.2019 08:34 Judith Status feedback => assigned
17.01.2019 10:52 STiFU Note Added: 0011380
17.01.2019 10:52 STiFU Status assigned => resolved
17.01.2019 10:52 STiFU Resolution open => fixed
26.01.2019 04:56 stgatilov Relationship deleted child of 0004955
26.01.2019 04:56 stgatilov Relationship added related to 0004955