View Issue Details

IDProjectCategoryView StatusLast Update
0004969The Dark ModModelspublic25.02.2019 00:08
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.07 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004969: models/darkmod/lights/extinguishable/cagelamp_hanging.lwo casts shadow in Shadow Map mode
Descriptiontdm_coals_hot needs to be replaced with a nonshadow-casting texture. This affects several other light models. Need to figure out whether this will break any custom skins in other maps first.

http://forums.thedarkmod.com/topic/19742-hanging-light-model-question/
TagsNo tags attached.

Activities

Springheel

Springheel

20.01.2019 18:15

administrator   ~0011448

If someone with the python script working could check to see if any FMs include something in the "skins" folder referencing "tdm_coals_hot", that would help decide which will have a more negative impact.
STiFU

STiFU

20.01.2019 21:38

developer   ~0011450

I have searched my whole darkmod folder and all fms for the term "tdm_coals_hot" with Notepad++, see attached file. Is that enough information for you?
STiFU

STiFU

20.01.2019 21:38

developer  

tdm_coals_hot_references.txt (5,293 bytes)   
Search "tdm_coals_hot" (78 hits in 41 files)
  H:\NoBackup\darkmod\def\tdm_lights_static.def (5 hits)
	Line 1414: 	"skin"					"tdm_coals_hot"
	Line 1415: 	"skin_lit"				"tdm_coals_hot"
	Line 1428: 	"skin_lit"				"tdm_coals_hot"
	Line 1599: 	"skin"					"tdm_coals_hot"
	Line 1618: 	"skin"					"tdm_coals_hot"
  H:\NoBackup\darkmod\fms\training_mission\maps\training_mission.map (1 hit)
	Line 186147: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\ac2\maps\ac2.map (1 hit)
	Line 19115: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\bcd\maps\bcd.map (5 hits)
	Line 43836: "tdm_coals_hot"
	Line 96143: "tdm_coals_hot"
	Line 223234: "tdm_coals_hot"
	Line 493873: "tdm_coals_hot"
	Line 513791: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\bh\maps\bh.map (2 hits)
	Line 1763: "tdm_coals_hot"
	Line 1782: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\briarwood\maps\briarwoodcathedral.map (3 hits)
	Line 66752: "tdm_coals_hot"
	Line 67452: "tdm_coals_hot"
	Line 68166: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\caduceus\maps\caduceus.map (1 hit)
	Line 94918: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\chalice1_1\maps\chalice.map (5 hits)
	Line 19317: "tdm_coals_hot"
	Line 19330: "tdm_coals_hot"
	Line 19343: "tdm_coals_hot"
	Line 19356: "tdm_coals_hot"
	Line 19369: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\chalice1_1\materials\tdm_coals_hotter.mtr (1 hit)
	Line 1: tdm_coals_hot
  H:\NoBackup\darkmod\fms_all\crystalgrave2_1\maps\krysztalowygrob1.map (4 hits)
	Line 33431: "skin" "tdm_coals_hot"
	Line 33456: "skin" "tdm_coals_hot"
	Line 38208: "skin" "tdm_coals_hot"
	Line 75722: "skin" "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\itb\maps\itb.map (1 hit)
	Line 143802: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\kingofdiamonds\maps\kod.map (1 hit)
	Line 67696: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\nhat3\maps\anoott.map (2 hits)
	Line 210721: "tdm_coals_hot"
	Line 243432: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\penny2_1\maps\allthewayup.map (1 hit)
	Line 182555: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\penny3\maps\erasing.map (1 hit)
	Line 104816: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\siegeshop\maps\siegeshop.map (1 hit)
	Line 66081: "skin" "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\slc\maps\mansion07.map (1 hit)
	Line 22393: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\training_mission\maps\training_mission.map (1 hit)
	Line 186146: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\ac2.map (1 hit)
	Line 19115: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\allthewayup.map (1 hit)
	Line 182495: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\anoott.map (2 hits)
	Line 210721: "tdm_coals_hot"
	Line 243432: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\bcd.map (5 hits)
	Line 43836: "tdm_coals_hot"
	Line 96143: "tdm_coals_hot"
	Line 223234: "tdm_coals_hot"
	Line 493873: "tdm_coals_hot"
	Line 513791: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\bh.map (2 hits)
	Line 1763: "tdm_coals_hot"
	Line 1782: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\briarwoodcathedral.map (3 hits)
	Line 66752: "tdm_coals_hot"
	Line 67452: "tdm_coals_hot"
	Line 68166: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\caduceus.map (1 hit)
	Line 94918: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\chalice.map (5 hits)
	Line 19317: "tdm_coals_hot"
	Line 19330: "tdm_coals_hot"
	Line 19343: "tdm_coals_hot"
	Line 19356: "tdm_coals_hot"
	Line 19369: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\erasing.map (1 hit)
	Line 104816: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\fever.map (1 hit)
	Line 87262: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\itb.map (1 hit)
	Line 143802: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\kod.map (1 hit)
	Line 67696: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\krysztalowygrob1.map (4 hits)
	Line 33431: "skin" "tdm_coals_hot"
	Line 33456: "skin" "tdm_coals_hot"
	Line 38208: "skin" "tdm_coals_hot"
	Line 75722: "skin" "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\siegeshop.map (1 hit)
	Line 66081: "skin" "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\training_mission.map (1 hit)
	Line 186146: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\maps\ws4_warrens.map (1 hit)
	Line 32365: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_all\volta1_1\materials\tdm_coals_hotter.mtr (1 hit)
	Line 1: tdm_coals_hot
  H:\NoBackup\darkmod\fms_all\ws4_warrens\maps\ws4_warrens.map (1 hit)
	Line 32365: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_SVN\cutn_beta_2.5.2\CleaningUp.map (1 hit)
	Line 4208: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_SVN\slc\maps\mansion07.map (1 hit)
	Line 22393: "tdm_coals_hot"
  H:\NoBackup\darkmod\fms_SVN\training_mission\training_mission.map (1 hit)
	Line 186146: "tdm_coals_hot"
  H:\NoBackup\darkmod\materials\tdm_models_fireplace.mtr (2 hits)
	Line 477: tdm_coals_hot
	Line 517: tdm_coals_hot_ns
  H:\NoBackup\darkmod\skins\tdm_fireplace.skin (3 hits)
	Line 43: tdm_coals_hot tdm_coals_smouldering
	Line 49: skin tdm_coals_hot
	Line 55: tdm_coals_ash tdm_coals_hot
tdm_coals_hot_references.txt (5,293 bytes)   
Springheel

Springheel

21.01.2019 00:52

administrator   ~0011454

Ok, thanks. From that, it looks like skins won't be an issue.
VanishedOne

VanishedOne

24.02.2019 00:36

developer   ~0011650

Did the fix for this involve a tdm_coals_hot_ns material? I'm asking because I can see cagelamp models referencing it, but it doesn't actually seem to be included in 2.07.
Springheel

Springheel

24.02.2019 18:04

administrator   ~0011654

It should be in tdm_models_fireplace.mtr
VanishedOne

VanishedOne

25.02.2019 00:02

developer   ~0011655

I see tdm_coals_hot in there but get no search results for tdm_coals_hot_ns.
Springheel

Springheel

25.02.2019 00:08

administrator   ~0011656

You're right. It was changed on SVN some time before release but apparently that change was not included in the package for 2.07.

Issue History

Date Modified Username Field Change
19.01.2019 19:55 Springheel New Issue
19.01.2019 19:55 Springheel Status new => assigned
19.01.2019 19:55 Springheel Assigned To => Springheel
19.01.2019 19:55 Springheel Description Updated View Revisions
20.01.2019 18:15 Springheel Note Added: 0011448
20.01.2019 21:38 STiFU Note Added: 0011450
20.01.2019 21:38 STiFU File Added: tdm_coals_hot_references.txt
21.01.2019 00:52 Springheel Note Added: 0011454
21.01.2019 01:19 Springheel Status assigned => resolved
21.01.2019 01:19 Springheel Fixed in Version => TDM 2.07
21.01.2019 01:19 Springheel Resolution open => fixed
24.02.2019 00:36 VanishedOne Note Added: 0011650
24.02.2019 18:04 Springheel Note Added: 0011654
25.02.2019 00:02 VanishedOne Note Added: 0011655
25.02.2019 00:08 Springheel Note Added: 0011656