View Issue Details

IDProjectCategoryView StatusLast Update
0004986The Dark ModGUIpublic12.05.2019 16:25
Reporterwesp5 Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionwon't fix 
PlatformPCOSWindowsOS Version7
Product VersionTDM 2.06 
Target VersionFixed in VersionTDM 2.07 
Summary0004986: Compass turns white when using stencil shadows
DescriptionThe summary says it all. Activating stencil shadows turns the compass white or whitish, depending on the brightness settings. Using shadow maps turns it back to normal.

Newer report:
  http://forums.thedarkmod.com/topic/19973-compass-model-all-whiteuntextured/#entry437234
TagsNo tags attached.

Activities

wesp5

wesp5

05.02.2019 10:29

reporter  

sound_alert_trainer_2019-02-05_11.10.52_stencil.jpg (270,627 bytes)
wesp5

wesp5

05.02.2019 21:28

reporter  

hhi_2019-02-04_19.21.55.jpg (222,030 bytes)
hhi_2019-02-04_19.21.55.jpg (222,030 bytes)
wesp5

wesp5

05.02.2019 21:30

reporter   ~0011544

Last edited: 05.02.2019 21:30

View 2 revisions

On a faster PC the compass stayed white unless Soft Shadows were disabled completely, but after enabling them it continued to look normal!

nbohr1more

nbohr1more

05.02.2019 22:50

developer   ~0011545

This looks like a driver bug.

Are you able to replicate on other graphics hardware?
STiFU

STiFU

06.02.2019 06:42

developer   ~0011547

Can you still reproduce this or was it a one time thing, maybe cured by a config reset?
wesp5

wesp5

06.02.2019 19:57

reporter   ~0011548

This happened to me on two different PCs both with two different NVIDIA GPUs (Geforce 1050 and Geforce 7600). It's reproduceable too, like when I start TDM and load a mission with soft shadows on, it will always be white. After I turn it off, it will become normal and stay even if I turn soft shadows on again afterwards.
duzenko

duzenko

08.02.2019 14:22

developer   ~0011550

Can't repeat on AMD - screenshot attached
A quicksave/viewpos and a .cfg would be great
duzenko

duzenko

08.02.2019 14:22

developer  

Untitled.jpg (404,758 bytes)
wesp5

wesp5

08.02.2019 14:59

reporter   ~0011551

I uploaded a save and my cfg file.
duzenko

duzenko

09.02.2019 13:09

developer   ~0011555

Where do I download that map from?
nbohr1more

nbohr1more

09.02.2019 16:04

developer   ~0011556

Sound Alert Map:

http://www.thedarkmod.com/missiondetails/?id=19
duzenko

duzenko

10.02.2019 08:52

developer   ~0011562

What was this save version?
I can't seem to load it with neither 2.07 nor trunk
Was it 2.06?
Does this still happen in 2.07?
wesp5

wesp5

13.02.2019 08:01

reporter   ~0011582

It was 2.07...
duzenko

duzenko

13.02.2019 19:09

developer   ~0011591

Can anyone else load the save game attached here? Or reproduce the problem elsehow?
wesp5

wesp5

15.02.2019 21:58

reporter   ~0011602

I have some more issues that might be connected. In Lords and Legacy some other inventory items turned completely white, including the backdrop. Again just disabling soft shadows and then enabling it again got rid of all these problems!
wesp5

wesp5

15.02.2019 21:59

reporter  

lordsnlegacy.rar (3,431,186 bytes)
wesp5

wesp5

20.02.2019 19:20

reporter   ~0011632

And another one: In Fiasco at Fauchard Street the map icon was translucent and didn't show the map. This was not corrected by turning soft shadows off and on so it might be something different, maybe Melan just forgot to add a icon version?
wesp5

wesp5

20.02.2019 19:21

reporter  

fauchard1_1_2019-02-19_23.15.39.jpg (489,635 bytes)
wesp5

wesp5

20.02.2019 19:21

reporter  

fauchard1_1_2019-02-19_23.30.42.jpg (432,799 bytes)
AluminumHaste

AluminumHaste

01.04.2019 12:43

developer   ~0011705

@wesp5 the bug report says it's for version 2.06 TDM.
We've had no issues with these maps, I played Fiasco a few weeks ago and it worked fine, Nvidia 980ti latest driver.
wesp5

wesp5

30.04.2019 20:41

reporter   ~0011773

The bug report had only the option 2.06 when I reported this as it hadn't been updated to 2.07! I never had any of these issues in 2.06, only in 2.07...
Judith

Judith

02.05.2019 10:09

reporter   ~0011777

Desktop Nvidia GTX 1060, laptop with integrated Intel Card, both 2.07 no hotfix - cannot reproduce the issue.
stgatilov

stgatilov

04.05.2019 13:26

developer   ~0011780

Last edited: 04.05.2019 13:30

View 2 revisions

Cannot reproduce it on my GeForce.

Next time when someone has this problem, please record everything you can:
1) darkmod.cfg at some moment
2) condump at the moment when you see white compass
3) record all actions you did since TDM start to most precision: did you start new mission of loaded save? what settings did you change and how they relate to saved config file?
Attach everything (add prefix to filenames) here and mention which files you have attached.

UPDATE: Ok, I managed to reproduce it from the save in .rar.
I'll post more info later.

stgatilov

stgatilov

04.05.2019 13:36

developer  

savegames.zip (862,556 bytes)
stgatilov

stgatilov

04.05.2019 13:48

developer   ~0011781

Last edited: 04.05.2019 13:50

View 4 revisions

I have reuploaded the savegames.rar as savegames.zip, with condump included.

The core reason for the problem is, most likely, "r_useFBO 0".
I think we dropped support for it in TDM 2.07 =)
Everyone who have had the "white compass problem" at least once, please set "r_useFBO 1" immediately and forever =)

This cause also explains why compass does not return back to white if you toggle soft shadows or related stuff on and off: you can get into non-FBO mode only if you start TDM afresh with "r_useFBO 0" set in config file.

Unless someone has the white compass issue with "r_useFBO 1", I think we can close this issue.

P.S. wesp5, your controls scheme is crazy =)

duzenko

duzenko

11.05.2019 07:29

developer   ~0011792

Could anyone confirm that r_useFBO 1 fixed it for them?
One other thing might be image_preload 1.
stgatilov

stgatilov

11.05.2019 08:14

developer   ~0011794

One player confirmed it:
  http://forums.thedarkmod.com/topic/19973-compass-model-all-whiteuntextured/#entry437395
wesp5

wesp5

11.05.2019 17:42

reporter   ~0011799

This bug can be fixed by setting r_useFBO 1 which should be default in future TDM versions!
stgatilov

stgatilov

12.05.2019 09:29

developer   ~0011801

I resolve it as "won't fix" because it happens on non-default non-FBO mode, which we don't support starting from 2.07.
duzenko

duzenko

12.05.2019 12:03

developer   ~0011803

Last edited: 12.05.2019 12:03

View 2 revisions

Delete the r_useFBO CVAR_ARCHIVE flag? It's possible for this cvar to auto-switch to 0 if an FBO has failed to initialize.

stgatilov

stgatilov

12.05.2019 16:25

developer   ~0011804

The suggestion about removing "archive" flag is a genius idea!

As far as I see, if we remove it, then:
1) r_useFBO will silently revert to default for everyone, starting from the second TDM launch.
2) If someone really wants to use non-FBO mode, he can do it a) for single launch in order to test, and b) permanently via autoexec.cfg hack.

We can do it, in case there is still some player with r_useFBO 0 by 2.08 =)

Issue History

Date Modified Username Field Change
05.02.2019 10:29 wesp5 New Issue
05.02.2019 10:29 wesp5 File Added: sound_alert_trainer_2019-02-05_11.10.52_stencil.jpg
05.02.2019 21:28 wesp5 File Added: hhi_2019-02-04_19.21.55.jpg
05.02.2019 21:30 wesp5 Note Added: 0011544
05.02.2019 21:30 wesp5 Note Edited: 0011544 View Revisions
05.02.2019 22:50 nbohr1more Note Added: 0011545
06.02.2019 06:42 STiFU Note Added: 0011547
06.02.2019 19:57 wesp5 Note Added: 0011548
08.02.2019 14:22 duzenko Note Added: 0011550
08.02.2019 14:22 duzenko File Added: Untitled.jpg
08.02.2019 14:59 wesp5 File Added: savegames.rar
08.02.2019 14:59 wesp5 Note Added: 0011551
09.02.2019 13:09 duzenko Note Added: 0011555
09.02.2019 16:04 nbohr1more Note Added: 0011556
10.02.2019 08:52 duzenko Note Added: 0011562
13.02.2019 08:01 wesp5 Note Added: 0011582
13.02.2019 19:09 duzenko Note Added: 0011591
15.02.2019 21:58 wesp5 Note Added: 0011602
15.02.2019 21:59 wesp5 File Added: lordsnlegacy.rar
20.02.2019 19:20 wesp5 Note Added: 0011632
20.02.2019 19:21 wesp5 File Added: fauchard1_1_2019-02-19_23.15.39.jpg
20.02.2019 19:21 wesp5 File Added: fauchard1_1_2019-02-19_23.30.42.jpg
01.04.2019 12:43 AluminumHaste Note Added: 0011705
30.04.2019 20:41 wesp5 Note Added: 0011773
02.05.2019 10:09 Judith Note Added: 0011777
03.05.2019 04:52 stgatilov Description Updated View Revisions
04.05.2019 13:26 stgatilov Note Added: 0011780
04.05.2019 13:30 stgatilov Note Edited: 0011780 View Revisions
04.05.2019 13:35 stgatilov File Deleted: savegames.rar
04.05.2019 13:36 stgatilov File Added: savegames.zip
04.05.2019 13:48 stgatilov Note Added: 0011781
04.05.2019 13:48 stgatilov Note Edited: 0011781 View Revisions
04.05.2019 13:50 stgatilov Note Edited: 0011781 View Revisions
04.05.2019 13:50 stgatilov Note Edited: 0011781 View Revisions
11.05.2019 07:29 duzenko Note Added: 0011792
11.05.2019 08:14 stgatilov Note Added: 0011794
11.05.2019 17:42 wesp5 Note Added: 0011799
12.05.2019 09:28 stgatilov Assigned To => stgatilov
12.05.2019 09:28 stgatilov Status new => assigned
12.05.2019 09:29 stgatilov Note Added: 0011801
12.05.2019 09:29 stgatilov Status assigned => resolved
12.05.2019 09:29 stgatilov Fixed in Version => TDM 2.07
12.05.2019 09:29 stgatilov Resolution open => won't fix
12.05.2019 12:03 duzenko Note Added: 0011803
12.05.2019 12:03 duzenko Note Edited: 0011803 View Revisions
12.05.2019 16:25 stgatilov Note Added: 0011804