View Issue Details

IDProjectCategoryView StatusLast Update
0005013The Dark ModModelspublic16.03.2020 11:54
ReporterVanishedOne Assigned ToDragofer  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.07 
Summary0005013: Collision mesh on models/darkmod/junk/stoup_broken.ase causes error on atdm:moveable_junk_stoup_broken
DescriptionAdding atdm:moveable_junk_stoup_broken to a map causes it to fail to load, with the error message 'cannot load collision model models/darkmod/junk/stoup_broken.ase'

The model doesn't cause this error as a func_static, only as a moveable. Maybe the shape of the collision hull is too concave for the moveable physics?
Additional InformationIt would actually make a pretty odd-looking moveable, since the visual model is clearly broken into several pieces. It might be best just to remove the atdm:moveable_junk_stoup_broken entity def unless there's evidence that it worked once.
TagsNo tags attached.

Activities

Dragofer

Dragofer

16.03.2020 11:53

developer   ~0012280

The error stems from the concave collision mesh, only convex meshes are allowed.

Since the broken stoup consists of many small fragments, I agree that it shouldn't exist as a single moveable. I've deleted the unusable entity (Rev 15848) and opened a new ticket (0005181) to create multiple smaller moveables out of the broken stoup model.

Issue History

Date Modified Username Field Change
15.03.2019 17:45 VanishedOne New Issue
15.03.2019 17:50 VanishedOne Additional Information Updated View Revisions
15.03.2019 17:51 VanishedOne Summary Collision mesh on models/darkmod/junk/stoup_broken.ase causes error => Collision mesh on models/darkmod/junk/stoup_broken.ase causes error on atdm:moveable_junk_stoup_broken
16.03.2020 11:53 Dragofer Note Added: 0012280
16.03.2020 11:54 Dragofer Assigned To => Dragofer
16.03.2020 11:54 Dragofer Status new => resolved
16.03.2020 11:54 Dragofer Resolution open => fixed