View Issue Details

IDProjectCategoryView StatusLast Update
0005030The Dark ModCodingpublic05.05.2019 17:40
Reporterstgatilov Assigned Toduzenko  
PriorityhighSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionTDM 2.07 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0005030: TDM sometimes crashes after finishing mission v2
DescriptionI see reports from people on TDM 2.07 (not sure hotfix or not) that TDM crashes when they finish mission. Moreover, loading the autosave (done on mission finish) crashes also.
Steps To Reproduce1) Start "William Steele 5: Commerce Bank" mission.
2) Run to the end of the streets and backwards.
3) Execute in console: tdm_end_mission.
darkmod.cfg is attached.
Additional InformationLinks:
1) http://forums.thedarkmod.com/topic/19957-fan-mission-commerce-bank-by-grayman-2019410/#entry436695
2) http://forums.thedarkmod.com/topic/19935-beta-testing-207-hotfix/page-2#entry436860 and http://forums.thedarkmod.com/topic/19935-beta-testing-207-hotfix/page-2#entry436865
TagsNo tags attached.

Activities

stgatilov

stgatilov

25.04.2019 16:12

developer   ~0011766

Note: I chose assignee rather randomly. If someone has already looked into the problem, feel free to reassign to yourself.
duzenko

duzenko

25.04.2019 18:14

developer   ~0011768

@stgatilov

Can you repeat this? If so, can you attach a stack trace?
stgatilov

stgatilov

04.05.2019 11:50

developer  

Darkmod.cfg (12,629 bytes)
stgatilov

stgatilov

04.05.2019 11:52

developer  

shadowmap_crash.png (82,700 bytes)
shadowmap_crash.png (82,700 bytes)
stgatilov

stgatilov

04.05.2019 11:54

developer   ~0011779

Last edited: 04.05.2019 14:57

View 2 revisions

I have managed to reproduce it on current Debug With Inlines (although I used my glimp_4820 branch) on NVIDIA.
See "Steps to Reproduce " above.

Basically, it crashes on some "shadowmap-only" surface, when retrieving its "shadow map offset". Both things sound like hacks to me =)

It seems to be not perfectly reproducible: try a few times.

duzenko

duzenko

05.05.2019 17:40

developer   ~0011783

Thanks for debugging this for me

Revision: 8215

Issue History

Date Modified Username Field Change
25.04.2019 16:11 stgatilov New Issue
25.04.2019 16:11 stgatilov Status new => assigned
25.04.2019 16:11 stgatilov Assigned To => duzenko
25.04.2019 16:12 stgatilov Note Added: 0011766
25.04.2019 18:14 duzenko Note Added: 0011768
04.05.2019 11:48 stgatilov Steps to Reproduce Updated View Revisions
04.05.2019 11:50 stgatilov File Added: Darkmod.cfg
04.05.2019 11:50 stgatilov Steps to Reproduce Updated View Revisions
04.05.2019 11:52 stgatilov File Added: shadowmap_crash.png
04.05.2019 11:54 stgatilov Note Added: 0011779
04.05.2019 14:57 stgatilov Note Edited: 0011779 View Revisions
05.05.2019 17:40 duzenko Note Added: 0011783
05.05.2019 17:40 duzenko Status assigned => resolved
05.05.2019 17:40 duzenko Fixed in Version => TDM 2.08
05.05.2019 17:40 duzenko Resolution open => fixed