View Issue Details

IDProjectCategoryView StatusLast Update
0005053The Dark ModAIpublic01.01.2020 14:11
ReporterVanishedOne Assigned Tostgatilov  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionreopened 
Product VersionTDM 2.07 
Fixed in VersionTDM 2.08 
Summary0005053: Lanternbot still has lit appearance after 'knockout'
DescriptionWhen a lanternbot is 'killed', parm7 is faded to 0 by tdm_ai_lanternbot::onDeath(), which fades down the bright yellow flickering of the lantern glass surface using the lanternbot_lit material.

However, lanternbots can also be disabled with the blackjack, and when that happens the actual light goes out but the lit material on the body is unchanged.
Additional InformationSpeaking of lanternbot_lit colouration, why are the diffuse colour parms multiplied by each other?

{
        blend diffusemap
        map models/md5/chars/steambots/bc_lanternbot
        rgb parm0 * parm1 * parm2
    }

The lanternbot has default "_color" "0.7 0.64 0" so presumably the result is rgb 0.
TagsNo tags attached.

Activities

stgatilov

stgatilov

30.12.2019 17:58

developer   ~0011990

By the way, a live lantern bot can be found in "In The Black" FM by executing: setviewpos 4448 3744 16
stgatilov

stgatilov

31.12.2019 06:34

developer   ~0011994

Added "ko_immune" "1" to base steambot in svn rev 15760.
It was intended that bots cannot be knocked out, but "ko_zone" "" has no effect because damage zones are not defined (and are consequently all empty strings too).
The bot is also immune to gas, so I guess nobody will ever knock it out again =)
VanishedOne

VanishedOne

31.12.2019 13:36

developer   ~0012000

Intended or not, that's a pretty major gameplay change in the difficulty of dealing with an AI that's been around for years. Did you consult anyone else?

When wesp5 wanted oil lamps made snuffable through frobbing to bring them in line with candles, his proposal was rejected on the grounds that maps' gameplay design shouldn't be changed retroactively, even if in principle the idea was sound.
stgatilov

stgatilov

31.12.2019 19:17

developer   ~0012003

Well, I wrote about it on public forums.
Speaking of lantern bots, the difficulty change is minor, since they can be killed with a sword just as easily.
VanishedOne

VanishedOne

01.01.2020 14:11

developer   ~0012005

Oh, I see. Linking to thread: https://forums.thedarkmod.com/index.php?/topic/11155-lanternbot-relations/&tab=comments#comment-442370

Fair point, most missions do provide the sword and blackjack at the same time, though it isn't universal.

Issue History

Date Modified Username Field Change
13.09.2019 16:29 VanishedOne New Issue
13.09.2019 17:04 VanishedOne Additional Information Updated View Revisions
30.12.2019 17:58 stgatilov Note Added: 0011990
31.12.2019 06:34 stgatilov Note Added: 0011994
31.12.2019 06:34 stgatilov Assigned To => stgatilov
31.12.2019 06:34 stgatilov Status new => resolved
31.12.2019 06:34 stgatilov Resolution open => fixed
31.12.2019 06:34 stgatilov Fixed in Version => TDM 2.08
31.12.2019 13:36 VanishedOne Status resolved => feedback
31.12.2019 13:36 VanishedOne Resolution fixed => reopened
31.12.2019 13:36 VanishedOne Note Added: 0012000
31.12.2019 19:17 stgatilov Note Added: 0012003
01.01.2020 14:11 VanishedOne Note Added: 0012005
01.01.2020 14:11 VanishedOne Status feedback => assigned