View Issue Details

IDProjectCategoryView StatusLast Update
0005055The Dark ModGraphicspublic29.12.2019 11:34
ReporterMirceaKitsune Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSLinux openSUSEOS VersionRelease
Product VersionTDM 2.07 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0005055: Incorrect shadow mapping when using Stencil shadows + Soft shadowing
DescriptionThere seems to be an issue with shadow rendering in the engine: When enabling both Stencil Shadows and Soft Shadows, shadows get incorrectly mapped and are stretched across the screen in front of the camera. I have no issues when using Stencil Shadows without shadow softness, nor when using Map Shadows both with and without soft shadows.

I attached two screenshots from the FM Full Moon Fever: The first shows stencil shadows without softness (normal results) and the second is stencil shadows with softness (corrupt shadows).
Steps To ReproduceGo to: Settings - Video - Advanced - Experimental Features. In this menu set: Shadows Implementation = Stencil, Soft Shadows Quality > Off (Low, Medium, High, Very High). Linux users with AMD video cards using the amdgpu module and Mesa should notice the corrupt shadows.
Additional InformationI'm running TDM 2.07 x64. My operating system is Linux openSUSE Tumbleweed x64. Kernel 5.2.14. Mesa 19.1.7 (amdgpu module). My video card is an AMD Radeon XFX R9 390.
Tagsengine, rendering, shadows

Relationships

related to 0005085 resolvedduzenko r_fboResolution greater than 1: skybox and flame 

Activities

MirceaKitsune

MirceaKitsune

24.09.2019 12:43

reporter  

stgatilov

stgatilov

13.11.2019 02:53

developer   ~0011863

Could you please attach darkmod.cfg and condump with soft shadows enabled?
Do you have the 2.07 hotfix version? (You can run tdm_update and try again to ensure it)
Given that 2.07 is out for quite some time, did this problem come up recently? Was/is it working in 2.06 (if you played it) ?
stgatilov

stgatilov

07.12.2019 17:26

developer   ~0011897

Let's watch over this problem during 2.08 beta.
The rendering has changed a lot since 2.07, including the almost finished Core Profile.
Judith

Judith

14.12.2019 14:02

reporter   ~0011928

That looks like Render Scale set to something other than 1 with Stencil Shadows. That feature works with Shadow Maps only.
stgatilov

stgatilov

14.12.2019 16:40

developer   ~0011930

Probably related: 0005068 (non-default r_fboResolution is buggy underwater).

It would be interesting to check if the problem can be reproduced with r_fboResolution + stencil shadows. Such case should either work properly or be impossible to set via menu graphical settings,
stgatilov

stgatilov

14.12.2019 16:59

developer   ~0011931

Last edited: 14.12.2019 17:01

View 2 revisions

I can confirm that I see this issue with:
  r_fboResolution 2 (or 0.5)
  r_shadows 1
  r_softShadowsQuality 12
on any map.

With r_fboResolution > 1 I see some additional weird effects on skybox and torch flames.
These effects do NOT go away if I switch to shadow maps.

MirceaKitsune

MirceaKitsune

14.12.2019 17:02

reporter   ~0011932

Interesting. Indeed this sounds like it might be related to 0005068 which was also caused by having r_fboResolution set to a value above 1. I changed that in my config so I should no longer be getting this either.
stgatilov

stgatilov

14.12.2019 17:09

developer   ~0011933

Here is the config file to be sure it could be reproduced.

Darkmod.cfg (12,742 bytes)
duzenko

duzenko

29.12.2019 07:11

developer   ~0011953

I can repeat this on my side too
duzenko

duzenko

29.12.2019 08:51

developer   ~0011957

Completed: At revision: 8471
stgatilov

stgatilov

29.12.2019 09:15

developer   ~0011959

The problem with r_fboResolution > 1 are still present:
  when I look at skybox, it becomes brighter every frame (getting VERY bright)
  when I look at flame, haze effect is broken
With r_fboResolution < 1 it does not look bad, but I guess it still does not work as intended.

Should I create anothenr issue for it?
duzenko

duzenko

29.12.2019 10:44

developer   ~0011964

Yeah, I think a separate issue would be great, because I can't repeat it yet

Issue History

Date Modified Username Field Change
24.09.2019 12:43 MirceaKitsune New Issue
24.09.2019 12:43 MirceaKitsune Tag Attached: engine
24.09.2019 12:43 MirceaKitsune Tag Attached: rendering
24.09.2019 12:43 MirceaKitsune Tag Attached: shadows
24.09.2019 12:43 MirceaKitsune File Added: fever_2019-09-24_03.37.34.jpg
24.09.2019 12:43 MirceaKitsune File Added: fever_2019-09-24_03.37.42.jpg
13.11.2019 02:53 stgatilov Note Added: 0011863
07.12.2019 17:26 stgatilov Status new => feedback
07.12.2019 17:26 stgatilov Target Version => TDM 2.08
07.12.2019 17:26 stgatilov Note Added: 0011897
14.12.2019 14:02 Judith Note Added: 0011928
14.12.2019 16:40 stgatilov Note Added: 0011930
14.12.2019 16:59 stgatilov Note Added: 0011931
14.12.2019 16:59 stgatilov Assigned To => stgatilov
14.12.2019 16:59 stgatilov Status feedback => confirmed
14.12.2019 17:01 stgatilov Note Edited: 0011931 View Revisions
14.12.2019 17:02 MirceaKitsune Note Added: 0011932
14.12.2019 17:09 stgatilov File Added: Darkmod.cfg
14.12.2019 17:09 stgatilov Note Added: 0011933
29.12.2019 05:41 stgatilov Assigned To stgatilov => duzenko
29.12.2019 07:11 duzenko Note Added: 0011953
29.12.2019 08:51 duzenko Status confirmed => resolved
29.12.2019 08:51 duzenko Resolution open => fixed
29.12.2019 08:51 duzenko Fixed in Version => TDM 2.08
29.12.2019 08:51 duzenko Note Added: 0011957
29.12.2019 09:15 stgatilov Note Added: 0011959
29.12.2019 10:44 duzenko Note Added: 0011964
29.12.2019 11:34 stgatilov Relationship added related to 0005085