View Issue Details

IDProjectCategoryView StatusLast Update
0005083The Dark ModGraphicspublic29.12.2019 07:58
Reporterstgatilov Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0005083: Player-held weapons are no longer lit
DescriptionIf you take out a sword, it is completely black, regardless of light sources nearby (lantern or candle).
In 2.07, held weapons are properly lit by surrounding lights.
Steps To ReproduceThe starting area in Closemouthed Shadows FM is good enough, since it has both sword at start and a candle in the starting area.
Additional InformationBy bisecting through history, I found that it got broken by source code changes in the beginning of October 2019.
  svn rev 8355: works properly
  svn rev 8376: does not work
I could not further reduce the range, because the intermediate SVN revisions don't compile.
TagsNo tags attached.

Activities

duzenko

duzenko

29.12.2019 07:13

developer   ~0011954

I can repeat this on my side too
duzenko

duzenko

29.12.2019 07:35

developer   ~0011955

Seemingly broken by multi-draw calls in depth pass
duzenko

duzenko

29.12.2019 07:58

developer   ~0011956

Completed: At revision: 8470

Issue History

Date Modified Username Field Change
29.12.2019 05:36 stgatilov New Issue
29.12.2019 05:36 stgatilov Status new => assigned
29.12.2019 05:36 stgatilov Assigned To => duzenko
29.12.2019 05:44 stgatilov Steps to Reproduce Updated View Revisions
29.12.2019 07:13 duzenko Note Added: 0011954
29.12.2019 07:35 duzenko Note Added: 0011955
29.12.2019 07:58 duzenko Status assigned => resolved
29.12.2019 07:58 duzenko Resolution open => fixed
29.12.2019 07:58 duzenko Fixed in Version => TDM 2.08
29.12.2019 07:58 duzenko Note Added: 0011956