View Issue Details

IDProjectCategoryView StatusLast Update
0005095DarkRadiantGUIpublic09.01.2020 19:25
ReporterDragofer Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindowsOS Version10
Product Version2.7.0 
Target Version2.7.0Fixed in Version2.7.0 
Summary0005095: Search box persists for some seconds after closing window or shifting focus
DescriptionThe new search box in 2.7 always stays onscreen for some seconds even though the window(widget) it came from has been closed down or is no longer in focus. It's even still shown if I alt-tab out of DR to report this bug. The text box no longer allows me to change or highlight the text, but the arrow buttons still work.

Cases where I've observed lingering search boxes so far are:
A) Searching in 'Create model' and clicking ok or cancel without having pressed escape to close the search box. If I quickly reopen 'Create model', click on the newly opened window and type something the search box stays up and can be used normally. Same goes for 'Create entity' or 'Insert prefab'.
B) Searching in the media browser or entity inspector. If I shift focus, i.e. to orthoview, the search box persists some seconds: the arrow buttons still work, but I can't enter text after clicking on the text field. If I quickly shift focus back to the media browser/entity inspector the search box stays and can be used normally again.

The search box doesn't linger in 'Create speaker'.
Steps To ReproduceFor 'Create model'
1) 'Create model', click in the list to set focus on this new window
2) Type in 'sto', you'll highlight a stone arch.
3) Press on ok or cancel. The search box stays open even if alt-tabbing out of DR. Text can't be entered, but the arrow buttons still respond to clicks.

Optional:
4) Quickly reopen 'Create model' and click in the list again before the search box disappears.
5) Type in 'ol' so the search box now contains 'stool'. It'll highlight a stool for you.
TagsNo tags attached.

Activities

Dragofer

Dragofer

02.01.2020 11:42

reporter  

greebo

greebo

04.01.2020 04:36

administrator   ~0012052

Fixed in 12f38b30a. The search popup now detects if the parent window is minimized, hidden, moved or losing focus.
Dragofer

Dragofer

07.01.2020 08:30

reporter   ~0012105

(I'm assuming I shouldn't open a new issue when providing feedback for an issue that's been set as resolved)
Testing the fix in 2.7pre3:
Case A looks to have been solved completely, wasn't able to get a lingering search box when using a right-click menu like Create model or Insert prefab anymore.

However, Case B still seems to be there:
If I search something in the media browser or entity inspector, then click on orthoview or switch to entity inspector/media browser respectively, the box still takes some time to disappear.
Unlike Case A this could even be useful behaviour, but at present you can't click on the text field to keep typing, you need to click into the media browser/entity inspector first.
Dragofer

Dragofer

07.01.2020 08:30

reporter   ~0012106

See my latest note (didn't know I can post a note with reopening an issue)
Dragofer

Dragofer

07.01.2020 08:37

reporter   ~0012107

In any case, I think the search box should disappear as soon as you switch between media browser <-> entity inspector. At present I can have 2 boxes visible simultaneously.
greebo

greebo

07.01.2020 18:45

administrator   ~0012114

Another fix attempt is in a40214dc9. The popup will now close when the user clicks on anything outside the active tree view.

Related Changesets

DarkRadiant: master 12f38b30

2020-01-04 05:34:08

greebo

Details Diff
Resolve 0005095: When the parent window is losing focus (e.g. by alt-tabbing to a different app), dismiss the search popup window Affected Issues
0005095
mod - libs/wxutil/TreeView.cpp Diff File

Issue History

Date Modified Username Field Change
02.01.2020 11:42 Dragofer New Issue
02.01.2020 11:42 Dragofer File Added: Persisting search field.png
02.01.2020 11:45 Dragofer Description Updated View Revisions
02.01.2020 12:47 greebo Status new => acknowledged
02.01.2020 18:03 greebo Status acknowledged => confirmed
02.01.2020 18:03 greebo Product Version => 2.7.0
02.01.2020 18:03 greebo Target Version => 2.7.0
04.01.2020 04:19 greebo Assigned To => greebo
04.01.2020 04:19 greebo Status confirmed => assigned
04.01.2020 04:36 greebo Status assigned => resolved
04.01.2020 04:36 greebo Resolution open => fixed
04.01.2020 04:36 greebo Fixed in Version => 2.7.0
04.01.2020 04:36 greebo Note Added: 0012052
07.01.2020 08:30 Dragofer Note Added: 0012105
07.01.2020 08:30 Dragofer Status resolved => assigned
07.01.2020 08:30 Dragofer Resolution fixed => reopened
07.01.2020 08:30 Dragofer Note Added: 0012106
07.01.2020 08:37 Dragofer Note Added: 0012107
07.01.2020 18:45 greebo Status assigned => resolved
07.01.2020 18:45 greebo Note Added: 0012114
09.01.2020 19:25 greebo Changeset attached => DarkRadiant master 12f38b30
09.01.2020 19:25 greebo Resolution reopened => fixed