View Issue Details

IDProjectCategoryView StatusLast Update
0005104DarkRadiantModelspublic09.01.2020 19:25
ReporterBikerdude Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version8.1
Product Version2.6.0 
Target Version2.7.0Fixed in Version2.7.0 
Summary0005104: Exporting bell_hand.lwo as ASE is producing an invalid model, which will fail to dmap
DescriptionExporting the hand bell model as ASE seems to have an issue causing a console error in TDM:

- 'ERROR: *MESH_TFACELIST before *MESH_FACE_LIST'

Steps To Reproduce- Open attached map
- Select the bell
- File > Export selected as model..
-- Format: ASE with these options checked:
-- Center objects around origin
-- Replace Selection with exported Model
- Export
- Run the game and dmap => error
Additional InformationI attached the .ASE file that caused the mesh error.
TagsNo tags attached.

Activities

Bikerdude

Bikerdude

03.01.2020 12:50

reporter  

random_shelf_items_1.ase (762,382 bytes)
greebo

greebo

05.01.2020 04:56

administrator   ~0012068

I exported a couple of new models (one from a set of brushes, and another one from two models to create a combined one) - this worked, both in DR 2.6.0 as well as in the current pre-release. The game could load the models just fine.

I can confirm that the attached .ASE is causing the error, but I need more information here. Can you give me more steps about how you created that ASE? It might be related to a specific source model.
Bikerdude

Bikerdude

05.01.2020 19:20

reporter   ~0012078

I just selected all 4 items (3x book models and hand_bell model) and then selected export as model, something I have done hundreds of times in this map.
greebo

greebo

06.01.2020 04:15

administrator   ~0012082

Ok, seems like the bell model is causing the problem, when it's exported in ASE format, I'll update the description.
And it's also happening in 2.6.0.
greebo

greebo

06.01.2020 04:20

administrator  

bell.7z (771 bytes)
greebo

greebo

06.01.2020 04:38

administrator  

broken_bell.ase.7z (6,325 bytes)
greebo

greebo

06.01.2020 04:38

administrator   ~0012087

The error in game seems to be caused by this empty geometry in the exported ASE file. Removing it solves the dmap problem

*GEOMOBJECT {
    *NODE_NAME "mesh1"
    *NODE_TM {
        *NODE_NAME "mesh1"
        *INHERIT_POS 0 0 0
        *INHERIT_ROT 0 0 0
        *INHERIT_SCL 0 0 0
        *TM_ROW0 1.0000 0.0000 0.0000
        *TM_ROW1 0.0000 1.0000 0.0000
        *TM_ROW2 0.0000 0.0000 1.0000
        *TM_ROW3 0.0000 0.0000 0.0000
        *TM_POS 0.0000 0.0000 0.0000
        *TM_ROTAXIS 0.0000 0.0000 0.0000
        *TM_ROTANGLE 0.0000
        *TM_SCALE 1.0000 1.0000 1.0000
        *TM_SCALEAXIS 0.0000 0.0000 0.0000
        *TM_SCALEAXISANG 0.0000
    }
    *MESH {
        *TIMEVALUE 0
        *MESH_NUMVERTEX 0
        *MESH_NUMFACES 0
        *MESH_VERTEX_LIST {
        }
        *MESH_FACE_LIST {
        }
        *MESH_NUMTVERTEX 0
        *MESH_TVERTLIST {
        }
        *MESH_NUMTVFACES 0
        *MESH_TFACELIST {
        }
        *MESH_NUMCVERTEX 0
        *MESH_CVERTLIST {
        }
        *MESH_NUMCVFACES 0
        *MESH_CFACELIST {
        }
        *MESH_NORMALS {
        }
    }
    *PROP_MOTIONBLUR 0
    *PROP_CASTSHADOW 1
    *PROP_RECVSHADOW 1
    *MATERIAL_REF 1
}
greebo

greebo

06.01.2020 12:34

administrator   ~0012093

Fixed in a907deaa0
Bikerdude

Bikerdude

06.01.2020 19:18

reporter   ~0012097

Thanks for sorting that and fixing the stock model causing the issue, that last one was on my todo this evening...

And moving forward I will try and be more detailed in the summary and steps to Reproduce.

Related Changesets

DarkRadiant: master a907deaa

2020-01-06 13:09:10

greebo

Details Diff
Fix 0005104: Exporting ASE with empty surfaces was producing invalid model files, which failed to dmap Affected Issues
0005104
mod - radiant/modelfile/AseExporter.cpp Diff File

Issue History

Date Modified Username Field Change
03.01.2020 12:45 Bikerdude New Issue
03.01.2020 12:50 Bikerdude File Added: random_shelf_items_1.ase
03.01.2020 12:52 Bikerdude Severity major => normal
03.01.2020 12:52 Bikerdude Additional Information Updated View Revisions
05.01.2020 04:53 greebo Product Version 2.6.0 => 2.7.0
05.01.2020 04:56 greebo Note Added: 0012068
05.01.2020 04:56 greebo Status new => feedback
05.01.2020 04:58 greebo Description Updated View Revisions
05.01.2020 19:20 Bikerdude Note Added: 0012078
05.01.2020 19:20 Bikerdude Status feedback => new
06.01.2020 04:15 greebo Note Added: 0012082
06.01.2020 04:20 greebo Status new => confirmed
06.01.2020 04:20 greebo Product Version 2.7.0 => 2.6.0
06.01.2020 04:20 greebo Summary DR 2.7 pre2 - Model exporter is borking .ASE models => Exporting bell_hand.lwo as ASE is producing an invalid model, which will fail to dmap
06.01.2020 04:20 greebo Description Updated View Revisions
06.01.2020 04:20 greebo Steps to Reproduce Updated View Revisions
06.01.2020 04:20 greebo File Added: bell.7z
06.01.2020 04:38 greebo File Added: broken_bell.ase.7z
06.01.2020 04:38 greebo Note Added: 0012087
06.01.2020 05:00 greebo Assigned To => greebo
06.01.2020 05:00 greebo Status confirmed => assigned
06.01.2020 05:00 greebo Target Version => 2.7.0
06.01.2020 12:34 greebo Status assigned => resolved
06.01.2020 12:34 greebo Resolution open => fixed
06.01.2020 12:34 greebo Fixed in Version => 2.7.0
06.01.2020 12:34 greebo Note Added: 0012093
06.01.2020 19:18 Bikerdude Note Added: 0012097
07.01.2020 03:35 greebo Category Scripting => Models
09.01.2020 19:25 greebo Changeset attached => DarkRadiant master a907deaa