View Issue Details

IDProjectCategoryView StatusLast Update
0005110DarkRadiantScriptingpublic13.11.2020 16:55
ReporterBikerdude Assigned To 
PrioritynormalSeveritynormalReproducibilitysometimes
Status closedResolutionunable to reproduce 
PlatformPCOSWindowsOS Version8.1
Product Version2.6.0 
Summary0005110: Exported .ASE models become non-solid
Description.ASE are almost always guaranteed to become non-solid where .LWO sometimes will be solid - at a guess I think this maybe be something to with collision models not being exported..?
Steps To Reproduce- Open DR.
- Go into Orthoview.
- Select the item/s you want to export as a single model.
- Go to file menu and select 'Export selected as model'>
-- select center objects around origin.
-- skip surfaces with caulk.
-- replace selected with model.
TagsNo tags attached.

Activities

Bikerdude

Bikerdude

06.01.2020 21:03

reporter  

Bikerdude

Bikerdude

06.01.2020 23:12

reporter   ~0012099

Just did a test export in 2.7pre2 and now both .ASE and .LWO models are solid in-game, yet not 2 days ago the same prceedure resulted in a non-solid .ASE model in the new area I am working on.
greebo

greebo

07.01.2020 03:07

administrator   ~0012100

So the problem is not occurring anymore? Could this possibly have been caused by dmapping problems? I've had this in the past, where the dmap would just fail and loading the map would use the outdated collision model.
Bikerdude

Bikerdude

07.01.2020 07:28

reporter   ~0012104

Let me continue to test it, as it was never fixed in 2.6 as I have loads of .LWO/ASE models in this map that are all non-solid. I will see if rexporting ones that the Ai/Player interactive with then become solid and I will come back to you.
Bikerdude

Bikerdude

12.01.2020 12:38

reporter   ~0012132

Did some more testing and annoying not all models are affected (as in become non solid) -

In my instance I have selected a bunch of different models and export them as a single .ASE model, here are some of the models that were exported the sing;le model - -

models/darkmod/furniture/tables/table_tavern01.lwo - SOLID
models/darkmod/furniture/shelves/winerack.ase - SOLID
models/darkmod/furniture/shelves/wall_shelf_tall01.lwo - SOLID

models/darkmod/kitchen/stove_small.lwo - NON-SOLID
models/darkmod/kitchen/skillet01.lwo - NON-SOLID
models/darkmod/kitchen/pot_stove01.lwo - - NON-SOLID

Hopefully this provide enough of a variation in models to explain why some and solid and other not.







Bikerdude

Bikerdude

12.01.2020 13:04

reporter   ~0012133

Scratch the above solid - non-solid comparison, that was a dmap anomaly.

- Did a re-export above models.
- deleted all generated maps files.
- ran map and in-game models and non-solid again.

Maybe its the conversion from .LWO to .ASE?
Bikerdude

Bikerdude

05.05.2020 15:40

reporter   ~0012466

@Greebo, would you like me to create a test map with reproducible, on-demand results..?
Bikerdude

Bikerdude

08.10.2020 09:49

reporter   ~0012794

I have narrowed down the reproducability, but it does seem to happen more on .LWO models.
Bikerdude

Bikerdude

09.10.2020 21:18

reporter   ~0012808

Let me knock up a test map and post it here.
Bikerdude

Bikerdude

03.11.2020 12:29

reporter   ~0012855

Sorry for the delay, I will create the test map this week!
Bikerdude

Bikerdude

08.11.2020 19:57

reporter   ~0012872

Last edited: 13.11.2020 16:49

View 4 revisions

Another update on this, while working on the final version of TPW 1.1 I have noticed a bunch of models that were non-solid are now solid.

@Greebo, would you still like me to make a test map? or shall we suspend this for now..?
greebo

greebo

09.11.2020 03:41

administrator   ~0012878

Well, I can't really tell what is going on and what the problem is. If there is a problem, then I need to be able to make it happen on my end, otherwise I cannot do anything about it.

A possible approach might be to verify if this issue is actually caused by the model exporter, i.e. the actual .ASE or .LWO file is faulty. If the model file itself is OK and is working fine in a different map, then this is very unlikely to be caused by the model exporter, but maybe a dmap problem in the original map or something else.
Bikerdude

Bikerdude

10.11.2020 20:21

reporter   ~0012887

Ok, leave it with me.
Bikerdude

Bikerdude

13.11.2020 10:51

reporter   ~0012900

Small update, did an export of a several .LWO & .ASE models into a single .LWO model and it remained solid in-game. Will keep testing.
Bikerdude

Bikerdude

13.11.2020 16:48

reporter   ~0012904

Last edited: 13.11.2020 16:51

View 3 revisions

As part of the fixing of the the models with bad rotation in The Elixir at Stgatilov's request, I consolidated a lot of models (both ASE & LWO) into .ASE and LWO and all of them are confirmed solid used DR 2.9pre2 and TDM 2.09 (dev16017-8976).

The only difference between The Elixir and The Painters Wife is map size & compexity, but beyond that I dont know why the issue only happens in TPW.

So I think its safe at this point to provisionally close this tracker. Or would you still like me to tray and narrow it down via your suggest approach "Verify if this issue is actually caused by the model exporter, i.e. the actual .ASE or .LWO file is faulty. If the model file itself is OK and is working fine in a different map, then this is very unlikely to be caused by the model exporter, but maybe a dmap problem in the original map or something else."

Issue History

Date Modified Username Field Change
06.01.2020 21:03 Bikerdude New Issue
06.01.2020 21:03 Bikerdude File Added: Export Selected as model_non-solid.JPG
06.01.2020 21:14 Bikerdude Summary Exported models .ase or .LWO become non-solid => Exported models become non-solid
06.01.2020 21:14 Bikerdude Description Updated View Revisions
06.01.2020 22:02 Bikerdude Description Updated View Revisions
06.01.2020 22:02 Bikerdude Steps to Reproduce Updated View Revisions
06.01.2020 23:12 Bikerdude Note Added: 0012099
07.01.2020 03:07 greebo Note Added: 0012100
07.01.2020 07:28 Bikerdude Note Added: 0012104
12.01.2020 12:38 Bikerdude Summary Exported models become non-solid => Exported .ASE models become non-solid
12.01.2020 12:38 Bikerdude Note Added: 0012132
12.01.2020 13:04 Bikerdude Note Added: 0012133
12.01.2020 16:47 greebo Status new => acknowledged
05.05.2020 15:40 Bikerdude Note Added: 0012466
08.10.2020 09:49 Bikerdude Note Added: 0012794
09.10.2020 21:19 Bikerdude Note Added: 0012808
03.11.2020 12:29 Bikerdude Note Added: 0012855
08.11.2020 19:57 Bikerdude Note Added: 0012872
08.11.2020 19:57 Bikerdude Note Edited: 0012872 View Revisions
08.11.2020 19:57 Bikerdude Note Edited: 0012872 View Revisions
09.11.2020 03:41 greebo Note Added: 0012878
10.11.2020 20:21 Bikerdude Note Added: 0012887
13.11.2020 10:51 Bikerdude Note Added: 0012900
13.11.2020 16:48 Bikerdude Note Added: 0012904
13.11.2020 16:49 Bikerdude Note Edited: 0012904 View Revisions
13.11.2020 16:49 Bikerdude Note Edited: 0012872 View Revisions
13.11.2020 16:51 Bikerdude Note Edited: 0012904 View Revisions
13.11.2020 16:55 greebo Status acknowledged => closed
13.11.2020 16:55 greebo Resolution open => unable to reproduce