View Issue Details

IDProjectCategoryView StatusLast Update
0005127DarkRadiantMap Editingpublic24.01.2021 18:33
Reporterkingsal Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.6.0 
Target Version2.11.0Fixed in Version2.11.0 
Summary0005127: Managing favorite resources (entities, textures,...)
DescriptionI spoke with Greebo about getting an all encompassing favorites menu where mappers and can any entity/ model/ or brush group to a favorites menu. I've done a couple quick mock-ups to show what this could look like.

dr_favorites1.jpg:
 - This seems like the simplest version for an entity favorites menu where you could select an entity and add it to a favorites folder within the create entity structure.

dr_favorites2.jpg:
- This is a more advanced, broader idea where we have a an actual favorites window that pops up. Kind of piggy backing off the layers menu. This would allow you to add anything to it including entities, models, brush groups, func_statics, or prefabs. Im not entirely sure how feasible it would be , but imagine these favorites would be stored in a way where you can access your them across multiple maps within your fm. Color coding and grouping would be a bonus!

dr_favorites3.jpg :
-This is just a better version of what we currently have for textures (which I actually didnt even know about until goldwell told me recently) where the texture favorites are stored in a menu within the thumbnail view of textures.

TagsNo tags attached.

Activities

kingsal

kingsal

13.01.2020 20:35

developer  

dr_favorites2.JPG (43,691 bytes)   
dr_favorites2.JPG (43,691 bytes)   
dr_favorites3.JPG (117,328 bytes)   
dr_favorites3.JPG (117,328 bytes)   
dr_favorites1.jpg (145,548 bytes)   
dr_favorites1.jpg (145,548 bytes)   

Related Changesets

DarkRadiant: favourites a4877474

2020-12-26 16:18:38

greebo

Details Diff
0005127: Add interfaces for managing favourite resources in a central manager class Affected Issues
0005127
add - include/idecltypes.h Diff File
add - include/ifavourites.h Diff File
mod - tools/msvc/include.vcxproj Diff File

DarkRadiant: favourites 55b012a7

2020-12-26 16:42:17

greebo

Details Diff
0005127: Add implementing FavouritesManager module Affected Issues
0005127
mod - radiantcore/CMakeLists.txt Diff File
add - radiantcore/decl/FavouritesManager.cpp Diff File
add - radiantcore/decl/FavouritesManager.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: favourites 86ac1713

2020-12-27 06:21:21

greebo

Details Diff
0005127: More FavouritesManager implementation. Add legacy loading code to import MediaBrowser favourites that have been stored in a different XPath up to v2.10. Affected Issues
0005127
add - radiantcore/decl/FavouriteSet.h Diff File
mod - radiantcore/decl/FavouritesManager.cpp Diff File
mod - radiantcore/decl/FavouritesManager.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: favourites 8be6c5e6

2020-12-27 06:22:16

greebo

Details Diff
0005127: Migrate MediaBrowser to use the new Favourites manager. Affected Issues
0005127
mod - radiant/ui/mediabrowser/MediaBrowser.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.h Diff File

DarkRadiant: favourites 6796334b

2020-12-27 07:18:44

greebo

Details Diff
0005127: Add a few unit test cases covering the add/remove functionality Affected Issues
0005127
mod - radiantcore/decl/FavouritesManager.cpp Diff File
mod - test/CMakeLists.txt Diff File
add - test/Favourites.cpp Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: favourites cf98ee48

2020-12-27 16:37:40

greebo

Details Diff
0005127: Add unit test covering the import of legacy media browser favourites Affected Issues
0005127
mod - test/Favourites.cpp Diff File
add - test/resources/settings/old_mediabrowser_favourites.xml Diff File

DarkRadiant: favourites 83546cd2

2020-12-27 16:51:16

greebo

Details Diff
0005127: Add unit test covering favourites persistence to user.xml Affected Issues
0005127
mod - test/Favourites.cpp Diff File

DarkRadiant: favourites bd2a1b4e

2020-12-27 17:22:54

greebo

Details Diff
0005127: Prepare eclass tree to highlight favourites Affected Issues
0005127
mod - include/idecltypes.h Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - radiantcore/decl/FavouritesManager.cpp Diff File

DarkRadiant: favourites 2864d595

2020-12-27 18:15:38

greebo

Details Diff
0005127: Move common tree view item formatting code to wxutil.
Remove wxutil namespace specifies from EntityClassChooser, it's part of wxutil
Affected Issues
0005127
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
add - libs/wxutil/TreeViewItemStyle.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.cpp Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: favourites c2391a23

2020-12-30 16:17:41

greebo

Details Diff
0005127: Split MediaBrowser's treeview functionality into two classes: ResourceTreeView > MediaBrowserTreeView, with the ResourceTreeView managing the tree along with the context menu and favourite handling. The rest of the MediaBrowser tree functionality has been moved to the MediaBrowserTree, like populating, selection changing, etc.
The idea is to re-use the ResourceTreeView as common base view for EntityClassChooser, SoundSelector, and the other views that display "resources" that support favourites. The EntityClassChooser is WIP in this commit.
Affected Issues
0005127
mod - libs/wxutil/CMakeLists.txt Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
add - libs/wxutil/ResourceTreeView.cpp Diff File
add - libs/wxutil/ResourceTreeView.h Diff File
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.h Diff File
add - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
add - radiant/ui/mediabrowser/MediaBrowserTreeView.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: favourites e643aa60

2021-01-01 16:34:32

greebo

Details Diff
0005127: Move more responsibilities to the ResourceTreeView class. It owns a reference to the TreeModel it's using, and it takes care of setting up the TreeModelFilter according to the selected view mode (show all vs. favourites only). As a benefit, the MediaBrowserTreeView specialisation is becoming slimmer, and the EntityClassChooser can re-use more code. Affected Issues
0005127
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/ResourceTreeView.cpp Diff File
mod - libs/wxutil/ResourceTreeView.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.h Diff File

DarkRadiant: favourites 1c447548

2021-01-02 03:00:57

greebo

Details Diff
0005127: Minor refactoring Affected Issues
0005127
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/ResourceTreeView.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File

DarkRadiant: favourites 50f4751a

2021-01-02 03:20:24

greebo

Details Diff
0005127: Group some wxutil tree view classes in the wxutil/dataview/ folder Affected Issues
0005127
mod - libs/wxutil/CMakeLists.txt Diff File
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/fsview/FileSystemView.h Diff File
mod - libs/wxutil/fsview/Populator.h Diff File
mod - plugins/dm.conversation/CommandEditor.h Diff File
mod - plugins/dm.conversation/ConversationDialog.cpp Diff File
mod - plugins/dm.conversation/ConversationDialog.h Diff File
mod - plugins/dm.conversation/ConversationEditor.h Diff File
mod - plugins/dm.conversation/ConversationEntity.h Diff File
mod - plugins/dm.difficulty/DifficultyEditor.cpp Diff File
mod - plugins/dm.difficulty/DifficultySettings.h Diff File
mod - plugins/dm.editing/AIHeadChooserDialog.h Diff File
mod - plugins/dm.editing/AIVocalSetChooserDialog.h Diff File
mod - plugins/dm.editing/MissionInfoEditDialog.cpp Diff File
mod - plugins/dm.editing/MissionInfoEditDialog.h Diff File
mod - plugins/dm.gui/GuiSelector.cpp Diff File
mod - plugins/dm.gui/GuiSelector.h Diff File
mod - plugins/dm.gui/ReadablePopulator.h Diff File
mod - plugins/dm.gui/ReadableReloader.h Diff File
mod - plugins/dm.gui/XDataSelector.h Diff File
mod - plugins/dm.gui/XdFileChooserDialog.h Diff File
mod - plugins/dm.objectives/ComponentsDialog.h Diff File
mod - plugins/dm.objectives/ObjectiveConditionsDialog.h Diff File
mod - plugins/dm.objectives/ObjectiveEntity.h Diff File
mod - plugins/dm.objectives/ObjectiveEntityFinder.h Diff File
mod - plugins/dm.objectives/ObjectivesEditor.h Diff File
mod - plugins/dm.stimresponse/ClassEditor.h Diff File
mod - plugins/dm.stimresponse/CustomStimEditor.h Diff File
mod - plugins/dm.stimresponse/EffectEditor.cpp Diff File
mod - plugins/dm.stimresponse/ResponseEditor.cpp Diff File
mod - plugins/dm.stimresponse/ResponseEditor.h Diff File
mod - plugins/dm.stimresponse/SREntity.h Diff File
mod - plugins/dm.stimresponse/StimResponse.h Diff File
mod - plugins/dm.stimresponse/StimTypes.cpp Diff File
mod - plugins/dm.stimresponse/StimTypes.h Diff File
mod - plugins/dm.stimresponse/precompiled.h Diff File
mod - radiant/eventmanager/GlobalKeyEventFilter.cpp Diff File
mod - radiant/ui/commandlist/CommandList.h Diff File
mod - radiant/ui/commandlist/CommandListPopulator.h Diff File
mod - radiant/ui/common/EntityChooser.h Diff File
mod - radiant/ui/common/ShaderSelector.cpp Diff File
mod - radiant/ui/common/ShaderSelector.h Diff File
mod - radiant/ui/common/TexturePreviewCombo.cpp Diff File
mod - radiant/ui/eclasstree/EClassTree.h Diff File
mod - radiant/ui/eclasstree/EClassTreeBuilder.cpp Diff File
mod - radiant/ui/eclasstree/EClassTreeBuilder.h Diff File
mod - radiant/ui/einspector/AddPropertyDialog.cpp Diff File
mod - radiant/ui/einspector/AddPropertyDialog.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File
mod - radiant/ui/einspector/SkinChooser.cpp Diff File
mod - radiant/ui/einspector/SkinChooser.h Diff File
mod - radiant/ui/entitylist/EntityList.cpp Diff File
mod - radiant/ui/entitylist/GraphTreeModel.h Diff File
mod - radiant/ui/entitylist/GraphTreeNode.h Diff File
mod - radiant/ui/filters/editor/FilterDialog.h Diff File
mod - radiant/ui/mapinfo/EntityInfoTab.h Diff File
mod - radiant/ui/mapinfo/LayerInfoTab.h Diff File
mod - radiant/ui/mapinfo/ModelInfoTab.h Diff File
mod - radiant/ui/mapinfo/ShaderInfoTab.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.h Diff File
mod - radiant/ui/modelselector/MaterialsList.h Diff File
mod - radiant/ui/modelselector/ModelDataInserter.h Diff File
mod - radiant/ui/modelselector/ModelPopulator.h Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File
mod - radiant/ui/mousetool/ToolMappingDialog.cpp Diff File
mod - radiant/ui/mousetool/ToolMappingDialog.h Diff File
mod - radiant/ui/particles/ParticleEditor.h Diff File
mod - radiant/ui/particles/ParticlesChooser.cpp Diff File
mod - radiant/ui/particles/ParticlesChooser.h Diff File
mod - radiant/uimanager/SoundChooser.cpp Diff File
mod - radiant/uimanager/SoundChooser.h Diff File
mod - radiant/uimanager/SoundShaderPreview.h Diff File
mod - radiant/uimanager/animationpreview/MD5AnimationViewer.h Diff File
mod - radiant/uimanager/colourscheme/ColourSchemeEditor.cpp Diff File
mod - radiant/uimanager/colourscheme/ColourSchemeEditor.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: favourites 4b479e65

2021-01-02 04:47:04

greebo

Details Diff
0005127: Introduce base class for the threaded population helper. Hide the wxThread inheritance from client code. Affected Issues
0005127
add - libs/wxutil/dataview/ResourceTreePopulator.h Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: favourites a8498d4c

2021-01-02 06:01:48

greebo

Details Diff
0005127: Another abstraction to allow for non-threaded populator implementations. The ResourceTreeView is planned to work with the IResourceTreePopulator only. Affected Issues
0005127
add - libs/wxutil/dataview/IResourceTreePopulator.h Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: favourites 44d25016

2021-01-02 06:41:32

greebo

Details Diff
0005127: Migrate ThreadedEntityClassLoader to derive from ThreadedResourceTreePopulator, to remove all the code dealing with wxThread. Affected Issues
0005127
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/dataview/ThreadedResourceTreePopulator.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.h Diff File

DarkRadiant: favourites b75f700c

2021-01-02 07:36:37

greebo

Details Diff
0005127: Remove a bit of unneeded code Affected Issues
0005127
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: favourites 3a7b0130

2021-01-02 09:11:15

greebo

Details Diff
0005127: Fix a crash during shutdown due to _topLevelWindow pointing to a freed resource Affected Issues
0005127
mod - radiant/ui/mainframe/MainFrame.cpp Diff File

DarkRadiant: favourites b13ba221

2021-01-02 09:18:39

greebo

Details Diff
0005127: Fix crashes when destroying Populator objects deriving from ThreadedResourceTreePopulator and introducing their own members.
Due to C++ dtor execution order threads will crash when the base class ThreadedResourceTreePopulator calls Delete().
The 100% solution would be to disallow subclassing from wxThread, but I'd like to keep the abstraction and the code re-use - therefore deriving classes must invoke EnsureStopped in their destructors. If they fail to do so, there's another safety measure in ResourceTreeView to call EnsureStopped before releasing the instance, to give classes a chance to clean up while the hierarchy is still intact.
Affected Issues
0005127
mod - libs/wxutil/dataview/IResourceTreePopulator.h Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - libs/wxutil/dataview/ThreadedResourceTreePopulator.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.h Diff File

DarkRadiant: favourites 06b3bb82

2021-01-02 09:37:31

greebo

Details Diff
0005127: It's easier to break an outer loop with an exception, use this in the MediaBrowserTreeView populator. Affected Issues
0005127
mod - libs/wxutil/dataview/ThreadedResourceTreePopulator.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File

DarkRadiant: favourites e329126f

2021-01-02 09:44:53

greebo

Details Diff
0005127: Move implementation to .cpp file. Affected Issues
0005127
mod - libs/wxutil/CMakeLists.txt Diff File
mod - libs/wxutil/dataview/IResourceTreePopulator.h Diff File
add - libs/wxutil/dataview/ThreadedResourceTreePopulator.cpp Diff File
mod - libs/wxutil/dataview/ThreadedResourceTreePopulator.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: favourites 70c696b7

2021-01-02 09:47:25

greebo

Details Diff
0005127: Adjustments to ThreadedEntityClassLoader Affected Issues
0005127
mod - libs/wxutil/EntityClassChooser.cpp Diff File

DarkRadiant: favourites dbb8f971

2021-01-02 17:33:40

greebo

Details Diff
0005127: More streamlining with regards to TreeModel::PopulationFinishedEvent handling - let this always point to the ResourceTreeView since, move the event handler argument from the Populator constructors to a setter.
Handle item selection after population right in ResourceTreeView.
Affected Issues
0005127
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File
mod - libs/wxutil/dataview/IResourceTreePopulator.h Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - libs/wxutil/dataview/ThreadedResourceTreePopulator.cpp Diff File
mod - libs/wxutil/dataview/ThreadedResourceTreePopulator.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File

DarkRadiant: favourites ebc5c979

2021-01-02 18:08:27

greebo

Details Diff
0005127: Harmonise the method first letter casing in the wxutil classes. When using types deriving from wxWidgets the mixed case is looking weird. Affected Issues
0005127
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.h Diff File

DarkRadiant: favourites 07ee110c

2021-01-02 18:34:53

greebo

Details Diff
0005127: Migrate SoundChooser to use the ResourceTreeView classes Affected Issues
0005127
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - radiant/uimanager/SoundChooser.cpp Diff File
mod - radiant/uimanager/SoundChooser.h Diff File

DarkRadiant: favourites 742890ef

2021-01-02 18:50:30

greebo

Details Diff
0005127: Add option to prepend custom menu items without having to derive from ResourceTreeView right away. Affected Issues
0005127
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File

DarkRadiant: favourites 046963be

2021-01-02 18:51:05

greebo

Details Diff
0005127: Migrate SoundChooser popup menu code Affected Issues
0005127
mod - radiant/uimanager/SoundChooser.cpp Diff File
mod - radiant/uimanager/SoundChooser.h Diff File

DarkRadiant: favourites 1ca3d948

2021-01-03 03:42:08

greebo

Details Diff
0005127: Add methods to enable or disable favourite management features Affected Issues
0005127
mod - include/idecltypes.h Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File

DarkRadiant: favourites feb0af63

2021-01-03 03:45:35

greebo

Details Diff
0005127: Set the correct decl::Type on the existing ResourceTreeView clients Affected Issues
0005127
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiant/uimanager/SoundChooser.cpp Diff File

DarkRadiant: favourites e27bf335

2021-01-03 03:48:24

greebo

Details Diff
0005127: Upgrade the PopupMenu code a bit Affected Issues
0005127
mod - libs/wxutil/menu/PopupMenu.cpp Diff File

DarkRadiant: favourites 8f66a35f

2021-01-03 03:57:19

greebo

Details Diff
0005127: Add a separate ui::MenuItem for separator elements Affected Issues
0005127
mod - libs/wxutil/menu/PopupMenu.cpp Diff File
add - libs/wxutil/menu/SeparatorItem.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: favourites 822bf95b

2021-01-03 04:33:46

greebo

Details Diff
0005127: Free menu items manually if they've been detached from their parent menu Affected Issues
0005127
mod - libs/wxutil/menu/MenuItem.h Diff File
mod - libs/wxutil/menu/SeparatorItem.h Diff File

DarkRadiant: favourites e0e38760

2021-01-03 04:35:17

greebo

Details Diff
0005127: Improve PopupMenu::show method to actually detach hidden items from and attach visible ones to the menu before it is shown Affected Issues
0005127
mod - libs/wxutil/menu/PopupMenu.cpp Diff File
mod - libs/wxutil/menu/PopupMenu.h Diff File

DarkRadiant: favourites 46bd5c92

2021-01-03 04:54:37

greebo

Details Diff
0005127: Expand unit tests to cover the decl::Type::None case Affected Issues
0005127
mod - radiantcore/decl/FavouritesManager.cpp Diff File
mod - test/Favourites.cpp Diff File

DarkRadiant: favourites 0363efdc

2021-01-03 05:03:58

greebo

Details Diff
0005127: Remove a bunch of unused members from EntityClassChooser Affected Issues
0005127
mod - libs/wxutil/EntityClassChooser.cpp Diff File
mod - libs/wxutil/EntityClassChooser.h Diff File

DarkRadiant: favourites 1ea9d7ae

2021-01-03 05:12:29

greebo

Details Diff
0005127: SoundChooser is displaying and remembering the favourites now Affected Issues
0005127
mod - radiant/uimanager/SoundChooser.cpp Diff File
mod - radiantcore/decl/FavouritesManager.cpp Diff File

DarkRadiant: favourites 73b32d02

2021-01-03 05:57:41

greebo

Details Diff
0005127: Selection Change Event handling is available for subclasses now, since it is not trivial to do this for all wx versions. Affected Issues
0005127
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/TreeView.cpp Diff File
mod - libs/wxutil/dataview/TreeView.h Diff File

DarkRadiant: favourites 3cb69757

2021-01-03 06:06:47

greebo

Details Diff
0005127: Linux build fixes Affected Issues
0005127
mod - libs/wxutil/CMakeLists.txt Diff File
mod - radiant/ui/mediabrowser/MediaBrowserTreeView.cpp Diff File
mod - radiantcore/decl/FavouriteSet.h Diff File
mod - radiantcore/decl/FavouritesManager.h Diff File

DarkRadiant: favourites 3e34b690

2021-01-03 08:10:44

greebo

Details Diff
0005127: Move Show All/Favourites radio button to a separate ResourceTreeViewToolbar widget that can be associated to an existing ResourceTreeView. Affected Issues
0005127
add - libs/wxutil/dataview/ResourceTreeViewToolbar.h Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.cpp Diff File
mod - radiant/ui/mediabrowser/MediaBrowser.h Diff File
mod - tools/msvc/wxutillib.vcxproj Diff File
mod - tools/msvc/wxutillib.vcxproj.filters Diff File

DarkRadiant: favourites 8cf632fa

2021-01-03 08:14:51

greebo

Details Diff
0005127: Add ResourceTreeViewToolbar to EntityClassChooser Affected Issues
0005127
mod - libs/wxutil/EntityClassChooser.cpp Diff File

DarkRadiant: favourites 2d95c882

2021-01-03 08:20:29

greebo

Details Diff
0005127: Keep the current selection intact when switching between modes Affected Issues
0005127
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File

DarkRadiant: favourites 2aef0a97

2021-01-03 08:27:09

greebo

Details Diff
0005127: Add ResourceTreeViewToolbar to SoundChooser Affected Issues
0005127
mod - radiant/uimanager/SoundChooser.h Diff File

DarkRadiant: favourites 1a2f05b9

2021-01-03 08:32:33

greebo

Details Diff
0005127: Add ResourceTreeViewToolbar to SoundChooser.
Set path and leafname correct as the ResourceTreeView model expects them.
Affected Issues
0005127
mod - radiant/uimanager/SoundChooser.cpp Diff File

DarkRadiant: favourites df46bf9b

2021-01-03 10:33:52

greebo

Details Diff
0005127: Migrate ModelSelector tree model to use the standard ResourceTreeView::Columns set Affected Issues
0005127
mod - radiant/ui/modelselector/ModelDataInserter.h Diff File
mod - radiant/ui/modelselector/ModelPopulator.h Diff File
mod - radiant/ui/modelselector/ModelSelector.cpp Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File

DarkRadiant: favourites 7a533eb7

2021-01-03 14:39:17

greebo

Details Diff
0005127: Start refactoring the ModelSelector tree towards ResourceTreeView. Affected Issues
0005127
mod - include/idecltypes.h Diff File
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - radiant/ui/modelselector/ModelDataInserter.h Diff File
mod - radiant/ui/modelselector/ModelPopulator.h Diff File
mod - radiant/ui/modelselector/ModelSelector.cpp Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File
add - radiant/ui/modelselector/ModelTreeView.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: favourites 28b719d5

2021-01-03 14:59:23

greebo

Details Diff
0005127: Prevent exceptions when trying to access empty columns values on data view items.
This can happen if the tree model filter function is accessing columns on items that are created by the ResourceTreeView base class, which is unaware of those columns.
Affected Issues
0005127
mod - libs/wxutil/dataview/TreeModel.h Diff File

DarkRadiant: favourites a8037439

2021-01-03 14:59:51

greebo

Details Diff
0005127: More ModelSelector WIP code Affected Issues
0005127
mod - radiant/ui/modelselector/ModelSelector.cpp Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File
mod - radiant/ui/modelselector/ModelTreeView.h Diff File

DarkRadiant: favourites c316105c

2021-01-03 16:01:24

greebo

Details Diff
0005127: Migrate ModelPopulator to derive from ThreadedResourceTreePopulator.
Move progress message handling to ResourceTreeView class - we need more control about when we need to clear that item.
Affected Issues
0005127
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - libs/wxutil/dataview/ThreadedResourceTreePopulator.cpp Diff File
mod - libs/wxutil/dataview/ThreadedResourceTreePopulator.h Diff File
mod - radiant/ui/modelselector/ModelPopulator.h Diff File
mod - radiant/ui/modelselector/ModelSelector.cpp Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File
mod - radiant/ui/modelselector/ModelTreeView.h Diff File

DarkRadiant: favourites bac0f6fd

2021-01-03 16:04:43

greebo

Details Diff
0005127: Refresh the view when the filter condition changes Affected Issues
0005127
mod - radiant/ui/modelselector/ModelTreeView.h Diff File

DarkRadiant: favourites 9256d995

2021-01-03 16:55:21

greebo

Details Diff
0005127: Create a separate event to give client code a chance to react when the tree model population is done Affected Issues
0005127
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File
mod - radiant/ui/modelselector/ModelSelector.cpp Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File

DarkRadiant: favourites fd9ad932

2021-01-03 17:17:24

greebo

Details Diff
0005127: Make the ModelSelector display its favourites correctly Affected Issues
0005127
mod - radiant/ui/modelselector/ModelDataInserter.h Diff File
mod - radiant/ui/modelselector/ModelSelector.cpp Diff File
mod - radiant/ui/modelselector/ModelTreeView.h Diff File
mod - radiant/uimanager/SoundChooser.cpp Diff File

DarkRadiant: favourites 912b0cc4

2021-01-03 17:25:52

greebo

Details Diff
0005127: Persist model favourites to registry Affected Issues
0005127
mod - radiantcore/decl/FavouritesManager.cpp Diff File

DarkRadiant: favourites 265953d5

2021-01-03 18:01:46

greebo

Details Diff
0005127: TreeModel columns is owned by the ModelTreeView class now. Move stuff to .cpp file. Affected Issues
0005127
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/modelselector/ModelDataInserter.h Diff File
mod - radiant/ui/modelselector/ModelPopulator.h Diff File
mod - radiant/ui/modelselector/ModelSelector.cpp Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File
add - radiant/ui/modelselector/ModelTreeView.cpp Diff File
mod - radiant/ui/modelselector/ModelTreeView.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: favourites d0a97905

2021-01-03 18:11:03

greebo

Details Diff
0005127: Progress message handling Affected Issues
0005127
mod - libs/wxutil/dataview/ResourceTreeView.cpp Diff File
mod - libs/wxutil/dataview/ResourceTreeView.h Diff File

DarkRadiant: favourites 0a0c7850

2021-01-03 19:08:06

greebo

Details Diff
0005127: Migrate ParticlesChooser Affected Issues
0005127
mod - include/idecltypes.h Diff File
mod - radiant/ui/particles/ParticlesChooser.cpp Diff File
mod - radiant/ui/particles/ParticlesChooser.h Diff File

DarkRadiant: favourites 1236c92c

2021-01-03 19:09:14

greebo

Details Diff
0005127: Persist favourite particle defs Affected Issues
0005127
mod - radiantcore/decl/FavouritesManager.cpp Diff File

DarkRadiant: favourites d631f9db

2021-01-04 02:14:34

greebo

Details Diff
0005127: There's no real benefit in the ParticlesChooser being a static singleton, convert it to a regular instantiable dialog. Affected Issues
0005127
mod - radiant/ui/particles/ParticlesChooser.cpp Diff File
mod - radiant/ui/particles/ParticlesChooser.h Diff File

DarkRadiant: favourites 5b0f8224

2021-01-04 03:39:09

greebo

Details Diff
0005127: Add toggle button to TextureBrowser to filter out non-favourites Affected Issues
0005127
add - install/bitmaps/favourite.png Diff File
mod - install/user.xml Diff File
mod - radiant/ui/texturebrowser/TextureBrowser.cpp Diff File
mod - radiant/ui/texturebrowser/TextureBrowser.h Diff File
mod - radiant/ui/texturebrowser/TextureBrowserManager.cpp Diff File

DarkRadiant: favourites 16f8cdf7

2021-01-04 03:47:56

greebo

Details Diff
0005127: Introduce signals to subscribe to when a favourite set is modified Affected Issues
0005127
mod - include/ifavourites.h Diff File
mod - radiantcore/decl/FavouriteSet.h Diff File
mod - radiantcore/decl/FavouritesManager.cpp Diff File
mod - radiantcore/decl/FavouritesManager.h Diff File

DarkRadiant: favourites d2f55f43

2021-01-04 03:54:04

greebo

Details Diff
0005127: TextureBrowser is notified on favourite changes Affected Issues
0005127
mod - radiant/ui/texturebrowser/TextureBrowser.cpp Diff File
mod - radiant/ui/texturebrowser/TextureBrowser.h Diff File

DarkRadiant: favourites 61104d5a

2021-01-04 04:01:48

greebo

Details Diff
0005127: Add unit test coverage for changed signals - and adjust the implementation Affected Issues
0005127
mod - radiantcore/decl/FavouritesManager.cpp Diff File
mod - test/Favourites.cpp Diff File

DarkRadiant: favourites b64c1714

2021-01-04 04:04:30

greebo

Details Diff
0005127: Another unit test case Affected Issues
0005127
mod - test/Favourites.cpp Diff File

DarkRadiant: favourites_gui 3aca4dec

2021-01-06 04:58:15

greebo

Details Diff
0005127: Add Favourites tab to Group Dialog listing the various types of favourites Affected Issues
0005127
mod - include/igroupdialog.h Diff File
mod - radiant/CMakeLists.txt Diff File
add - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
add - radiant/ui/favourites/FavouritesBrowser.h Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File

DarkRadiant: favourites_gui 1e31563f

2021-01-06 05:23:22

greebo

Details Diff
0005127: Add toolbar to show/hide the favourite types. Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: favourites_gui 41ce6152

2021-01-06 05:34:15

greebo

Details Diff
0005127: Add command to toggle the favourites browser in the group dialog. Refactoring. Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: favourites_gui f27e9f0b

2021-01-06 06:19:07

greebo

Details Diff
0005127: Add toggle to show/hide the full path Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: favourites_gui 69e799d4

2021-01-06 06:31:52

greebo

Details Diff
0005127: Subscribe to favourite changes to update the list Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: favourites_gui 67a1290f

2021-01-06 06:38:06

greebo

Details Diff
0005127: Rebuild the control lazily when favourites get updated Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: favourites_gui 7ea6e7db

2021-01-06 13:39:12

greebo

Details Diff
0005127: Implement context menu with a "Remove from Favourites" option.
Since the wxListView items cannot store much apart from the name, the FavouritesBrowser needs to keep a local shadow structure in memory to save the info we need for removing the items from the favourites set.
Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: favourites_gui 6d0b0e17

2021-01-09 04:28:55

greebo

Details Diff
0005127: Add "Apply to selection" item for textures Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: favourites_gui 536ccfdb

2021-01-09 05:06:52

greebo

Details Diff
0005127: Handle double clicks on items (textures only at this point) Affected Issues
0005127
mod - include/version.h Diff File
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: master 69e2c461

2021-01-15 11:58:44

greebo

Details Diff
0005127: Fix Linux compilation Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: master f8ce09db

2021-01-24 11:38:57

greebo

Details Diff
0005127: Double-clicking a favourite entity class will attempt to create it. Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: master 4518031e

2021-01-24 16:28:02

greebo

Details Diff
0005127: Move the algorithm to create a speaker to the core module, add corresponding "CreateSpeaker" command. Affected Issues
0005127
mod - radiant/ui/ortho/OrthoContextMenu.cpp Diff File
mod - radiantcore/entity/EntityModule.cpp Diff File
add - radiantcore/entity/algorithm/Speaker.h Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: master f19486d1

2021-01-24 16:32:51

greebo

Details Diff
0005127: Add "Create Speaker" context menu options to favourites browser Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: master 790c29d6

2021-01-24 17:23:23

greebo

Details Diff
0005127: Add context menu option to apply the sound shader to selected entities (WIP) Affected Issues
0005127
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

DarkRadiant: master 6b7edd3a

2021-01-24 17:53:55

greebo

Details Diff
0005127: Implement the "Apply Sound to Selection" algorithm Affected Issues
0005127
mod - libs/entitylib.h Diff File
mod - radiant/ui/favourites/FavouritesBrowser.cpp Diff File
mod - radiant/ui/favourites/FavouritesBrowser.h Diff File

Issue History

Date Modified Username Field Change
13.01.2020 20:35 kingsal New Issue
13.01.2020 20:35 kingsal File Added: dr_favorites2.JPG
13.01.2020 20:35 kingsal File Added: dr_favorites3.JPG
13.01.2020 20:35 kingsal File Added: dr_favorites1.jpg
13.01.2020 21:05 kingsal Category General => Map Editing
13.01.2020 21:05 kingsal Description Updated View Revisions
14.01.2020 03:30 greebo Summary DR Favorites menu => Managing favorite resources (entities, textures,...)
14.01.2020 03:30 greebo Status new => acknowledged
27.12.2020 06:26 greebo Status acknowledged => confirmed
27.12.2020 06:26 greebo Assigned To => greebo
27.12.2020 06:26 greebo Status confirmed => assigned
27.12.2020 06:33 greebo Target Version => 2.11.0
27.12.2020 18:16 greebo Changeset attached => DarkRadiant favourites a4877474
27.12.2020 18:16 greebo Changeset attached => DarkRadiant favourites 55b012a7
27.12.2020 18:16 greebo Changeset attached => DarkRadiant favourites 86ac1713
27.12.2020 18:16 greebo Changeset attached => DarkRadiant favourites 8be6c5e6
27.12.2020 18:16 greebo Changeset attached => DarkRadiant favourites 6796334b
27.12.2020 18:16 greebo Changeset attached => DarkRadiant favourites cf98ee48
27.12.2020 18:16 greebo Changeset attached => DarkRadiant favourites 83546cd2
27.12.2020 18:16 greebo Changeset attached => DarkRadiant favourites bd2a1b4e
27.12.2020 18:16 greebo Changeset attached => DarkRadiant favourites 2864d595
30.12.2020 16:25 greebo Changeset attached => DarkRadiant favourites c2391a23
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites e643aa60
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites 1c447548
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites 50f4751a
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites 4b479e65
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites a8498d4c
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites 44d25016
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites b75f700c
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites 3a7b0130
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites b13ba221
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites 06b3bb82
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites e329126f
02.01.2021 09:47 greebo Changeset attached => DarkRadiant favourites 70c696b7
02.01.2021 18:52 greebo Changeset attached => DarkRadiant favourites dbb8f971
02.01.2021 18:52 greebo Changeset attached => DarkRadiant favourites ebc5c979
02.01.2021 18:52 greebo Changeset attached => DarkRadiant favourites 07ee110c
02.01.2021 18:52 greebo Changeset attached => DarkRadiant favourites 742890ef
02.01.2021 18:52 greebo Changeset attached => DarkRadiant favourites 046963be
03.01.2021 04:54 greebo Changeset attached => DarkRadiant favourites 1ca3d948
03.01.2021 04:54 greebo Changeset attached => DarkRadiant favourites feb0af63
03.01.2021 04:54 greebo Changeset attached => DarkRadiant favourites e27bf335
03.01.2021 04:54 greebo Changeset attached => DarkRadiant favourites 8f66a35f
03.01.2021 04:54 greebo Changeset attached => DarkRadiant favourites 822bf95b
03.01.2021 04:54 greebo Changeset attached => DarkRadiant favourites e0e38760
03.01.2021 04:54 greebo Changeset attached => DarkRadiant favourites 46bd5c92
03.01.2021 05:57 greebo Changeset attached => DarkRadiant favourites 0363efdc
03.01.2021 05:57 greebo Changeset attached => DarkRadiant favourites 1ea9d7ae
03.01.2021 05:57 greebo Changeset attached => DarkRadiant favourites 73b32d02
03.01.2021 06:06 greebo Changeset attached => DarkRadiant favourites 3cb69757
03.01.2021 08:36 greebo Changeset attached => DarkRadiant favourites 3e34b690
03.01.2021 08:36 greebo Changeset attached => DarkRadiant favourites 8cf632fa
03.01.2021 08:36 greebo Changeset attached => DarkRadiant favourites 2d95c882
03.01.2021 08:36 greebo Changeset attached => DarkRadiant favourites 2aef0a97
03.01.2021 08:36 greebo Changeset attached => DarkRadiant favourites 1a2f05b9
03.01.2021 17:27 greebo Changeset attached => DarkRadiant favourites df46bf9b
03.01.2021 17:27 greebo Changeset attached => DarkRadiant favourites 7a533eb7
03.01.2021 17:28 greebo Changeset attached => DarkRadiant favourites 28b719d5
03.01.2021 17:28 greebo Changeset attached => DarkRadiant favourites a8037439
03.01.2021 17:28 greebo Changeset attached => DarkRadiant favourites c316105c
03.01.2021 17:28 greebo Changeset attached => DarkRadiant favourites bac0f6fd
03.01.2021 17:28 greebo Changeset attached => DarkRadiant favourites 9256d995
03.01.2021 17:28 greebo Changeset attached => DarkRadiant favourites fd9ad932
03.01.2021 17:28 greebo Changeset attached => DarkRadiant favourites 912b0cc4
03.01.2021 18:01 greebo Changeset attached => DarkRadiant favourites 265953d5
03.01.2021 19:09 greebo Changeset attached => DarkRadiant favourites d0a97905
03.01.2021 19:09 greebo Changeset attached => DarkRadiant favourites 0a0c7850
03.01.2021 19:09 greebo Changeset attached => DarkRadiant favourites 1236c92c
04.01.2021 04:02 greebo Changeset attached => DarkRadiant favourites d631f9db
04.01.2021 04:02 greebo Changeset attached => DarkRadiant favourites 5b0f8224
04.01.2021 04:02 greebo Changeset attached => DarkRadiant favourites 16f8cdf7
04.01.2021 04:02 greebo Changeset attached => DarkRadiant favourites d2f55f43
04.01.2021 04:02 greebo Changeset attached => DarkRadiant favourites 61104d5a
04.01.2021 04:04 greebo Changeset attached => DarkRadiant favourites b64c1714
06.01.2021 14:00 greebo Changeset attached => DarkRadiant favourites_gui 3aca4dec
06.01.2021 14:00 greebo Changeset attached => DarkRadiant favourites_gui 1e31563f
06.01.2021 14:00 greebo Changeset attached => DarkRadiant favourites_gui 41ce6152
06.01.2021 14:00 greebo Changeset attached => DarkRadiant favourites_gui f27e9f0b
06.01.2021 14:00 greebo Changeset attached => DarkRadiant favourites_gui 69e799d4
06.01.2021 14:00 greebo Changeset attached => DarkRadiant favourites_gui 67a1290f
06.01.2021 14:00 greebo Changeset attached => DarkRadiant favourites_gui 7ea6e7db
09.01.2021 05:07 greebo Changeset attached => DarkRadiant favourites_gui 6d0b0e17
09.01.2021 05:07 greebo Changeset attached => DarkRadiant favourites_gui 536ccfdb
15.01.2021 11:59 greebo Changeset attached => DarkRadiant master 69e2c461
16.01.2021 03:21 greebo Status assigned => resolved
16.01.2021 03:21 greebo Resolution open => fixed
16.01.2021 03:21 greebo Fixed in Version => 2.11.0
24.01.2021 18:33 greebo Changeset attached => DarkRadiant master f8ce09db
24.01.2021 18:33 greebo Changeset attached => DarkRadiant master 4518031e
24.01.2021 18:33 greebo Changeset attached => DarkRadiant master f19486d1
24.01.2021 18:33 greebo Changeset attached => DarkRadiant master 790c29d6
24.01.2021 18:33 greebo Changeset attached => DarkRadiant master 6b7edd3a