View Issue Details

IDProjectCategoryView StatusLast Update
0005139The Dark ModDef / Setuppublic21.02.2020 12:28
Reporterstgatilov Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 2.07 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0005139: Renew particle declarations for rain
DescriptionThe current particle declarations for rain are flawed.
Aside from inherent problems, they are also not compatible with currently-implemented collisionStatic keyword.

Here is a brief list of proposed changes:
1)"deform particle" instead of "deform particle2" in materials
2) disable gravity, i.e. set "gravity 0"
3) drop distribution, i.e. set "distribution rect 0.000 0.000 0.000"
4) set constant speed, e.g. "speed 500.000"
5) remove "offset" --- I guess it is not necessary
6) remove "fadeIndex" and bump "color"
7*) remove "fadeOut" and set "fadeIn" to something like 20%
8*) set "orientation aimed" first number to 0.0

Without point 1 particle distribution is not uniform. This applies to ALL particles which are emitted from surfaces!
Without points 2, 3, 4 collisionStatic will not work, so should be fixed for rain.
Point 5 is optional.
Point 6 is questionable: it makes rain more visible even with less particles. Performance is not very good yet.

Point 7 fixes the stupid situation when all particles are always considered "faded", and allows to introduce proper fading in.
Point 8 improve performance two-fold. When the "aimed K" is set, then every particle is rendered as K+1 quads. Since rain goes in straight direction, curved trails are not a problem, so there is no reason to double quads number.
Tagsparticle

Relationships

related to 0004957 resolvedstgatilov Snow and rain particles stopping on brushes 

Activities

stgatilov

stgatilov

21.02.2020 12:28

developer   ~0012234

Done in svn rev 15791.

I have only reworked rain, with three new versions (light, heavy, downpour).
More versions are perhaps not necessary, since mappers will have to copy/paste definitions to use collisionStatic.
I have put the new definitions into new file tdm_weather2.{prt|mtr}.
I hope to look into snow later, when collisionStatic supports it.

Issue History

Date Modified Username Field Change
01.02.2020 05:43 stgatilov New Issue
01.02.2020 05:43 stgatilov Relationship added related to 0004957
01.02.2020 05:44 stgatilov Tag Attached: particle
17.02.2020 14:41 stgatilov Description Updated View Revisions
17.02.2020 17:01 stgatilov Description Updated View Revisions
18.02.2020 15:27 stgatilov Assigned To => stgatilov
18.02.2020 15:27 stgatilov Status new => assigned
21.02.2020 12:28 stgatilov Note Added: 0012234
21.02.2020 12:28 stgatilov Status assigned => resolved
21.02.2020 12:28 stgatilov Resolution open => fixed
21.02.2020 12:28 stgatilov Fixed in Version => TDM 2.08