View Issue Details

IDProjectCategoryView StatusLast Update
0005140DarkRadiantGUIpublic23.04.2020 04:58
ReporterSpooks Assigned Togreebo  
PrioritylowSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.7.0 
Target Version2.8.0Fixed in Version2.8.0 
Summary0005140: ToggleFullScreenCamera does not toggle the full screen camera
DescriptionI believe by default the "ToggleFullScreenCamera" command in the shortcut list is set to F11. It maximizes the 3D viewport when pressed and returns the 2D orthoview/entity pane on another press. This toggle doesn't work in 2.7.0. When pressing F11, the 3D viewport will get maximized but the regular view won't return when the key is pressed again. You have to manually drag them back from the borders of the window.

IMPORTANT: This bug is conditional on your window layout. I'm using Embedded and the bug exists there, where the 3D view gets expanded. However, when:
using "Floating", the 3D viewport gets toggled.
using "Regular", the 2D viewport gets toggled.
using "RegularLeft", the middle border just changes location, the toggle does not work here.
using "SplitPane", the 3D viewport gets toggled.

This means "Embedded" and "RegularLeft" are the two window layouts that the command doesn't work in.
Steps To ReproduceIf "ToggleFullScreenCamera" is not set to a keyboard shortcut, go to Edit > Keyboard Shortcuts... and set one.
If "Embedded" or "RegularLeft" is not your window layout, go to View > Window Layout and change it. Restart DR.
Press the key twice.
Additional InformationTried with other keys besides F11. Other function keys do not work, "A" does not work.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master cc22ed6b

2018-04-25 22:21:31

orbweaver

Details Diff
Remove persistence of EmbeddedLayout pane positions

A bug in the persistence code is causing a progressive shift of the pane
positions with each successive session, moving the splitters to the right and
downwards until the 2D view and group widgets are hardly visible. With this
code disabled, the splitters are left at their default position, which (on
Linux at least) seems to be 50% of the widget size. This is not optimal but at
least is consistent between sessions.
Affected Issues
0005140
mod - radiant/ui/mainframe/EmbeddedLayout.cpp Diff File
mod - radiant/ui/mainframe/EmbeddedLayout.h Diff File

DarkRadiant: master bd5abeed

2020-04-23 04:38:53

greebo

Details Diff
0005140: Fix ToggleFullscreenCamera in EmbeddedLayout Affected Issues
0005140
mod - radiant/ui/mainframe/EmbeddedLayout.cpp Diff File
mod - radiant/ui/mainframe/EmbeddedLayout.h Diff File

DarkRadiant: master 92b82769

2020-04-23 04:57:31

greebo

Details Diff
0005140: Fix ToggleFullscreenCamera in Regular and Regular Left layouts Affected Issues
0005140
mod - radiant/ui/mainframe/RegularLayout.cpp Diff File
mod - radiant/ui/mainframe/RegularLayout.h Diff File

Issue History

Date Modified Username Field Change
03.02.2020 09:15 Spooks New Issue
03.02.2020 12:52 greebo Status new => acknowledged
21.04.2020 19:32 greebo Status acknowledged => confirmed
21.04.2020 19:33 greebo Changeset attached => DarkRadiant master cc22ed6b
23.04.2020 04:57 greebo Changeset attached => DarkRadiant master bd5abeed
23.04.2020 04:57 greebo Changeset attached => DarkRadiant master 92b82769
23.04.2020 04:57 greebo Target Version => 2.8.0
23.04.2020 04:57 greebo Assigned To => greebo
23.04.2020 04:57 greebo Status confirmed => assigned
23.04.2020 04:58 greebo Status assigned => resolved
23.04.2020 04:58 greebo Resolution open => fixed
23.04.2020 04:58 greebo Fixed in Version => 2.8.0