View Issue Details

IDProjectCategoryView StatusLast Update
0005148DarkRadiantGUIpublic20.04.2020 11:34
ReporterDragofer Assigned Togreebo  
PrioritylowSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.7.0 
Target Version2.8.0Fixed in Version2.8.0 
Summary0005148: 'Show help' tooltip text updates incorrectly
Description2 very similar issues:

A) Sometimes I want to look at a spawnarg's tooltip and put a tick in the entity inspector's 'Show help' box. The tooltip box pops up at the bottom of the entity inspector, but it has no text. I first have to select a different spawnarg, then come back to the original spawnarg to see the text. Toggling 'Show help' repeatedly will keep showing no tooltip text.

B) When I disable 'Show help' -> select a different spawnarg -> reenable 'Show help', I'm shown the previously shown tooltip contents again. Toggling 'Show help' repeatedly will keep showing the old tooltip contents.
Steps To Reproduce1) Create model -> stagecoach.lwo
"Origin" and "model" both have tooltips, "rotation" doesn't.

Issue A)
2) Select the "origin" spawnarg
3) Enable 'Show help'. A tooltip box appears but it has no text.
4) Select a different spawnarg, then select "origin" again. You're now shown the correct tooltip.

Issue B)
5) Disable 'Show help'.
6) Select a different spawnarg.
7) Enable 'Show help'. You're shown the tooltip of "origin".
TagsNo tags attached.

Activities

Dragofer

Dragofer

09.02.2020 18:43

developer   ~0012187

Issue B is probably the dominant issue and A is just a consequence:
Whenever you enable 'Show help', you're shown the previous tooltip. If you're looking at your first tooltip since opening DR you're shown nothing because there's no previous tooltip yet.

Related Changesets

DarkRadiant: master 296203f6

2020-04-20 11:33:37

greebo

Details Diff
Fix 0005148: Entity Inspector's help text area is not updating its contents when the "Show Help" option is checked. Affected Issues
0005148
mod - radiant/ui/einspector/EntityInspector.cpp Diff File

Issue History

Date Modified Username Field Change
09.02.2020 18:36 Dragofer New Issue
09.02.2020 18:43 Dragofer Note Added: 0012187
14.02.2020 04:14 greebo Status new => acknowledged
20.04.2020 11:24 greebo Status acknowledged => confirmed
20.04.2020 11:33 greebo Assigned To => greebo
20.04.2020 11:33 greebo Status confirmed => assigned
20.04.2020 11:33 greebo Target Version => 2.8.0
20.04.2020 11:34 greebo Changeset attached => DarkRadiant master 296203f6
20.04.2020 11:34 greebo Resolution open => fixed
20.04.2020 11:34 greebo Status assigned => resolved
20.04.2020 11:34 greebo Fixed in Version => 2.8.0