View Issue Details

IDProjectCategoryView StatusLast Update
0005166DarkRadiantMap Editingpublic08.11.2020 18:34
ReporterLDAsh Assigned Togreebo  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Fixed in Version2.8.0 
Summary0005166: Fixed Subdivisions higher than 32
DescriptionAbility for "Fixed Subdivisions" of "Patch Tesselation" in "Patch Inspector" to be higher than 32, or at least not cap patches back to 32. NetRadiant can currently load map files with higher values even though the GUI still says 32. I managed to get up to 4444 4444 which was many millions of triangles. I think this is a good move to help future-proof the software
Steps To ReproduceSelect patch-mesh
Shift+S
"Fixed Subdivisions"
Additional Informationor import a MAP that has higher values than 32 and DR won't display it correctly.
TagsNo tags attached.

Activities

greebo

greebo

06.04.2020 18:20

administrator   ~0012334

Is this something related to a specific game? Can an idTech engine handle such high values properly?
If yes, I'd be inclined to make the maximum configurable through the settings in the .game file.
LDAsh

LDAsh

10.04.2020 20:30

reporter   ~0012350

With Quake IV, Radiant complains about the subdivisions exceeding 32, but (anyway) will actually display, save, and "dmap" successfully, and the patches do show up in the game properly. It's sluggish, but using DR with other newer engines using LOD, numbers like 32 quickly become trivial.
LDAsh

LDAsh

10.04.2020 20:51

reporter   ~0012351

Please see here for evidence:-
https://www.violae.net/temp/Q4patchtess64.jpg
greebo

greebo

11.04.2020 03:03

administrator   ~0012352

Ok, I'd go for making this limit a configurable value in the .game file and set the Q4 game to, I don't know, 128 maybe? Would this be ok for your needs?
(Not sure if such high subdivision values make any difference in the game visually, can it get any smoother?)
LDAsh

LDAsh

11.04.2020 12:17

reporter   ~0012353

No offense, but, every generation says this... The answer is yes, it definitely can. Imagine if this were a giant silo.
Quake IV itself probably won't ever need more than 32, but our game project already needs it, because of heavy use of vertex-buffer LOD.
DarkRadiant is the only (idTech4) Radiant that currently forces these tessellations to 32, even if the patchDef3 has a higher value.
greebo

greebo

12.04.2020 03:14

administrator   ~0012357

The upper limit in the code has been removed now. The UI will restrict this to 16384 subdivisions for X and Y, respectively.

(Setting this to 2048x2048 on a cylinder sent DR into a hang on my end. When lowered to 1024 it was rendering in DR, but TDM crashed on dmapping.)

Related Changesets

DarkRadiant: master 38149679

2020-04-12 03:10:53

greebo

Details Diff
0005166: Remove the limit of 32 fixed subdivisions on patches. The limit is now at 16384, imposed by the patch inspector UI, not the code, just edit the .XRC file to change this limit. Affected Issues
0005166
mod - install/ui/patchinspector.fbp Diff File
mod - install/ui/patchinspector.xrc Diff File
mod - radiant/patch/Patch.cpp Diff File
mod - radiant/ui/patch/PatchInspector.h Diff File

Issue History

Date Modified Username Field Change
01.03.2020 12:08 LDAsh New Issue
06.04.2020 18:20 greebo Status new => feedback
06.04.2020 18:20 greebo Note Added: 0012334
10.04.2020 20:30 LDAsh Note Added: 0012350
10.04.2020 20:30 LDAsh Status feedback => new
10.04.2020 20:51 LDAsh Note Added: 0012351
11.04.2020 03:03 greebo Note Added: 0012352
11.04.2020 12:17 LDAsh Note Added: 0012353
11.04.2020 15:54 greebo Status new => acknowledged
12.04.2020 03:09 greebo Assigned To => greebo
12.04.2020 03:09 greebo Status acknowledged => assigned
12.04.2020 03:12 greebo Changeset attached => DarkRadiant master 38149679
12.04.2020 03:14 greebo Status assigned => resolved
12.04.2020 03:14 greebo Resolution open => fixed
12.04.2020 03:14 greebo Fixed in Version => 2.8.0
12.04.2020 03:14 greebo Note Added: 0012357
08.11.2020 18:34 greebo Status resolved => closed