View Issue Details

IDProjectCategoryView StatusLast Update
0005168DarkRadiantMap Editingpublic19.04.2020 18:08
ReporterDragofer Assigned Togreebo  
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.7.0 
Target Version2.8.0Fixed in Version2.8.0 
Summary0005168: Autosaves don't save last camera angle & position
DescriptionUsually when you load a map the camera should be in the position it was at when the map was saved. However, autosaves don't save this information, so the camera always starts back at the centre of the map.
Steps To Reproduce1) Open a map, move the camera to a certain position, make a change and wait for an autosave to occur.
2) Close the map and open the autosaved map. The camera starts at the default position.

Optionally open the original .map and the autosaved .map in a text editor. The autosaved .map doesn't contain these 2 lines at the start:
"editor_drLastCameraPos" "755.801 -237.987 -12.9453"
"editor_drLastCameraAngle" "-5.4 46.375 0"
Additional InformationAncient bug.
TagsNo tags attached.

Relationships

related to 0005220 resolvedgreebo Resized Models lose their scale in auto-saved maps 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 3e5f9117

2020-04-16 03:43:41

greebo

Details Diff
0005168: Move last camera position save/restore code to MapPositionManager and tie it to the MapEvent listener. Affected Issues
0005168
mod - radiant/map/Map.cpp Diff File
mod - radiant/map/Map.h Diff File
mod - radiant/map/MapPositionManager.cpp Diff File
mod - radiant/map/MapPositionManager.h Diff File

DarkRadiant: master 91069c01

2020-04-19 10:06:07

greebo

Details Diff
0005168: Fix map properties not being saved after deserialising Affected Issues
0005168
mod - radiant/map/MapPropertyInfoFileModule.cpp Diff File

DarkRadiant: master bba97e39

2020-04-19 10:09:01

greebo

Details Diff
0005168: Change MapPosition class to store properties to the map root's property bag immediately. DR no longer stores the map position as dummy spawnargs to the worldspawn, since we now have a property store in the map root to hold them. Legacy key values found on worldspawn are automatically converted to root properties on map load.
Add events to MapExport class to be able to inject data to the exported scene, regardless of the format or what type of scene is exported.
Affected Issues
0005168
mod - radiant/map/Map.cpp Diff File
mod - radiant/map/MapPosition.cpp Diff File
mod - radiant/map/MapPosition.h Diff File
mod - radiant/map/MapPositionManager.cpp Diff File
mod - radiant/map/MapPositionManager.h Diff File
mod - radiant/map/MapResource.cpp Diff File
mod - radiant/map/MapResource.h Diff File
mod - radiant/map/algorithm/MapExporter.cpp Diff File
mod - radiant/map/algorithm/MapExporter.h Diff File

DarkRadiant: master a885384d

2020-04-19 10:41:52

greebo

Details Diff
0005168: Move last camera position storage location to the map root Affected Issues
0005168
mod - radiant/map/MapPositionManager.cpp Diff File
mod - radiant/map/MapPositionManager.h Diff File

DarkRadiant: master 4489ccdb

2020-04-19 15:53:24

greebo

Details Diff
0005168: Move export signals to IMapResourceManager interface. Affected Issues
0005168
mod - include/imapresource.h Diff File
mod - radiant/map/Map.cpp Diff File
mod - radiant/map/MapPositionManager.cpp Diff File
mod - radiant/map/MapPositionManager.h Diff File
mod - radiant/map/MapResourceManager.cpp Diff File
mod - radiant/map/MapResourceManager.h Diff File
mod - radiant/map/algorithm/MapExporter.cpp Diff File
mod - radiant/map/algorithm/MapExporter.h Diff File

DarkRadiant: master 5cd0e304

2020-04-19 16:26:41

greebo

Details Diff
0005168: Ensure that up-to-date edit timings are written to automatic saves. Affected Issues
0005168
mod - radiant/map/EditingStopwatch.cpp Diff File
mod - radiant/map/EditingStopwatch.h Diff File

Issue History

Date Modified Username Field Change
04.03.2020 18:39 Dragofer New Issue
07.03.2020 06:20 greebo Status new => acknowledged
09.04.2020 15:51 greebo Status acknowledged => confirmed
16.04.2020 03:44 greebo Changeset attached => DarkRadiant master 3e5f9117
19.04.2020 16:27 greebo Changeset attached => DarkRadiant master 5cd0e304
19.04.2020 16:27 greebo Changeset attached => DarkRadiant master 4489ccdb
19.04.2020 16:27 greebo Changeset attached => DarkRadiant master a885384d
19.04.2020 16:27 greebo Changeset attached => DarkRadiant master bba97e39
19.04.2020 16:28 greebo Changeset attached => DarkRadiant master 91069c01
19.04.2020 16:32 greebo Assigned To => greebo
19.04.2020 16:32 greebo Status confirmed => assigned
19.04.2020 16:32 greebo Target Version => 2.8.0
19.04.2020 17:01 greebo Status assigned => resolved
19.04.2020 17:01 greebo Resolution open => fixed
19.04.2020 17:01 greebo Fixed in Version => 2.8.0
19.04.2020 18:08 greebo Relationship added related to 0005220