View Issue Details

IDProjectCategoryView StatusLast Update
0005187The Dark ModModelspublic28.03.2020 15:22
ReporterDragofer Assigned ToDragofer  
PrioritynormalSeveritynormalReproducibilityN/A
Status closedResolutionreopened 
Product VersionTDM 2.07 
Summary0005187: Missing tabletops for rtable1 and endtable_round01
DescriptionBoth these tables have no valid materials for their table tops.
TagsNo tags attached.

Relationships

related to 0005188 resolvedgreebo DarkRadiant DR can't find materials whose names start with table 

Activities

Dragofer

Dragofer

19.03.2020 18:12

developer   ~0012285

Fixed in Rev 15855
VanishedOne

VanishedOne

20.03.2020 03:07

developer   ~0012286

I've reopened this because I think it may actually be a DR bug.

table_medallion works fine in TDM if you drop rtable1.lwo into a map; but DR fails to find the material, even though it *is* declared in tdm_models_furniture_tables.mtr. And it turns out DR won't find this either:

table_test
{
    diffusemap _white
}

Whereas it will find this:

ttable_test
{
    diffusemap _white
}

So my hunch is that DR's .mtr parsing code, since it needs to skip table declarations, skips *any* name that begins with the string 'table'.

Thoughts?
Dragofer

Dragofer

20.03.2020 13:58

developer   ~0012287

Last edited: 20.03.2020 14:07

View 3 revisions

Thanks VanishedOne for isolating the bug, I'll open a report for greebo in the DR section and close this one. I've reverted to the original table models and instead took the opportunity to make the following revision:

Rev 15856
Created rtable1b skin to match the rtable2b skin
Created plainwood skin with medallion to match default skin with medallion
Increased poly count of tabletop for roundness (+60 polys)
Removed internal faces and added missing bottom faces in table legs
Dragofer

Dragofer

22.03.2020 13:10

developer   ~0012293

Reopen to remove from 2.08 roadmap

Issue History

Date Modified Username Field Change
19.03.2020 18:11 Dragofer New Issue
19.03.2020 18:12 Dragofer Assigned To => Dragofer
19.03.2020 18:12 Dragofer Status new => resolved
19.03.2020 18:12 Dragofer Resolution open => fixed
19.03.2020 18:12 Dragofer Fixed in Version => TDM 2.08
19.03.2020 18:12 Dragofer Note Added: 0012285
20.03.2020 03:07 VanishedOne Status resolved => feedback
20.03.2020 03:07 VanishedOne Resolution fixed => reopened
20.03.2020 03:07 VanishedOne Note Added: 0012286
20.03.2020 13:47 Dragofer Summary Fix missing tabletops of rtable1 and endtable_round01 => Missing tabletops for rtable1 and endtable_round01
20.03.2020 13:47 Dragofer Description Updated View Revisions
20.03.2020 13:58 Dragofer Note Added: 0012287
20.03.2020 13:59 Dragofer Status feedback => closed
20.03.2020 14:02 Dragofer Note Edited: 0012287 View Revisions
20.03.2020 14:07 Dragofer Note Edited: 0012287 View Revisions
22.03.2020 13:10 Dragofer Assigned To Dragofer =>
22.03.2020 13:10 Dragofer Status closed => feedback
22.03.2020 13:10 Dragofer Note Added: 0012293
22.03.2020 13:10 Dragofer Fixed in Version TDM 2.08 =>
22.03.2020 13:10 Dragofer Target Version TDM 2.08 =>
22.03.2020 13:10 Dragofer Assigned To => Dragofer
22.03.2020 13:10 Dragofer Status feedback => closed
28.03.2020 15:22 greebo Relationship added related to 0005188