View Issue Details

IDProjectCategoryView StatusLast Update
0005201The Dark ModAIpublic28.03.2020 23:37
Reporterkingsal Assigned ToSpringheel  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in VersionTDM 2.08 
Summary0005201: 2.08 Ape beasts missing wearables.
DescriptionTwo wearables missing from the ape beasts (both are in volta_wearables.def):

Missing Fruit:
They use a custom "idle_eat" animation where they pull out a strange fruit and eat it. The fruit is custom to volta and either needs to be included as a prop OR switched to an apple or something.

    anim manbeast_idle_eat models/md5/chars/monsters/manbeast/manbeast_idle_eat.md5anim
    {
        no_random_headturning
        ai_no_turn
        
        frame 18 attach volta_strange_fruit_prop apple hand_l
        frame 28 sound_voice tdm_crunch
        frame 33 sound_voice tdm_chew
        frame 38 sound_voice tdm_chew
        frame 44 sound_voice tdm_chew
        frame 44 destroy apple
    }

Missing Mask:
In the apebeast def file there is a head variant with a mask. This mask is custom and is missing from the props def. This is totally optional, but if you guys want to include it its prop_volta_relic_mask in the volta_wearables.def.

//Head variant with mask
entityDef volta_ai_manbeast_mask
{ "editor_usage" "Beast with creepy mask."
    "inherit" "atdm:ai_head_base"
    "model" "manbeast_head"
    
        "def_attach1" "prop_volta_relic_mask"
        "pos_attach1" "velvetcap_1"
        
        //Harder to KO
            "ko_angle_horiz" "110"
            "ko_angle_vert" "180"
            "ko_angle_alert_horiz" "110"
            "ko_angle_alert_vert" "180"
    
        "ko_alert_immune_state" "5" //cannot be KO'd when in Combat

}
Additional InformationI labelled this as a major bug because I think the the missing fruit will throw up a warning in the console and boot people back to the main menu.
TagsNo tags attached.

Activities

Springheel

Springheel

28.03.2020 23:37

administrator   ~0012321

Last edited: 28.03.2020 23:37

View 2 revisions

Fixed this in SVN release branch by commenting out head and switching to movable apple prop.

Issue History

Date Modified Username Field Change
28.03.2020 18:33 kingsal New Issue
28.03.2020 23:37 Springheel Note Added: 0012321
28.03.2020 23:37 Springheel Note Edited: 0012321 View Revisions
28.03.2020 23:37 Springheel Assigned To => Springheel
28.03.2020 23:37 Springheel Status new => resolved
28.03.2020 23:37 Springheel Resolution open => fixed
28.03.2020 23:37 Springheel Fixed in Version => TDM 2.08